Previous 1 2 Next 24 Replies Latest reply: Jul 19, 2010 10:35 AM by dubulous
Adam Albright Level 1 Level 1 (85 points)
When will I learn not to do upgrades while I'm traveling? Sigh...

I'm on the road, and without thinking, clicked "OK" to the upgrade this afternoon. After a while of downloading, backing up, and verifying, eventually things hit a snag with "An error occurred while restoring this iPhone (-402653091)". Restarted the phone, got the message "iTunes was interrupted while restoring", asked if I wanted to continue. That seemed promising, so I said "yes". However, now it continues to just say "An error occurred while restoring this iPhone (-402620415)".

My full back-up is still on my hard drive in ~/Library/iTunes/Mobile\ Backups, and I can do a restore to some "default" OS 4 install (in ~/Library/iTunes/iPhone Software Updates", but after doing the restore, I always still get the same error message when it's actually trying to restore the data.

Sometimes after this, the computer says it doesn't recognize the phone (once, it had to go through ATT activation? I got a message to wait a while during activation, and eventually a message that my iPhone was ready to use- but iTunes was asking whether I wanted to set it up as a new phone, or restore from a backup)

So, it looks like I can get it to a point where it can boot and probably send/receive calls, but my data is hosed, and I can't manage to make it restore from the backup that it made. Ideally I'd find a way to get around the error and restore, since I'm on the road and won't be back on the home computer for a bit. At this point, anything that lets it recognize my phone as an "instance" of my old phone would be good, though.

Hjalp?!?

iPhone 3G, iOS 4, (or trying to use iOS 4, anyway; stuck between 3 and 4)
  • khowell Level 1 Level 1 (0 points)
    I'm having the same problem on my iPhone 3G. I've downloaded the OS4 and I keep getting the -402620415 error. I am getting the iPhone 4 tomorrow, but given this problem I'm a little nervous. Are there any solutions running about?
  • Adam Albright Level 1 Level 1 (85 points)
    I haven't found any... I finally figured out that after doing a restore and letting the phone re-activate with ATT and having iTunes say it doesn't recognize the phone, if I allow it to restore from a backup, I get my non-media files back. But it still asks says every time I connect it that there was an interrupted restore and asks if I want to continue (which obviously leads to an error). Rather than clicking "delete", I'm just canceling for now, in hopes that I discover a way to make the restore succeed.
    (I'm more or less resigned to the idea that I'm just without any media until I get back home and can re-install it from the drive where my music lives... I don't carry all my music with me on the road)
  • UCFJess Level 1 Level 1 (0 points)
    I am having the same issue, but I can't get past it. How can I get my phone to even turn on??
  • Adam Albright Level 1 Level 1 (85 points)
    Oh- my phone turns on just fine (the software was installed fine, it just failed to restore my data and media from the 13gig backup that it made). I'm waiting to delete that backup in case someone knows a way to massage it so that iTunes can use it properly- but until then, my phone does work for calls, and I got back my notes and photos by doing a restore to an older backup...
  • UCFJess Level 1 Level 1 (0 points)
    I think the software was updated ok, I just can't get past the "iTunes was interrupted while restoring..."I either try to keep restoring and I continue to get that message, or if I cancel, iTunes will try to sync my phone but then I get an error about the connection. I tried to restore to original factory default and I got the same original error message. My phone perpetually displays the apple icon, sometimes with or without a progress bar that never progresses.... I can't get out of this stupid cycle!
  • Paulskeldon Level 1 Level 1 (0 points)
    This all happened to me here in the UK: stuck in the reboot cycle. It doesnt even show up in iTunes, crashes iTunes and when it does let iTunes work I get the interruption message and then same error message only with number -402653165

    I tried to get an iPhone 4 this morning (queued from 6am) but they stock so few that hardly anyone got them. I am really really ****** off with Apple: they should have properly tested iOS4 on 3Gs, should stock more 4s in the shops (you can't buy them online here til July) and I don't want to have to get another iPhone 3 with a contract because I want a 4 -- network operator won't help me, apple won't help me and I am now using a really old ***** Samsung phone that makes calls and sends texts... and I am still paying my monthly fee to O2 for my iPhone that iOS4 has rendered useless. I am sooo angry. Thanks for letting me vent!
  • Bashar42 Level 1 Level 1 (0 points)
    I am having almost the exact same issue. Except my error code is (-402653165). Sometimes it also gives me the message that an "unknown error has occurred with 0xE8000065." The phone shows an Apple Icon, sometimes with a progress bar with only a small amount filled in. The phone keeps trying to connect to ITunes (WinXP keeps making the ding sound like a new device has been attached to the computer every time it does), but every time ITunes tries to connect and/or continue to restore it freezes ( listed as Not Responding in Task Manager) or gives me error messages and then a minute later the phone tries to connect again, and this cycle repeats itself over and over again.

    Getting very frustrated! I need the phone to stay in touch with people for work!

    I have WinXP SP3, this started happening after I upgraded to latest version of ITunes (without incident), and then tried to install iOS4.



    Bashar42
  • Adam Albright Level 1 Level 1 (85 points)
    These partial boot issues sound quite different from the one I'd been asking about, in which the phone boots and works fine, but I was simply unable to restore my media and content from the large (13gig) backup that iTunes makes in order to wipe everything and reinstall it. In my case, I just keep getting the message "an error occurred while restoring this iPhone", and everything would probably be fine if I clicked "delete" to delete the backup. But then my media would be gone until I can get back home and have all my files available to re-sync all my playlists.

    Given that I do still have the backup in ~/Library/iTunes/Mobile\ Backups, I was hoping that there was some way to persuade iTunes to use this to restore the media to my phone!
  • Bashar42 Level 1 Level 1 (0 points)
    The errors are related. My guess would be that the problem resides with ITunes 9.2. It won't recognize/connect with the phone (which before upgrading to 9.2 were recognized fine for months). As long as ITunes doesn't properly recognize/connect to the phone, we will be unable to restore our content from the backup. People in my situation have the added problem of not just losing all content, but also having a dead brick for a phone.
  • Adam Albright Level 1 Level 1 (85 points)
    In my case, though, iTunes can connect to the phone just fine- I'm able to restore from a "regular" backup (i.e., with info but no media), I can do new syncs just fine, etc. There was just a problem restoring from the "special mega-backup" that contains all of the media, etc., that iTunes makes when doing an OS update. Since my normal backups (which don't contain all that content) are fine, I was able to restore from one of those. I was just hoping that there might be some way of diagnosing based on the error what's holding up the special "full" restore, though, so I don't have to wait for a couple weeks to get my content back from a regular sync.
  • Adam Albright Level 1 Level 1 (85 points)
    Found the solution! Hooray!
    Noticed a suggestion on this thread:
    http://discussions.info.apple.com/message.jspa?messageID=11731496#11731496

    To look in the ~/Library/iTunes/Mobile\ Backups folder to find the Manifest.plist folder, and delete entries for apps that might be causing the problem.
    I remembered that a little while ago, I had started getting an error message while syncing and updated app (Sleepmaker or something- couldn't remember which, precisely, but knew that it was a white noise app). So, I went to the Manifest.plist folder, and removed the entries for the couple different flavors of the Sleepmaker app that I had installed.

    Then, reconnected the iPhone, and clicked "Continue Restore" once again when it reported that there had been an interrupted restore. This time, it went through fully! Took quite a while (~1 hr) to copy all my media onto the phone, but now it's all there! Hopefully this will help others who might in the same situation...
  • CindyLynn Level 1 Level 1 (0 points)
    Adam: I tried following what you said in regards to the solution and I can't figure out exactly what you are talking about? I am having the same exact problem you were having. Please help..

    Thank you
  • wolso1 Level 1 Level 1 (0 points)
    This is exactly what happened to me- I downloaded iTunes 9.2,then downloaded Ios 4 but then it told me I had to restore my phone which I wasn't happy about but went ahead with. It gets almost to the end of restoring it and then comes up with error 21. Now my phone won't even turn on- just comes up with the apple logo. This is my third phone in two weeks since the last one was faulty. I'm going to the apple store on Monday but until then I have a completely useless phone!
  • zekro Level 1 Level 1 (0 points)
    I have been having the exact same problem. I have searched all over the internet, tried everything Apple and other sites have been saying and nothing works. Ive used separate computers, separate accounts, cables, tried different ITunes versions, tried restoring it back to 3.2 and still get the 21 error.

    This is getting very frustrated....now I have no phone
Previous 1 2 Next