14 Replies Latest reply: Jun 26, 2010 9:08 AM by Karen in AZ
sugurtle Level 1 Level 1 (0 points)
Ok I believe it is an hardware problem, but i need some help to figure it out. Here's the situation: My 2007 macbook pro has no audio, No startup chime, no audio from nowhere. No red light from the jack input. I did an hardware test and everything shows fine. I can control the volume and it displays right, but still no audio. I tried resetting the nram, but nothing. If it help, I remember using audio Hijack to take some audio from a skydive video and shortly after that the audio just didn't come out. It recognizes the internal speakers, i can see them in the settings, but still no audio. Can somebody please help me? I'm going crazy! Thank you guys!

Mac book pro, Mac OS X (10.4.11), Sound problems!
  • CMCSK Level 6 Level 6 (10,600 points)
    I remember using audio Hijack

    culprit that probably changed your settings. Go into the Utilities folder & check your output settings in the Audio Midi app - http://docs.info.apple.com/article.html?artnum=300832



    Open up GarageBand if installed. Open a program.
    Quit out of the GarageBand app.



    Trash the com.apple.systemsound.plist file and restart your computer.
  • sugurtle Level 1 Level 1 (0 points)
    Thanks that was something i didn't check. how to delete the file com.apple.systemsound.plist ?
    here'w what i found in the midi app:
    default in: inner mic, for the output of the system and default it is inner output. on the other screens I have IAC driver, network and anotherone which i removed that was keystation 61 es.
    Is there anything wrong with that? Thank you and sorry for my english, i'm Italian.
    Thanks!
  • sugurtle Level 1 Level 1 (0 points)
    Ok i tried to find the com.apple.systemsound.plist but i can't find that. I found com.apple.soundpref.plist tho, can i mess with that? thanks
  • CMCSK Level 6 Level 6 (10,600 points)
    Apparently Snow Leopard is slightly different than the Tiger OS regarding plist files & the Midi app.
    If the com.apple.systemsound.plist file is inside your Home/Library/Preferences folder, it is ok to trash this file and restart your computer. The plist file will be recreated.

    As far as the Midi app in Tiger, I believe it looks something like this
    !http://www.lexiconpro.com/images/misc/omegaAMsetup.JPG!
    Make sure your *Audio Output* setting has the same Format as the one in the picture - _44100.0 Hz._



    Have you tried the Garage Band solution?
  • sugurtle Level 1 Level 1 (0 points)
    Hi, Yes I tried garage band but still no solution. The Midi app looks just like that but I have the default output on (mac inner output). I really don't get what the problem is!
  • sugurtle Level 1 Level 1 (0 points)
    I'm looking everywere in my mac but can't find the file com.apple.systemsound.plist could that be the problem? I just can't find it even ith finder.
  • sugurtle Level 1 Level 1 (0 points)
    i'm sorry I meant I couldn't find it even with spotlight.
  • Baby Boomer (USofA) Level 9 Level 9 (56,785 points)
    Hmmmmm, that GB trick the privious poster mentioned usually works for problems like yours. Strange!



    Under Tiger it's the com.apple.soundpref.plist file you should be looking for. It's found in.........



    Home>Library>Preferences>com.apple.soundpref.plist



    Below is my Midi app which is a little different from the default settings because I have external speakers hooked up to my comp. Compare yours to mine to find out if any of your settings have changed:
    !http://i46.tinypic.com/2na1nwj.png!
    Change the Audio Input & Output Format to *44100.0 Hz 2ch-16bit*



    *Last resort..........*
    *Disconnect all devices fro*m your computer. Uninstall Audio Hijack. If it comes w/a uninstaller strongly urge you to use it. If not, use one of these utilities:
    AppDelete (free)



    AppZapper (shareware)
    These utilities basically do all the work for you by not only trashing the apps but the apps preference files, caches & all its associated files scattered throughout the system.



    Boot up from your install DVD and run *"Repair Disc"* from the Utility menu.
    After booting back to your desktop, repair permissions & restart your computer.





    !http://i50.tinypic.com/izvwo1.gif!
  • sugurtle Level 1 Level 1 (0 points)
    hi boomer,
    I tried all of that, even to delete the com.apple.soundpref.plist, and after i deleted it, it didn't recreate a new one after restarting. In midiapp When i set the "Properties for - Built in audio", it shows me only the box on the left, and in the right box it says Not supported. I can also choose Built-it output, and in this case It only shows me the right box, leaving the left one saying "Not supported". As a matter of fact, I cannot use "Built-in output" as default input.
    It seems to me that It doesn't read my sound card, but the hardware test didn't show problems. Installing leopard would help this situation? Thanks guys!
  • CMCSK Level 6 Level 6 (10,600 points)
    Installing leopard would help this situation?

    No. You should not upgrade over an os you are having issues with.



    Did you uninstall Hijack?



    Set up a new account. Do you have sound? If you do, we will know your issue is not system wide.
  • sugurtle Level 1 Level 1 (0 points)
    I did and not sound coming out. The thing that worries me is that i have no startup bong either..
  • CMCSK Level 6 Level 6 (10,600 points)
    no startup bong either..

    Not a good sign. Disconnect all peripherals and the power cord, remove the battery. Take a deep breath & count to 60 slowly. Reconnect the power cord and battery and see if the machine starts normally. If it does, you can start connecting all peripherals one at a time.

    If this tactic does not work, disconnect the power cord and hold down the Power button for 5 seconds, then reconnect the power adapter and press the Power Button to turn on the computer.
    If that does not work, time to call AppleCare if you have it. If you don't, go to an Apple Store. The staff there will run a few diagnostic tests to determine if you are having hardware issues.

    Message was edited by: CMCSK
  • sugurtle Level 1 Level 1 (0 points)
    no solved, sorry guys, i think it s time to go to the apple store... sigh...
  • Karen in AZ Level 1 Level 1 (0 points)
    When you say you uninstalled the Audio Hijack program, what exactly did you do? Just trashing the app itself won't clear all of the components the original installer may have left. Perhaps there are other files floating around in your Home->Library folder that could be affecting your sound. Some installer programs also contain an unistall feature...if so, you should use that to make sure everything's removed.

    Also, did you reset your PRAM? You said "nram" but I wasn't sure what you meant. Restart and hold down the Command-Option-P-R keys until you hear at least two start up chimes.

    Hope this helps to save you a trip to the store

    -Karen-