12 Replies Latest reply: Jul 4, 2010 1:54 PM by RodBauer
margaretmay Level 1 Level 1 (0 points)
How do I set my screen saver to not turn on while I'm watching videos? It never used to happen, but today I've been watching a lot of videos - on Hulu desktop, Quicktime, DVD Player - and just when it really gets going, the screen saver kicks on.

There's gotta be a setting for this.

Macbook, Mac OS X (10.6.4)
  • Noiseboy2006 Level 3 Level 3 (905 points)
    I use Caffeine:

    http://lightheadsw.com/caffeine/

    Or you could set up a Hot Corner to disable the screen saver. You can do this from System Preferences/Exposé & Spaces.
  • R C-R Level 6 Level 6 (14,870 points)
    FWIW, my screensaver is set to start after 9 minutes of inactivity & it never starts up while I'm using Hulu Desktop or DVD Player to watch things even several hours long. I do not use any special utilities or hot corner items or anything like that. For me, it just works, at least with these apps.

    You might try creating a temporary new user account for testing & see if the issue persists. If not, something in your normal account's home directory isn't right.

    If you try this test, post back with what happens & perhaps we can figure out the cure.
  • margaretmay Level 1 Level 1 (0 points)
    I set up a new account and set my screen saver to go after 5 minutes of inactvity then started watching something on Hulu, and about 5 minutes in, it kicked on just like on my regular account. This really didn't used to happen ... what do you mean about my home directory?
  • R C-R Level 6 Level 6 (14,870 points)
    Well, weirdly enough, this afternoon I started seeing the same behavior with Hulu Desktop. I don't yet know why. AFAIK, it isn't because of an OS update or any other software addition to my system: two days ago my screen saver would not start during a show & now it does, yet I have not changed anything I can think of.

    If I figure out why this is happening, I will post about it but for now I'm mystified.
  • margaretmay Level 1 Level 1 (0 points)
    thanks - glad to know it's not just me. I'm looking into the problem at Hulu, too - maybe this is all their fault.
  • mattofatto Level 1 Level 1 (10 points)
    I think this is an issue with os x 10.6.4. I use hulu desktop a lot and only saw it happen immediately after the 10.6.4 update. I remember a similar thing happening in an earlier os x update, but it was fixed in a subsequent revision. I don't know why it happens, just that it works before an os x update, and then I get screensaver issues after an update and it persists until some future update. I hope apple fixes this soon.
  • mattofatto Level 1 Level 1 (10 points)
    Oh one more thing... the cursor doesn't disappear any more when in full screen mode. Maybe these things are linked?
  • R C-R Level 6 Level 6 (14,870 points)
    I've noticed the same from time to time with Hulu Desktop: usually the cursor disappears along with the other stuff like the time slider but sometimes it doesn't. I have noticed that it never does if I use the workaround to set a "hot corner" in System preferences > Expose & Spaces to "Disable Screen Saver" & park the cursor there (which is what I'm currently doing to prevent it kicking in) but even without that option enabled I was noticing this 'no-hide' behavior occasionally as early as when 10.6.3 was released, & maybe earlier than that.

    I'm sort of writing all this off to Hulu Desktop for OS X being perpetually in beta, but it is really annoying that sometimes the Screen Saver never kicks in & sometimes it does, & I still have no clue about what is different to cause that.
  • lucaberta Level 1 Level 1 (0 points)
    I have to agree with mattofatto, I applied the 10.6.4 update yesterday and now Hulu Desktop gets interrupted by the standard screen saver even during video playback, something that I had never seen with 10.6.3 or earlier versions including Leopard.

    On the other hand, when browsing the menus in Hulu Desktop, the screen saver would always kick in (even before the 10.6.4 update) when browsing using the infrared remote. So clearly the infrared remote would not reset the screen saver timer.

    Hope we can find a workaround to allow Hulu Desktop to properly disable the screen saver counter.

    Ciao, Luca
  • R C-R Level 6 Level 6 (14,870 points)
    As I said in an earlier post, I'm fairly sure I was not having this problem when I first installed 10.6.4 (or any other Apple update). It was only a few days ago that I first noticed Hulu Desktop getting interrupted with the screensaver (the night following the start of this topic, to be precise), but I installed 10.6.4 on the day it was released, June 16th, almost two weeks ago.

    I am almost certain that several time in the following week I watched programs without touching mouse, keyboard, or IR remote for at least as long as my screensaver was set to startup & never saw that happen.

    I don't know if this means Hulu did something in the last few days or I changed something on my iMac during the same period, or what. I think I still have a clone of my system I made just prior to applying the 10.6.4 update, so if I can find the time to make sure I still have it & test with it, I may be able to learn more. If so, I'll post what I find out.
  • R C-R Level 6 Level 6 (14,870 points)
    OK, I just started up from a clone of my system made just before installing 10.6.4 (& Safari 5, which is a part of that package). The clone has 10.6.3 installed & exactly the same version of Hulu Desktop & everything else on the iMac's normal startup drive as of one hour or so before running the OS update. I ran Hulu Desktop exactly as I have been doing for months & checked a few of the same Hulu items that under 10.6.4 now allow the screensaver to kick in.

    The result: *no difference*. Hulu Desktop now behaves the same way under 10.6.3 & 10.6.4. I'm not sure this means Hulu is doing something different, but I'm sure it is not happening because of 10.6.4.
  • RodBauer Level 1 Level 1 (85 points)
    Same here. I'm still on 10.6.3 here and never had this problem before until now, out of the blue... Didn't really installed or changed anything that I can think of. Hope this is sorted soon...