Previous 1 10 11 12 13 14 Next 338 Replies Latest reply: Jan 3, 2015 9:32 AM by appleornothin Go to original post Branched to a new discussion.
  • GamblingJames Level 1 Level 1 (0 points)

    Hello Everyone.

     

    This is a very simple fix. If you are at an airport, or a hotel and cannot get into the app store,

     

    go to your settings

    go to wifi, choose a network

    click the blue arrow beside the network you are connected too

    go Down to DNS. delete all of the numbers in there and enter 8.8.4.4

    go to search domain and change it to google.com

     

    This will fix your issues.

     

    JR- Former IT Professional

  • Doddster Level 1 Level 1 (0 points)

    Ok here's the thing! I've tried all the things previously posted but nothing worked.  So here's the thing - maybe this just works for me but every time the message "I can't connect to iTunes store" message comes up I have to open the safari browser, type into google search box "I can't connect....blah blah" and when the page loads I just go back to iTunes app store and everything works fine! Don't ow why or how but I'm telling you it's worked every time. Fingers crossed it continues!

  • varkatope Level 1 Level 1 (0 points)

    Yes!

     

    I had the exact same problem as you, jspanglr, and I was also able to solve it by connecting my iPhone 4s to my computer and syncing it to the latest version of iTunes. Crazy.

     

    Thanks!

  • andrearella Level 1 Level 1 (0 points)

    I have the same problem can't get into both ITunes store and app store. After followed yr steps, it works!!! Thank you

  • h2o2wine Level 1 Level 1 (0 points)

    Hey JR,

     

    Awesome advice.  Seems to have gone unnoticed by most, but the concept works on 2 iPxx devices.  Thanks for your help.

     

    -h2o2wine

  • dopelikeaboss Level 1 Level 1 (0 points)

    Have the same issue. Tried connecting to iTunes, but gives me the error message "cannot connect to iTunes store". I have my iPhone 4s. I can access my App store, podcast, and all that. But still can't open my iTunes. Tried it with WiFi and even 3G, still the same issue. Tried syncing it with iTunes on my laptop, works fine. But opening iTunes on my iPhone still gives me the same error message. It's kinda frustrating.

     

    Any help guys?

  • Gquard Level 1 Level 1 (0 points)

    There is obviously different causes for this error. I had to spend the time going through a lot of discussions posts to find the symptoms that matched mine. If you are seeing this error literally every other time (50%) you try and open the App Store, then the fix that japanglr found should fix you problem. It did for me.

    I just purchased a new iPhone 4s and had not connected it to my home pc.  Once I connected it to my pc, updated my iTunes to the latest version, and regestered my new device to my pc's iTunres, problem resolved.

  • Tiptopalop Level 1 Level 1 (0 points)

    I just tried this and it worked. Its been driving my mum nuts.

     

    On you're system settings under store choose sign out. Get someone else to sign using their existing account on your device. Then launch app store first to see if it able to connect. It should do. Then launch iTunes  and to see if it can connect to the store. It may Hang for a minute but then connect. If it doesn't shut app down and launch again. It should then connect with other persons account. Once this is done go back to settings and then back to store and sign out. Sign back in again with your own account.

     

    That is all I did and now it's fine.

    Hope this helps with your devices.

     

    It will be interesting to see weather it works for you guys or not.

  • Humberto Quetz Level 1 Level 1 (0 points)

    I live in Brazil and someone brought an iPhone 4s for me from the US. It's all been working great but now it showed the message everyone is getting.

     

    I tried everything like you guys have said already. It's been happening for 2 days now and I find really odd that I can't download any app when at home but I got to download stuff while at the university earlier today. When I got home again it wouldn't work.

     

    I had a friend giving me 2 of his Apple's ID (in brazil and argentina) and both worked fine while I'm at my house, meaning it doesn't have anything to do with my router or Wi-Fi connection overall. Then I relogged mine and AGAIN got blocked. I only have to think it's something with some of the Apple ID's... something they should've fixed a long time ago.

     

    If it doesn't get fixed I suppose I'll create another ID and let you guys know if that works fine.

  • geminicfl Level 1 Level 1 (0 points)

    Download the latest version of iTunes, or upgrade your currently installed version, then sync your iPhone. It should overwrite the corrupted settings file that causes this issue for many users. If that doesn't work, try restoring your iPhone as new and avoid restoring from a backup. I restored my iPhone as new And have not had this issue since.

     

    Also, do not keep switching Apple IDs on your phone. I have not tried this method, but I have heard some users report that there is a limit to how many times you can switch in a certain time period.

  • Bambam2264 Level 1 Level 1 (0 points)

    I've been havin a similar problem with my iPad, some have said they can download but not update, well I cant download an app but I can surf my iTunes store no problem (haven't tried to purchase anything in iTunes). I tried turning off the wifi on my iPad resetting my modem and turning the wifi back on on my iPad, that works for literally 30seconds then pops up with the "cannot connect to iTunes store" again.. I can surf the internet (that's how I'm posting this right now) so I don't know what the problem is..

  • danilogabba Level 1 Level 1 (0 points)

    I was getting the same "Cannot connect to..." message when trying to update or purchase new apps. Today was actually the first time I've ever seem this message.

     

    What worked for me was a simple Soft Reset. When it finished rebooting it automatically started to download all updates without a new password request.

     

    Hope this helps someone out there.

     

    Cheers!

  • Bambam2264 Level 1 Level 1 (0 points)

    I did a complete settings reset to my iPad n now it's working just fine.. I figured since I didnt really have anything on here a hard reset would be easiest and fix just about anything

  • Matthew Burk Level 1 Level 1 (0 points)

    I was having a problem with updating my apps on my new iPhone 4s. "Can't connect to the iTunes store" error.  I updated my credit card info, it had an error saying that I needed to confirm my info because I was using a new device.  I re-entered my info, and now it works.  Hope this helps some of you.

  • yr2615 Level 1 Level 1 (0 points)

    What worked for me was unplugging my router and then plugging it back in after a few seconds.  It was one of the recommendations listed in the Apple troubleshooting forum:

    http://support.apple.com/kb/TS1368

     

    I've had my iPhone 4 for almost a year and just today I started getting that "Cannot connect to iTunes Store" message when I tried updating a few of my apps.  I tried shutting off my phone, I verified that I had the latest iOS, and I toggled the on/off button in my wireless settings on the phone, but none of that worked.  I didn't want to reset my phone or sync it to iTunes so I googled it and came across the link above.  I didn't think that my router was the problem because my internet was working just fine on my iPhone and the signal strength was good.  But as soon as I unplugged my router and plugged it back in, I tried updating my apps again and sure enough, as soon as I entered my password, the apps began updating immediately.  Really weird.  Maybe this will work for some of you.

     

    Another issue I've had is when I'm somewhere that doesn't have WiFi, it won't allow me to update or download apps that are over a certain size.  Sometimes it'll give me the message that I need to connect to WiFi because the app is over certain MBs in size, and sometimes it won't say anything at all and it just won't download.  But as soon as I connect to WiFi, it will.  

Previous 1 10 11 12 13 14 Next