Previous 1 17 18 19 20 21 Next 338 Replies Latest reply: Jan 3, 2015 9:32 AM by appleornothin Go to original post Branched to a new discussion.
  • shirleyfromemmaus Level 1 Level 1 (10 points)

    For a resolution of this problem (not just for iPhone 4), follow this link <http://support.apple.com/kb/TS1368?viewlocale=en_US&locale=en_US> for Apple's article regarding "Can't Connect to the iTunes Store."

  • TerraCognita Level 1 Level 1 (0 points)

    On a 4S with iOS 5, JR's procedure - modifying the DNS and Search Domains data - resolved the problem for me.  Thanks, JR!

     

    (The problem on my device only occurred with the App Store app. All the other apps were able to connect fine over wifi - including iTunes. In over a year, this is the first time I've encountered this issue. Whether a coincidence or not, it cropped up just after I tried to access the App Store after  an iTunes sync using a Mac Pro.)

     

     

    Logging out and back in from the Store did not correct the issue, though it's definitely worth a try as it seems to have helped others here in some instances. I recommend  logging out, then in, as a first step, and updating the DNS and Search Domains as a second step.

     

     

    I haven't tested  to see, but I wonder if reverting all Settings isn't simply a broad brush method of addressing the DNS setting (along with a host of others)? Hopefully most folks can avoid having to resort to this.

  • TerraCognita Level 1 Level 1 (0 points)

    Here is GamblingJames' (JR's) procedure.

     

    (The post is on page 12. Hashjeet on page 13 recommends adding 8.8.4.4 to the DNS IP string, rather than replacing those already there. This may also work, but I haven't tried it.)

     

    Hello Everyone.

    This is a very simple fix.

    If you are at an airport, or a hotel and cannot get into the app store,

    • go to your settings
    • go to wifi,
    • choose a network
    • click the blue arrow beside the network you are connected to
    • go Down to DNS.
    • delete all of the numbers in there and enter 8.8.4.4
    • go to search domain and change it to google.com

     

    This will fix your issues.

     

    JR- Former IT Professional

  • Belles-Lettres Level 1 Level 1 (0 points)

    The easiest solution: just turn the phone off for a minute and turn it back on. I read all these posts, and chose not to reset the settings for my iPhone 4 which had a recent iOS 6 upgrade. The hard reboot worked and reset the app and itunes stores which became immediately accessible.

  • Mhudak98 Level 1 Level 1 (0 points)

    Thank you, I turned my Wifi off and back on and logged out and back into app store for good measure. Logging in and out of app store didn't work until I turned wifi on and off so thanks for that tip!! All is good in my iphone AppStore world now :)

  • ishakir Level 1 Level 1 (0 points)

    I did the reset all, still the problem is there "cannot connect to iTunes stores". I guess apple doesn't hav any resolution for this yet. They r busy only fighting with Samsung over patents n Samsung is doin business along with legal case. Soon this f****g apple will get rotten if their products hav this issue. Sometimes AppStore is not getting connected n if it gets connected I get error saying m not authorized to use the UK, sometimes US, sometimes Canada when my settings shows my country as Kuwait.

  • Cheburaska1 Level 1 Level 1 (0 points)

    If you changed your date for some reasons, set it to "set automatically". It worked for me

  • Jklempa Level 1 Level 1 (0 points)

    Resetting worked for me! Thanks!

  • HARMANKurd Level 1 Level 1 (0 points)

    I had same problem what I did to fix that I went to SETTING >>>  STORE sign out than went AppStore ask me to sign in and every thing works FINE  

  • biofinity4 Level 1 Level 1 (0 points)

    Here's my fix.  Access your wireless router settings, go to WAN settings and change MTU from 1500 to 1453.

     

    The App store and itunes now works with WI-FI on iOS 6.0.1 (iPhone 4S)

  • Webae55 Level 1 Level 1 (0 points)

    Resetting all worked for me too... Thanks!

  • AdnanKamal Level 1 Level 1 (0 points)

    Kindly try this:

    1- go to setting

    2- iTunes &amp; App stores

    3- click on the Apple ID: on the the top

    4- sign out

    5- sign in again

    6- use the App Store

    7- if it works, kindly press "like"

  • Aeros Level 1 Level 1 (0 points)

    I was getting the "cannot connect to iTunes" message, so i couldn't do some of the suggested fixes as i couldn't even get in to the itunes store.  Just changing the date didn't work so I went for the "reset settings" option and it's worked so far, just had to find the password to access the wi-if but got there in the end.  Fingers crossed it will continue to work.

  • Attaurrehman Level 1 Level 1 (0 points)

    Hello Sirs,

     

    I can't connect my iPhone4 to iTunes Store since couple of days but I still remember that I had baught last application on 18 Jan 2013.

     

    Now my iPhone is not connecting to iTunes store.

     

    If I am on wifi or on 3G.

     

    I have installed iTunes which I downloaded recently from apple.com in my computer is also not connecting to iTunes store.

     

     

    Please instruct.....

  • destroyed92 Level 1 Level 1 (0 points)

    same problem here..!!

    it just shows up white screen..!!

Previous 1 17 18 19 20 21 Next