Previous 1 18 19 20 21 22 23 Next 338 Replies Latest reply: Jan 3, 2015 9:32 AM by appleornothin Go to original post Branched to a new discussion.
  • Keem7 Level 1 (0 points)

    There's a simple solution which worked for me, just turn your location service on/off. Trust me, it'll work! You're welcome!

  • artkitekt Level 1 (0 points)

    All,

     

    I had the same problem you are experiencing... walked through every suggested solution from changing the date, to altering the DNS input, to turning off/on location service.  However, nothing worked until I noticed something very very simple that I was overlooking.  If you walked through everything and are still having problems give this a whirl...

     

    Go to Settings > General > Cellular ... and make sure the 'iTunes' tab indicates 'on' .  Sounds simple I know but when I updated my iphone 4s to the IOS 6.1 it turned off... so, that is my suggestion... I hope you find the solution because I understand how frustrating this may be.

     

    Happy hunting.

  • jmbell Level 1 (0 points)

    I used your suggestion and it worked! So, I updated apps, then thought I was done. Remembering an app I wanted to download, went to reconnect to the Store. It took forever! I got bored and stopped. Is this an ongoing bug we are going to have to live with? Is Apple going to bring out a fix? It is annoying as blazes. (And, yes, I checked. The iTunes tab was still "on."

  • jedrizmom Level 1 (0 points)

    same problem here   Im in the UAE and my apple id is set to this country but i will get the same message as you mentioned... on my 2nd hour reading and trying the suggested fixes but nothing worked so far!!

  • Patrick Hill1 Level 1 (25 points)

    Worked like a CHAMP! Great tip!

  • Anthonysal1 Level 1 (0 points)

    Go to settings>general>reset>reset network settings

  • leetut Level 1 (10 points)

    20 pages of absolute junk here

     

    "cannot connect to itunes store" on device

    but can download and install while connected to itunes

     

    still no definite solution

  • mron66 Level 1 (0 points)

    I turned airplane mode on then off again and it worked. Well chuffed.

  • ojumpmantwenty3 Level 1 (0 points)

    Tried everything suggested here and none of it worked :/

  • TongueJedi Level 1 (0 points)

    Method 1:

    Reset your network settings by Navigating to

    Settings App –> General –> Reset –> Reset Network Settings then your iPhone will Restart.

    Method 2:

    Enable Restrictions for about 5 seconds and disable it back again.

    Navigate to Settings App –> General –> Restrictions.

    Method 3:

    Rest your WIFI then Reboot your iPhone and try again.

    Navigate to Settings App –> WiFi –> {YourWiFiNetwork}

    Method 4:

    Check your date and time and time zone.

    Navigate to Settings App –> General –> Date & Time.
    Disable Set Automatically.
    If the date and time correct, enable Set Automatically.

    Method 5:

    Uninstall iBooks and install it back again.

  • TongueJedi Level 1 (0 points)

    the one that usually works..

    Go to Settings > General > Date and Time > Set Automatically > Off. Set the date one year ahead. Try to update the apps again. If you get an error message, go back to the Settings app and change Date and Time > Set Automatically back to On. Then go back and try again.”

  • JennD17 Level 1 (0 points)

    Okay, for those who tried this and it didn't work (as was the case for me), I will post exactly what I did - which somehow worked in the end!

    1. Open Settings.
    2. Open General.
    3. Open Date & Time.
    4. Switch the Set Automatically setting to Off.
    5. Open Set Date & Time.
    6. Set the date to 1 January 2038
    7. Go back to itunes & app stores in setttings
    8. Click apple id and sign out
    9. Turn off phone
    10. Turn on phone
    11. Open settings and Set Date & Time back to the current date
    12. Go back to the Home screen and open Passbook.
    13. Tap the App Store button. Sign in with apple ID.


      somehow this elaborate way worked. Try in case the previous ways mentioned didn't work for you! Good luck!
  • shell_114 Level 1 (0 points)

    Set your date and time ahead eg the year 2014. See if its working then set it back to automatic. This worked for me :)

  • jlbtech Level 1 (10 points)

    This is the only thing that actually worked for me.  I have no idea why.  I will definitely hesitate with future iOS updates as I normally do with iTunes updates.

  • b_wepp Level 1 (0 points)

    I tried every suggestion except for Jenn's first, because it seemed random and complicated.  None of them worked.  That one did. THANKS!!!!!!!!!!!!!!