1 3 4 5 6 7 Previous Next 337 Replies Latest reply: Jun 7, 2014 4:45 PM by hiphoppolice007 Go to original post Branched to a new discussion.
  • 60. Re: "Cannot connect to iTunes Store" - iPhone 4
    geforcer Level 1 Level 1 (5 points)
    I can always connect to the iTunes store, however I'll still receive this error. For instance, when I open the App Store, it'll give me the error, but if I look behind it, it'll still show everything loaded correctly such as checking for updated apps. Any ideas why this happens?
  • 61. Re: "Cannot connect to iTunes Store" - iPhone 4
    dave2humphreys Level 1 Level 1 (0 points)
    Im getting the same problem, but intermittently,

    for example last night I updated to apps no problem, but then this morning another app needed updating and it wouldn't work. It keeps taking me to my payment information and asking me to input my security code, even though I have done that before...
  • 62. Re: "Cannot connect to iTunes Store" - iPhone 4
    tymccat Level 1 Level 1 (0 points)
    My iPhone 3G was sending message Cannot Connect to iTunes Store when I clicked on the App for iTunes or App Store. I tried every possible solution and verified my internet connection was still working properly. Nothing worked! Then I tried my iTunes App one more time and I noticed that when I got the message about the phone couldn't connect the menu navigation icons were still at the bottom of the screen. I tapped the music Icon and the screen loaded up with New releases and needless to say I accessed each of the Icons and the screens loaded. I did the same process for the App Store Icon after I got the message and I got the App Store Icon working as well. I don't know if this helps for the iPhone 4 users but I wanted to share anyways. Good Luck!
  • 63. Re: "Cannot connect to iTunes Store" - iPhone 4
    BuddieBrilliant Level 1 Level 1 (0 points)
    As with every suggestion this worked for me with but might not with everyone. I've getting this problem intermittently for the last week or so on my 3G (running 3.1.3).

    I tried the solution of signing out of the itunes account but then I couldn't sign back in. I was able to browse the app and itunes stores, surf web, send emails, etc and the network was showing as a full signal 3G bars.

    I then discovered that my data APN setting was missing (Settings->General->Network>Cellular Data Network) I'm on the Three network so I re-added the APN details, Disabled 3G and then re-enabled 3G again and now I can happily update my apps.

    Who know's how long this solution will last for but so far so good.
  • 64. Re: "Cannot connect to iTunes Store" - iPhone 4
    ipune Level 1 Level 1 (0 points)
    Basically the same problem here too. I have a 3Gs that always connects fine. My wife has a new iphone 4 that loads itunes but when you try to download or stream a podcast it gives the dreaded "can't connect to itunes store".
    Even more strange is that sometimes you click to stream a podcast and it starts playing from the episode list screen without loading the player!!?
    ***** to upgrade and have issues that never existed with the old 3G..
  • 65. Re: "Cannot connect to iTunes Store" - iPhone 4
    relio Level 1 Level 1 (0 points)
    Hi guys writing from Italy. Same problem here with two Iphone4 and one ipad. Spent one hour talking at the phone with the Apple center. They did not give any solution. What does really scare me is that this topic began the last june and seems that nobody solved this issue. Unbelivable!
  • 66. Re: "Cannot connect to iTunes Store" - iPhone 4
    SoCalCat Level 1 Level 1 (0 points)
    YES, this did work for me. Turned off WiFi. Bought something via 3G connection. I was asked to update by credit card info since it was the first purchase on my new iPhone (which had been initially updated with my iTouch information). I was able to complete the purchase. Turned WiFi connection back on and was able to purchase!
  • 67. Re: "Cannot connect to iTunes Store" - iPhone 4
    Issachar Level 1 Level 1 (0 points)
    neil kitchen wrote:
    I am having the same problem with my 3gs. When I try to update I get a "Cannot Connect with iTunes Store" message. I have reinstalled my iPhone with the back-up and "create new iPhone" option; deleted the Apps that were to be updated both on my computer and iPhone - now, two days later, I have ten I can't update; I have signed in and out of my account and have reentered my financial information on my computer and iPhone - no luck! I can install from my computer or iPhone - but I cannot update from the update icon. HELP!!!


    I have the EXACT SAME PROBLEM! No problem with getting new apps from Appstore on iPhone4 but I get the "Cannot Connect to iTunes Store" everytime I want to update an app!
  • 68. Re: "Cannot connect to iTunes Store" - iPhone 4
    IpodHappy Level 1 Level 1 (30 points)
    I get this error when I open the Apps Store and try to check for apps to update the first time in a day. If I click another tab in the Apps Store, it connects. I can then check for apps which need updating and it will work fine. After the initial hang, I can check for updated apps again as much as I want during that day and it works.
  • 69. Re: "Cannot connect to iTunes Store" - iPhone 4
    squirbel Level 1 Level 1 (0 points)
    I want to notify everyone that the solution to this issue is to turn off your WiFi. Reset your device, and turn it back on. Turn the WiFi back on, and load the iTunes store. You're good to go!
  • 70. Re: "Cannot connect to iTunes Store" - iPhone 4
    wiz2003 Level 1 Level 1 (0 points)
    This does not work for me.......
  • 71. Re: "Cannot connect to iTunes Store" - iPhone 4
    Adam Jackson1 Level 1 Level 1 (0 points)
    I get the same issue when checking for updates. Everything else works ok! I've tried logging out & back in, turning WiFi off & back on, and have also done a complete restore, all to no avail! I'm at the end of my tether with this now...
  • 72. Re: "Cannot connect to iTunes Store" - iPhone 4
    =DJ= Level 1 Level 1 (0 points)
    Do you have either of the apps "Ship Finder" or "Sylvan Archive"?

    Crazy as it sounds, if you have either of these apps and you delete them from your iPhone you'll find you'll be able to receive updates for other apps on your phone again!

    There's a current problem on the app store where some packages have become corrupted and if you own these apps the update checks fail...

    These two apps are known to have suffered this issue (and their poor developers are pulling their hair out waiting for a response from Apple!), but I guess it's possible others might be affected...
  • 73. Re: "Cannot connect to iTunes Store" - iPhone 4
    carlinlondon Level 1 Level 1 (0 points)
    DJ - Thanks so much for the response re the "Ship Finder" app!!! I haven't been able to update apps for the last week. Just removed Ship Finder and now updating normally!
  • 74. Re: "Cannot connect to iTunes Store" - iPhone 4
    =DJ= Level 1 Level 1 (0 points)
    Ah that's brilliant news!

    Yes, it was Ship Finder for me too - most odd that a mismatched file can fail the whole update process!

    Keep an eye on the developer's blog who I'm sure will be super excited when Apple fix the binary
    http://my.pinkfroot.com/profiles/blogs/we-love-apple-but-what-do-you
1 3 4 5 6 7 Previous Next