1 2 3 4 Previous Next 52 Replies Latest reply: Aug 22, 2010 7:29 AM by joelewisuk Go to original post
  • 30. Re: iPhoto won't import photos or videos from iPhone 4
    iBrox Level 1 Level 1 (0 points)
    Had this problem and I'm not sure if this is the root cause or not, but I think the problem is stemming from the photo/video file names. They are resetting on the iphone and when an attempt is made to transfer new photo/videos, it causes the problem because the file names already exist. I changed file names of videos on my Mac and was able to import new videos from iPhone 4. What a pain! Is there a setting that can prevent iphone from resetting file naming of videos/photos?
  • 31. Re: iPhoto won't import photos or videos from iPhone 4
    DrSGK Level 1 Level 1 (0 points)
    Just had the same problem with the iphone 4 and my MacBook Pro - file not recognised kept appearing. Very frustrating, however it seems to have resolved itself completely.

    I had been impatiently trying to import the images into iphoto as it automatically booted up when the iphone was connected. If I now let itunes and iphone sync (takes a few seconds) before trying to import into iphoto all is well and it will import as many images as I want.
  • 32. Re: iPhoto won't import photos or videos from iPhone 4
    Michael Randow Level 1 Level 1 (20 points)
    Sort of the same problem here. I took about a dozen pics on the new iPhone 4.0 and got them imported onto my MBP at the house. Put the pics on a memory stick and brought it to work to import into iPhoto 8.1.2 and it won't import. Got one imported somehow and now it just hangs on the "importing photo's" forever and ever. Faces is going crazy as well . spinning gear like its cranking away at identifying faces or something. Other JPG's seem to import fine, it just the new iPhone 4 photos.

    Deleting the cache.db file didn't work.
  • 33. Re: iPhoto won't import photos or videos from iPhone 4
    Jonnycat76 Level 1 Level 1 (0 points)
    +1 Thanks for saving me some time tracking it down to the iPhoto cache & Reboot fix.
    For something that "Just Works" this "Doesn't Just Work" all that well!!
    C'mon Apple let's get some interdepartmental collaboration going on!
  • 34. Re: iPhoto won't import photos or videos from iPhone 4
    A M Level 1 Level 1 (85 points)
    Confirming that emptying cache.db and restarting the iPhone 4 did the trick.
    Probably some file sync problem.
    Imports in no time
    Thanks to all for posting the fix.
  • 35. Re: iPhoto won't import photos or videos from iPhone 4
    scottf75 Level 1 Level 1 (0 points)
    Same problem on my iPhone 4 since upgrading to iOS 4.0.1.
  • 36. Re: iPhoto won't import photos or videos from iPhone 4
    Greylash Level 1 Level 1 (0 points)
    My first Mac, and not impressed. Sure, it's beautiful, but this is sad. Apple product doesn't work with Apple product? They can't even blame a 3rd party.

    The cache delete and iPhone reboot did NOT work for me. I have an iPhone 3GS with latest OS.
  • 37. Re: iPhoto won't import photos or videos from iPhone 4
    Christopher42 Level 1 Level 1 (0 points)
    Had the same problem, but...

    restarting iPhone 4
    deleting iPhoto cache
    restarting MacBook

    ...solved it and I was able to import again.
  • 38. Re: iPhoto won't import photos or videos from iPhone 4
    nickffc Level 1 Level 1 (0 points)
    stupid question....how do you delete the iphoto cache...??
  • 40. Re: iPhoto won't import photos or videos from iPhone 4
    Michael Battenfield Level 1 Level 1 (135 points)
    Since updating my 3G to iOS4, I too have had all sorts of issues, with the Camera app and iPhoto importing being just one of many problems.

    As a long-time Apple fan and user (18+ years), this software update is the first that has actually caused me to question my view of Apple. I had been seriously contemplating jumping to the new iPhone 4 (am due an upgrade), just waiting to put the $$ together - when all the issues with the release came out (from supply issues, to AT&T + Apple ordering problems), then the antenna/"grip of death" (though somewhat over-inflated), and the numerous software issues - has made me glad I didn't join the early-adopter's club.

    And I knew that with my older (is 15 months REALLY that old for a phone?) 3G, I wouldn't get all the new and nifty bells and whistles, though the folders was really promising.

    But have had nothing but fits since the update. Phone is slow to launch pretty much everything. Even Apple-suppled default apps (like Camera, Mail, etc.) sometimes crash or even fail to launch.

    And then, I snap a couple of photos this morning for a quick post to a message board - come back in the house and connect to my desktop, launch iPhoto - and NO photos show up (I know for a fact there are 168 photos on my phone). I tried the various suggestions on this thread and nothing.

    BUT -

    After the 3rd hard reboot of my phone, with it connected to the computer, I tapped the photos icon on the phone - and nothing showed there! After about 3 seconds, the screen changed and showed "rebuilding library". After about 2 minutes, the photos all showed on the phone. Looking at iPhoto - some of my older photos were no visible...

    After two more reboots of the phone, all my photos became visible in iPhoto.

    What has set Apple apart for 25+ years - hardware and software that "just works" - and one of those "bragging rights" we have as Apple users... is now vaporizing.

    Further, Apple has not handled this well at all - the release of the iPhone 4 or the software updates to iOS 4. Personally, I believe that either a "light" and OPTIONAL version of iOS 4 should have been stipulated for the 3G, but a clear path to revert BACK to 3.1.3 should be provided by Apple (not by some 3rd party hack or code voodoo...

    I know several of my friends who have similar 3G issues after the update. One who was never an Apple fan until getting their iPhone 3G, falling in love with Apple stuff... and then iOS4 came out... and they are cursing Apple and have already jumped to a different phone.

    For a company that has unofficially been dubbed the "Anti-Microsoft", Apple sure is becoming more LIKE Microsoft...

    While I am glad I got to my photos again - why should I have to jump through such hoops?

    If anyone from Apple is actually monitoring these threads - please listen to your customers, particularly the loyal ones (or maybe formerly loyal?). You have dropped the ball. Time to pick it up.
  • 41. Re: iPhoto won't import photos or videos from iPhone 4
    TheScoot Level 1 Level 1 (0 points)
    I have closed every app, rebooted both my phone and iMac, only started image capture on reboot and still can not get my videos off of my iPhone 4. So frustrating.
  • 42. Re: iPhoto won't import photos or videos from iPhone 4
    TheScoot Level 1 Level 1 (0 points)
    Here is how I finally got it to work. Had iTunes Closed, Had iPhoto Open. I Hard Reset my phone (Power and Home button held down until it restarts) and iPhoto grabs a hold of the phone before anything else preventing the files from getting locked. I was then able to import the photos and videos that have been stuck on there for weeks. It was hours and hours of trial and error before I finally hit the right combo.
  • 43. Re: iPhoto won't import photos or videos from iPhone 4
    Douglas B. Evans Level 1 Level 1 (10 points)
    Same problems. Photos on the camera roll won't show up in iPhono and won't upload.
  • 44. Re: iPhoto won't import photos or videos from iPhone 4
    Raypoh Level 1 Level 1 (0 points)
    Hey Apple,

    how about some response on this......