Previous 1 2 Next 15 Replies Latest reply: Aug 12, 2010 9:25 PM by sput_nick
rajeshgarga Level 1 (0 points)
After updating to iOS4, I am not able to edit the contacts in my iPhone 3GS. The edit button is missing.

However, in messages app, when i am trying to send a message, I am able to get the contacts stored and I am even able to edit them from there.

I have not seen this problem reported by anyone else here. Can someone help me with this?

iphone, iOS 4
  • ramzoozi Level 1 (0 points)
    I am also facing this same problem, where any newly added contact (after updating my iPhone software) cannot be edited. Note that adding a contact only works when it is done through the Call App, not through the Contacts App!! and even then, I can't edit the newly added contact. If I attempt to add a new contact through the Contacts App it does not allow me to enter a phone number, and even then, when I click Done, it just saves a blank contact!!


    I've asked other friends with the identical 3GS phone that have also done the update, they are NOT facing this same problem, however they updated their software on iTunes while in Ireland, and I'm in England, could some installation updates over iTunes be dodggy?
  • BrakTalk Level 1 (0 points)
    Disregard. I was in the wrong thread myself. I should follow my own advice. :P

    Message was edited by: BrakTalk
  • BrakTalk Level 1 (0 points)
    Disregard. I was in the wrong thread myself. I should follow my own advice. :P

    Message was edited by: BrakTalk
  • Scott McArron Level 1 (0 points)
    I've got the same or similar problem. Not only have I lost the 'edit' button in contacts, I've lost the 'add' or '+' button from the All Contacts page. I can add a contact my manually typing in the number on the keypad and then using the add contact button on the lower left corner so this isn't a huge issue for me. Not being able to edit contacts, whether added before or after the iOS4 upgrade, is a big deal, though. Hopefully, this will be fixed in the next update whenever that becomes available.
  • rajeshgarga Level 1 (0 points)
    Yes. I failed to mention in my original post about not being able to add contacts from contacts page. That holds good for me too.

    Scott, This is not true for everyone who has upgraded. So i am not sure if Apple is even aware of this issue.
  • ajm001 Level 1 (0 points)
    I have the same problem after updating to 4.0 - When I attempt to add a contact via the Contact App I can enter the name but there is no place or ability to enter a phone number. "Done" just saves a blank contact with No Name at all.

    Is this a known issue? Is there a known fix?

  • rajeshgarga Level 1 (0 points)
    This problem seems to have hit a few people and no solution is forthcoming. I will go to a genius bar tomorrow and update this post with their response.
  • wforster1 Level 1 (0 points)
    Exactly the same issue, with no + icon in the corner - Only noticed after updating to iOS 4..
    Also, i have noticed that occasionally when oppening the contacts app, the + icon will appear, but only for a split second (i have tried catching it but I'm just too slow )...
    this is a real bummer, as i can't do anything to edit my contacts - only add them sloowly via keypad...
    I Hope the Geneii can help!
  • solinvictus21 Level 1 (0 points)
    I have the exact same problem. In my case, it appears that any contacts I add from the phone from the call log exhibit the following behavior.

    (a) They are uneditable.
    (b) They cannot be deleted.
    (c) They do not sync with iTunes nor OTA with my Gmail account.
    (d) In the Contacts app, they appear if I search in the group "All Contacts", but not if I search in the groups "All from My Mac", "Gmail->Contacts" or "Gmail Global Address List".

    It's freaking bizarre. It's as if there is a hidden sub-group of contacts that is only included in the "All Contacts" search, but any contacts in that hidden sub-group are strictly read-only and do not sync with anything. I really hope this is a bug that Apple is aware of and that they are working on a fix.
  • brit53 Level 1 (0 points)
    I was having the same problem - no way to edit contacts but it seems to be resolved now. I have been using gmail set up as an exchange account to sync calendar entries for some time. Yesterday I also enabled contact sync for this account to try to keep my contacts more in sync by using google's push capability.

    This afternoon I decided to turn it back off as I decided I don't like the way phone number "types" are mapped in the sync process and installed the "soocial" app for contact syncing and it is working better for me. I synced soocial with gmail and then synced my iphone to soocial which did a reload of all my contacts. This is when the "missing" + and edit buttons problem appeared.

    I tried powering down the phone and restarting (which has cured several other unexplained iOS4 glitches) but no change. I tried getting to contacts by launching the contacts app and through the phone and messaging apps but could not find any way to get the edit function back.

    Finally in frustration I decided to turn the google sysnc function for contacts back on. When I went beck into contacts and selected the 'All on My iPhone' group my contacts were all there and the edit functions had all reappeared.
    I went back to settings and disabled the google contacts again (selecting 'delete google contacts from my phone') and everything still works.

    Can't explain why this worked but it did.
  • JaybeChun Level 1 (0 points)
    I had exact same problem as folks had here.
    It could be resolved by using Recovery on iTunes.

    After recovery, iTunes ask you to choose to do it by backup file or New iPhone. I just did it from New iPhone after recovering and it fixed.

    You may have below risks.

    - Loosing Phone call histories
    - Loosing SMS & MMS
    - Loosing Photo library

    So I would like to recommend you checking twice the full backup before do this. You should check the backup file existing in proper directory. This will be helpful once you learned that it is better to go back rather than missing data. Good luck!
  • Shinaar Level 1 (0 points)
    Sorry for my bad english. There's the solution for me: deleting Exchange account from calendar/messages/contacts settings. After this my "uneditable" contact has been dissapeared and i can add it again with contact-list.
  • zoomzoom.mike Level 1 (0 points)
    Same problem, iPhone 3Gs (MC131X), iOS v 4.0.1 (8A306).
  • zoomzoom.mike Level 1 (0 points)
    Under "Settings > Mail, Contacts, Calendar > Accounts" delete the account which is Exchange enabled. For me I use Exchange sync with Gmail. So I recreated the account,

    My contacts now have the edit button back again. I seem to have lost the contacts that I loaded since the error appeared.


    Under "Settings > Mail, Contacts, Calendar > Accounts"
    I could see I have 7 email accounts. There was only 1 Exchange enabled email account (because it was previous OS3). Mail:ON, Contacts:OFF, Calendars:ON

    I dont normally sync CONTACTS this way, because I prefer Groups / SyncInABlink to manage duplicates.

    The following did not work:
    (1) Turn Contacts:ON, check email (which should cause a sync)

    (2) Connect iPhone to PC. Launch iTunes, click on iPhone, click on Info tab, tick [sync Contacts with Google Contacts], Apply

    Got warning "The info on this iPhone is synced with another user account, delete or merge?" I selected merge. I got an error message: An error occurred while merging.

    (3) Third thing I tried worked (see top for solution)
Previous 1 2 Next