1 Reply Latest reply: Jun 25, 2010 12:48 PM by BDAqua
Dirtydog69 Level 1 Level 1 (125 points)
I am just after confirmation. Is the latest version if OS X for the PPC G5 OSX 10.5? It seems it is not easy to get the "now older" versions of the OS. Any help appreciated.

G5 2GHz Power PC 1GB DDR/ Macbook 1.8Ghz, Mac OS X (10.4.10)
  • BDAqua Level 10 Level 10 (120,380 points)
    Yes, which can be upgraded to 10.5.8 right now, but it isn't even easy to get.

    Leopard requirements/10.5.x...

    * Mac computer with an Intel, PowerPC G5, or PowerPC G4 (867MHz or faster) processor

    minimum system requirements

    * 512MB of memory (I say 2GB at least)
    * DVD drive for installation
    * 9GB of available disk space (I say 30GB at least)

    You have to call Apple & ask for a Product Specialist to get it.