Previous 1 3 4 5 6 7 Next 91 Replies Latest reply: Jun 27, 2014 10:27 PM by Terence Devlin Go to original post
  • Kukutoo Level 1 Level 1 (5 points)

    I just ran a new update, and suddenly Iphoto '09 will not import the photos directly from my Canon camera anymore! I do photos all day long, and taking out the card to a reader 10 times a day is not a good system!

    Wish I had not done that update!


    Is there any solution to this problem? I am using 10.6.8. and my camera is a Canon Power Shot.

  • worker_worker Level 1 Level 1 (0 points)

    I did try updating to the latest Kodak EasyShare, and that works with my Z730 camera.  Even OS X update since then has not broken EasyShare, but iPhoto 9 is still broken.  So now I use EasyShare which is easier than a card reader.

  • Kukutoo Level 1 Level 1 (5 points)

    Well, of all things, mine turned out to be the USB port! Good news/bad news. Not have to take mini in for repair.

  • Kate Griep Level 1 Level 1 (0 points)

    I know I'm late to this discussion but wanted to give my input just in case someone else could use the info! After upgrading to Mountain Lion and iPhoto '11 from Leopard and iPhoto '08, I took my son's first day of school photos on my old Kodak V550 Easy Share camera. I was always able to plug the camera into my usb on my iMac and iPhoto would automatically open and recognize the photos. Now, after my upgrades to ML and iPhoto '11, my iMac recognized the camera but wouldn't import the jpeg files. After searching around in these forums, I saw something someone said about using the card reader on their printer to load the photos. I thought, I've never seen a card reader on my all-in-one printer, but sure enough, my Canon MP520 has a card reader! I took the SD card out of my camera, stuck it in the slot in the printer, and POOF! My iMac recognized the jpegs and imported them into iPhoto just like it used to. So, maybe not quite as easy as the USB import, but just as effective! And now I don't have to break it to the hubby that we need a new camera! Good luck, and thanks to everyone for the helpful tips.

  • macaphile Level 1 Level 1 (0 points)

    Have an easyshare z5120.  Have the same problem as everyone else.  Worked the first time (importing into Aperature) but computer doesn't recognize camera now.  While this is a cheap secondary camera (being clearanced at Woot!) I'm not sure it is worth the trade off of no raw and having to use a card reader.

  • lizknaus Level 1 Level 1 (0 points)

    Until they fix this (let’s hope they do) Mac should issue a warning when they send out any upgrades that upgrading Mac software will disable certain features such as importing jpgs from cameras via usb.

  • lizknaus Level 1 Level 1 (0 points)

    Thanks for the inspiration. Since my upgrade to iMac 10.6.8, I was unable to import my Kodak V603 images via usb to iPhoto. I opened EasyShare, plugged in via usb and syncronized my camera through the app that I'd installed back when I bought the camera. Now I am able to upload images to EasyShare. From there, I exported the jpgs to my desktop. Finally, I was successfully able to import them into iPhoto from my desktop! Once this was done, I drug the desktop images to the trash. Extra steps, yes, but I won't have to go buy a card reader as others suggested which I was going to try if this didn't work. I sure hope that Mac/Apple  fixes this! I've done quite a bit of research to figure this out and it will take a lot of extra time to deal with photos this way.

  • lizknaus Level 1 Level 1 (0 points)

    EasyShare transfer only worked once, so I ordered an SD memory card.

  • gjmitch Level 1 Level 1 (0 points)

    Similar problem.  Upgraded iMac to Snow Leopard, then updated to OS X 10.6.8.  Then was not able to import photos from Kodak EasyShare V550 camera.  Got screen in iPhoto with blank outlined squares with file identification attached to each, all dot JPG files.  Prior to the upgrades importing photos directly from the camera was trouble free - touch of a button on the Kodak camera dock.  Current version of iPhoto after upgrade is '08 ver 7.1.5 (378).  Don't know what the prior version was.

         Had a couple conversations with Apple technical support, but no solution.  Found that our Canon printer has a card reader slot which accepts the SD card from the camera, and with iPhoto open and the card plugged into the printer, the photos magically appeared and I was able to import the selected shots.  Have done this once only and hope it is repeatable.  Less convenient than before, but a work around. I'm convinced the difficulty lies within the upgraded software, not fully backwards compatible.  Tough luck.

  • eshaines Level 1 Level 1 (0 points)

    I just had the same problem--when I haven't had problems before.  I just tried to upload 68 photos and three 5-10 minutes-each videos from my Nikon D3100 in iPhoto and I got the same error message:  unrecognizable format (jpg).  I also tried just uploading the photos and not the videos, to no avail.  My camera's battery was dying, so I also tried charging the camera battery first--I have yet to see if this works but will let you know if it works.  Is there another way to import my photos, like drag and drop style, that doesn't require iPhoto?  Does anyone know?


    Thanks in advance!

  • LarryHN Level 9 Level 9 (68,665 points)

    Image capture - in your applications folder - can download photos without using iPhoto


    Or you can use the fix that everyone has found to work - a USB card reader



  • eshaines Level 1 Level 1 (0 points)

    Does image capture work for downloading videos as well as images?

  • LarryHN Level 9 Level 9 (68,665 points)



    It is possible that your iPhoto issue is not caused by the Kodak problem but by giant videos - try using iPhoto to import only the photos - or after download them to disk import from there



  • fortescue Level 1 Level 1 (0 points)

    Hello All,

    I had problem that it would give an error "iphoto the following file could not be imported unrecognized format"

    Files that had problem are .MOV files.

    I have downloaded all the files to local folder and then imported them to iphoto. It seems to work fine then.

  • squidna Level 1 Level 1 (0 points)

    i am also a kodak easyshare z730 user who had no problems with camera-computer communication until osx 10.6.  my work around was to pull off new photos from the camera using a mac g4 silver door that runs osx 10.4 or such and then transfer the photos to dropbox and then into the main imac.  but the g4 started misbehaving (won't boot) and i don't want to deal with it yet, so i took the card reader advice given here. i purchased a sabrent usb 3.0 card reader from amazon prime for $12.  it reads most every type of card out there and is backwards compatible to usb 2.0.  i plugged it into the imac with a sandisc sd 512mb card in it and voila!  thanx for all your help.

Previous 1 3 4 5 6 7 Next