7 Replies Latest reply: Aug 26, 2010 1:06 PM by fallingforstars
lurpdog101 Level 1 Level 1 (0 points)
hi all

I recently got the ipad, and am loving it. However, I cannot send emails from my talk talk account. The smtp address is simply smtp.talktalk.net and port 25, exactly as on my PC, however it says it cannot send.
When I created the account, it said this type of email is for O2 users only and the O2 username and password should be entered on the outgoing server area. I do not have an O2 username password and do not understand why this should be the case, when the ipad I have is not a 3G one, yet O2 is a cellphone carrier.

Cann anyone help me out?

ipad
  • a1000 Level 2 Level 2 (215 points)
    Hi there. It is likely that Talk Talk, like many other ISPs, only allow you to send e-mails through their SMTP server if you are connected through your wifi connection and logged in. This is, I believe, to stop spammers from sending spam from their servers.

    I'm assuming that you have a 3G iPad and an O2 sim in it. What you will need to do is register with O2 for a username which will give you an O2 e-mail account and access to their SMTP server. This will allow you to set up the O2 SMTP with username and password which will then allow you to send when not on wifi.

    If you are on another network then it may vary slightly and you may not need a username and password.

    Hope this helps.
  • lurpdog101 Level 1 Level 1 (0 points)
    Hi
    Thanks for the response. I have solved the issue!

    After speaking with Talk Talk, they advised me to phone Apple. I did this, and was referred back to Talk Talk as it was their issue (which I'd gathered) and asked to get a 2nd smtp address.

    I called Talk Talk back, and they were utterly useless, didn't even know a second address, and tried passing the buck to senior teams...she couldn't even understand what an ipad was (I work in IT support and you're always aware of latest gadgets even if you don't know how to support them). Anyhow she couldn't help.

    I eventually found something on here about talk talk and the i-touch. Same issue...I changed my smtp gateway from 25 (Talk Talk one on my PC and what they advised) to 110 which this other chap had...and it works fine now!

    Thanks
  • a1000 Level 2 Level 2 (215 points)
    Excellent. Glad you're up and running. I agree the helpdesks provided by most networks/ISPs don't seem to be too well briefed.
  • Bob Donaldson Level 1 Level 1 (0 points)
    Hi - I have exactly the same problem with my iPad and talk talk mail. I changed the port to 110 as you suggested but it still does not work. Can you let me know what you have for the SMTP section on your iPad - Server (On), Host name (smtp.talktalk.net), user name (actual email address), password (entered own password),Use SSL (OFF), authentication (password), server posrt (110). Tried different combinations but no luck - does wifi need to be off to do this?
    Thanks.
  • lurpdog101 Level 1 Level 1 (0 points)
    Hi there

    Ok. Under the mail settings, then talk talk I have:

    Incoming Mail Server: mail.talktalk.net
    Username: my username
    Password my password

    Outgoing Mail Server
    SMTP: smtp.talktalk.net
    Other SMTP serviers: smtp.gmail.com (I added my gmail account)

    Advanced:
    Use SSL - OFF
    Authentication - Password
    Server Port 110

    That's my setup...hope it helps
  • Bob Donaldson Level 1 Level 1 (0 points)
    Thanks Lurpdog - your settings are exactly the same as the ones that I have set up. Still can't send an e-mail. Anyone else out there using an iPad with talk talk that has another option?

    Thanks
  • fallingforstars Level 1 Level 1 (0 points)
    Hi Bob.
    Try this website: AuthSMTP.com
    It's a global email relay service - costs 14GBP per year. I've just installed the settings on my iPad this week and it works (I am also with TalkTalk). The SMTP setting replaces TalkTalk's with: mail.authsmtp.com (you will also need to input a unique username and a password).
    There is certainly something odd about the way TalkTalk's servers handle incoming from mobile devices. The setting listed above works fine in Apple Mail on the iPad but I have the PrintCentral app installed and sending email from within the app with the same settings as in 'Mail' does not work. It's just one big merry go round isn't it?