Skip navigation
This discussion is archived

Iphone 4 - can't put photos with contacts

11176 Views 18 Replies Latest reply: Nov 8, 2010 10:45 PM by Sarah R. RSS
1 2 Previous Next
usarow Calculating status...
Currently Being Moderated
Jun 26, 2010 4:10 AM
The photos associated with my contacts did not come over when I sync'd my new iPhone. Also, if I take another photo for a contact, it saves fine but when I go somewhere else and return to the contact, the photo is gone.

Any suggestions? Thanks.
iphone 4, iOS 4
  • shawkyns Calculating status...
    Currently Being Moderated
    Jun 29, 2010 5:25 AM (in response to usarow)
    I have the same problems, but it is only with the 'main' camera. I can add from the front-facing camera just fine. anybody know a way around this? my old contact photos synced fine.
    imac, iphone, Mac OS X (10.6.4)
  • sephus Calculating status...
    Currently Being Moderated
    Jun 30, 2010 4:21 AM (in response to usarow)
    I have an iPhone 3GS and I recently upgraded to iOS 4. First of all there was some issue during install, and I had to restore. This erased a lot of my stuff, and I didn't notice until a few days later that all my contact photos were gone.

    Not only that, but when I add a contact, then take a photo of them to use as their contact photo, it doesn't appear. Everything works as usual until after you "take photo", "Move and Scale" and select "Use Photo". The iPhone says "Saving Photo", but then the photo doesn't appear in the box. It just goes back to the "add photo" state.

    I tried taking a photo thru camera, and then Assigning to Contact. That works fine.

    Definitely a bug and I am not surprised since iOS4 is still in its early days, but nevertheless not too happy about it, especially since I don't think the photos get saved anywhere else, so they are all gone. Please let me know if I'm wrong...hoping I am.

    I guess its best to take photos using camera, save them, and add to contacts later.
    iPhone 3GS, iOS 4, Macbook Pro
  • Larry Gordon Calculating status...
    Currently Being Moderated
    Jun 30, 2010 1:21 PM (in response to sephus)
    Same issue found here. I had to take a picture with camera and then in contacts use existing photo.
    iphone 4, iOS 4
  • Nick Marsh Calculating status...
    Currently Being Moderated
    Jul 4, 2010 4:23 AM (in response to usarow)
    I have the same problem - the contact photos do not not sync across to the iP4. They are there on Address Book and also sync to MobileMe, but only text syncs to the iphone. Surely this is a bug?

    Strange thing is - a few photos have indeed now gone across, but the majority not. Any fixes?
    MacBook, Mac OS X (10.6.2)
  • jeetung Calculating status...
    Currently Being Moderated
    Jul 5, 2010 10:42 PM (in response to Nick Marsh)
    got the same problem, some contacts have photos associated with the said contacts, some don't, even it's set up to sync with MobileMe and photos are still there in Address Book on my mac.

    I stumbled onto the "workaround" which is, to go into your address book, double click the photo (as to either resize or change) and just click set again, it will then be synced to iP4.

    It's a hassle, but the only way so far right now other than to get hold of the person and re-take their pictures
    Quad-2.8 Mac Pro (Early 2008), 3rd and dying (dead) 8800GT, Mac OS X (10.6.2)
  • JediMaveriC Calculating status...
    Currently Being Moderated
    Jul 6, 2010 2:06 AM (in response to usarow)
    Similar problem.
    I do have all my contact photos, but in order to add a new one i need to take it with the camera and the add from the library.

    If i try to do it from the add contact lvl all of the info that i wrote b4 is erased and the screen reverts to its blank - non filled with new contact info state.

    This is a bug. No doubt about it.
  • MaFt Calculating status...
    Currently Being Moderated
    Jul 6, 2010 4:50 AM (in response to Nick Marsh)
    Same here. VERY frustrating... All photo's sync to MobileMe and MacBook Pro address book but then vanish from iPhone 4. Even photo's taken with front and rear camera are there for a while until it syncs with MM then they're gone from teh phone again...
    MacBook Pro, Mac OS X (10.6.4)
  • pinkfloydian Calculating status...
    Currently Being Moderated
    Jul 6, 2010 8:02 AM (in response to usarow)
    I have found a workaround that only works part of the time. If your contact photo disappears, go to Address Book, cut out the picture, then reinsert the picture, and click Set. Then open the picture again, and click Set again. Then close Address Book. About 80% of the time the picture gets through to the iPhone. I have had this problem since I received the iPhone 4.

    When it doesn't work, I shut off MobileMe sync for contacts on the phone, delete the contacts, then turn it back on. In a few minutes all the contacts come back, WITH the pictures.

    This is no solution - just a painful workaround. I already talked to Apple support on this one and of course they "never heard of this". Baloney.
    iMac (Core 2 Duo) 24", Mac OS X (10.6.4)
  • jasonrocks7 Calculating status...
    Currently Being Moderated
    Jul 6, 2010 1:34 PM (in response to pinkfloydian)
    I'm having the same problem with my iPhone 4. Same exact problem.
  • Nysul Calculating status...
    Currently Being Moderated
    Jul 7, 2010 2:11 AM (in response to jasonrocks7)
    I also have this problem. I go to add a contact, click "add photo", click "take photo" take a photo of my wife (with either camera), the move and scale doesn't seem to do anything and the photo never saves. It does save if I select "choose photo". How can a bug in a core app like this get past QA?
    iPhone 4, iOS 4
  • MaFt Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 7, 2010 2:59 AM (in response to usarow)
    We seem to be mixing 2 separate issues here:

    1) contact photo's disappearing when synced with MobileMe

    2) not being able to resize and add a new photo using the iPhone's camera

    Seeing as (1) was the original post, can I suggest perhaps starting a new thread for (2)?

    MaFt
    MacBook Pro, Mac OS X (10.6.4)
  • kikiyal Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 12, 2010 11:04 AM (in response to MaFt)
    I have the second problem as well. The solution is to switch your phone off, and then it works. I just did it one minute ago.
  • victoriaaa Calculating status...
    Currently Being Moderated
    Jul 14, 2010 2:13 PM (in response to usarow)
    i'm having the same issue described here, no photos for my contacts. my mobileme contacts all have photos in address book on my macbook pro and online in the web interface, but not on my new iPhone 4. i've tried a hard reset, disabling syncing and re-enabling it, and nothing. any other suggestions?
    2.4ghz mbp, 8gb iPhone 3G, Mac OS X (10.6.1), defunct 900MHz iBook G3 12", 1.5ghz 15" powerBook G4.
  • sport1901966 Calculating status...
    Currently Being Moderated
    Jul 15, 2010 1:57 AM (in response to Nysul)
    I was having this exact problem, funnily enough switching the iphone off and on again seemed to sort it
    iOS 4
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.