5 Replies Latest reply: Feb 3, 2006 10:13 AM by Claude Thomas1
Roel Smelt Level 1 Level 1 (0 points)
Just trying to sync my iPhoto library with my iPod. Just after the update is starting an error is shown: error -50.

Does anyone has a clue how to solve this.

iMac G5, Mac OS X (10.4.3)
  • nickz Level 1 Level 1 (0 points)
    No idea how to solve it - I am having the same problem. Re-installed everything (iTunes, iPhoto, reset iPod) but it doesn't work. I can import folders of pictures, but not through iPhoto. Very frustrating - it worked when I first got it, but seemed to stop after I did a software update.
  • Roel Smelt Level 1 Level 1 (0 points)
    Eventually I could solve it by creating a new iPhoto library.

    Open iPhoto with the <alt> pressed. Then you will be given the option to create a new library.
    This worked for me. Good luck.
  • Roel Smelt Level 1 Level 1 (0 points)
    See my post
  • nickz Level 1 Level 1 (0 points)
    Thanks for the info. It did work when I created a new library, however, I didn't want to lose all of the rolls and albums I have created in my old one. I tried to move all of my old files into the new library, but the iPod problem came back. It would seem the problem is somewhere in the iPhoto directories that were in my old library. I'll have to think about this one. If anyone has any ideas, please let me know.
  • Claude Thomas1 Level 1 Level 1 (75 points)
    It did work when I created a
    new library, however, I didn't want to lose all of
    the rolls and albums I have created in my old one. I
    tried to move all of my old files into the new
    library, but the iPod problem came back. It would
    seem the problem is somewhere in the iPhoto
    directories that were in my old library. I'll have
    to think about this one. If anyone has any ideas,
    please let me know.


    Did you ever solve this? I have iphoto 6, and a ipod video 60g. All I get is the complete library of photos. When I choose "Sync with iPhoto" no albums are on the list. The other choice, Photo Library, is just a dump of everything.

    Is there a fix other than createing a new iPhoto library?