3 Replies Latest reply: Jul 30, 2010 4:15 PM by karenairdrie
Jose Marcelino Level 1 Level 1 (5 points)
An error message occurred as I was trying to restore the iOS4 software on my iPhone 4.

I keep getting "The iPhone could be not be restored. An unknown error occurred (9)." and then it goes to "iTunes has detected an iPhone in recovery mode. You must restore this iPhone before it can be used with iTunes."

So...basically, I just keep getting the above. On the iphone I just get the plug to iTunes graphic.

I reinstalled iTunes 9.2 and reinstalled iOS4 on my main Mac and my Macbook Pro to no avail. I even used different USB ports but that didn't work either.

Any help is appreciated.

iPhone 4, iOS 4
  • Jim Suriano Level 1 Level 1 (0 points)
    I have had the same issue with my phone. I noticed that it was using up the battery too quickly. After numerous attempts to fix the issue (turn off/on, make sure there are not background apps, etc), I decided to finally do a restore.

    I have had the same issue on restoring the phone ("unknown error occurred (9)"). It appears to be an issue with the phone talking over the USB. Suggestions on Apple's site (can't find the link right now) are to try different cables, different USB ports, assure you have no other devices on the USB bus, and try another computer. I've tried all of this and haven't had any luck so far. I'm hoping that either AT&T or Apple will have a replacement phone at this point since this one seems to be bricked
  • Jose Marcelino Level 1 Level 1 (5 points)
    Hey Jim...I actually fixed the issue...by reinstalling iTunes. It didn't work the conventional way of just redownloading and overwriting the existing iTunes program. I erased iTunes completely by using the following Apple Support page. Just follow the instructions on the link and hopefully yours will be up and running again. Must be some old legacy files that isn't compatible and needs to be updated...or some type of bug that needs to be fix. However, I'm now up and running and hopefully you will be too.

    good luck...let me know if it works.

    http://support.apple.com/kb/ht1224
  • karenairdrie Level 1 Level 1 (0 points)
    I have the same problem and have completely uninstalled and reinstalled itunes with the same error still coming up. it even went through the restore process twice, but always ends up with the same error. have tried all the other basic apple suggestions ie different usb port, restart computer, restart iphone, etc. iphone is brand new out of the box!!!