6 Replies Latest reply: Jul 14, 2010 7:41 PM by Nick1028
Nick1028 Level 1 (0 points)
I upgraded from my first gen iPhone to an iPhone 4, and since upgrading I have had issues with my Gmail. When setting it up through the Gmail option, and turning off the archive feature, my attempts to delete the email still result in it archiving. Also, for some reason my mail previews are not always downloading, and, finally, my emails are sometimes coming through twice. Not all of them, but some of them.

I have deleted the account and started anew, I have not however done a hard reset and would like to avoid that, so any thoughts?

iPhone 4, iOS 4
  • jinniferb Level 1 (145 points)
    Those behaviors shouldn't be attributed to your phone, they should be attributed to Gmail. The phone is just now reflecting how Gmail's system actually works, is all.
    Gmail doesn't want you to delete your messages so that they can continue to scan the texts to serve your personalized ads. It's Gmail who is making it intentionally obtuse and giving you the runaround regarding your being able to fully delete a message, not Apple.
  • Nick1028 Level 1 (0 points)
    Actually, I'm not entirely sure whose fault it is just yet as the functionality for delete should be in place given that you could do it in the past.

    To update my original post, I deleted my [gmail]/trash folder in the past, which was generated when creating imap originally, and wonder if that needs to be re-created. Although, I would prefer not to give the fact that having those additional folders was rather unpleasing. Also, keep in mind everything works fine in Apple Mail, just having this string of problems on the new phone.
  • wyattisimo Level 1 (0 points)
    That "gmail/trash" folder is created because you're using your iPhone's local trash folder, which is then synced to Gmail like a regular label. Have you tried specifying the Deleted Mailbox behavior to use the Gmail trash?

    On your iPhone, go to the settings screen for your Gmail account, then Account Info > Advanced. Under the "Mailbox Behaviors" section you'll see "Drafts Mailbox" and "Deleted Mailbox". Select "Deleted Mailbox" and on the next screen select the "Trash" folder on the Gmail server.
  • Nick1028 Level 1 (0 points)
    Yup, already formatted that way.
  • wyattisimo Level 1 (0 points)
    Weird... well, if you already have the "Archive Messages" setting turned off as you said, and you're already using the Gmail trash folder on the server as I suggested, then the only thing I might suggest is to set it up on your phone as a generic IMAP account, rather than a Gmail account.

    After you select "Add Account...", select the "Other" option. Use imap.gmail.com for the incoming server and smtp.gmail.com for the outgoing server.

    Personally, I set up my Gmail this way because it gives me more control over certain options. Then I add an Exchange account to sync my Gmail contacts and calendar. So I end up with a generic IMAP account to sync email and notes, and an Exchange (Google Sync) account to sync my contacts and calendar with the benefit of push. You can use the Exchange account to sync email too, but it provides no option to make deleted items go to the trash--they always archive.

    Here's some info on Google Sync: http://www.google.com/mobile/sync/
  • Nick1028 Level 1 (0 points)
    And for some reason, that worked. I had been using google sync and the automated set up for gmail, but the manual imap setup seems to have fixed it. Thanks for the idea.