Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iPhone Configuration Utility Error

I am receiving an error when trying to launch the iPhone Configuration Utility on a Windows machine. I get iPCU has encountered a user-defined breakpoint. I get it every time I launch it. This worked just fine before the update to iTunes 9.2.

No uninstalls or reinstalls seem to fix it. Any suggestions?

Macbook Pro

Posted on

Reply

Page content loaded

Dec 23, 2010 9:25 AM in response to J_Shiff In response to J_Shiff

I'm sorry, I have to revive this topic. The solution that you provided is for another problem, not this one.
I will explain exactly what happens. I'm using Windows 7 (I suppose iPCU works on Mac OS). I installed it, ran it, and it worked fine. But when I tried to open it again a couple of days after (I restarted my iOS, so I had to do the same thing I did with iPCU), it said "iPCU has encountered a user-defined breakpoint". And the funny thing is, I installed it again on an another computer with Windows 7 in my house, and it also worked when I first opened it, but not the second time.
Please, if someone has a solution, we would be very grateful.

Dec 23, 2010 9:25 AM

Reply Helpful

Jan 24, 2011 5:37 PM in response to jgilroy In response to jgilroy

For Windows XP:

-Uninstall via Add/Remove Software in the Control Panel

-Remove all files in the following directory...
C:\Documents and Settings\your username\Local Settings\Application Data\Apple Computer\iPhone Configuration Utility

-Reboot computer and install a fresh copy of the IPCU for Windows.

*Replace your username with your user name

**Note that the above directory is a hidden directory and will need to be made visible through Tools:Folder Options: View: Hidden files and folders > Show hidden files and folders

Jan 24, 2011 5:37 PM

Reply Helpful

Feb 9, 2011 6:35 AM in response to Junky099 In response to Junky099

I ran into the same issue "...ipcu.exe has encountered a user-defined breakpoint...".

Ran iPCU on the same machine as a different user.... worked just fine.

To resolve for the user w/ issues, I first uninstalled iPCU from Add/Remove, then manually had to go in and remove all profile-specific files & folders. For this particular machine ( Windows Vista Enterprise ), the following folders required deletion:

C:\Users\{UserName}\AppData\Local\Apple
C:\Users\{UserName}\AppData\Local\Apple Computer
C:\Users\{UserName}\AppData\Local\Apple_Inc

C:\Users\{UserName}\AppData\LocalLow\Apple
C:\Users\{UserName}\AppData\LocalLow\Apple Computer
C:\Users\{UserName}\AppData\LocalLow\Apple_Inc

C:\Users\{UserName}\AppData\Roaming\Apple
C:\Users\{UserName}\AppData\Roaming\Apple Computer
C:\Users\{UserName}\AppData\Roaming\Apple_Inc

C:\Program Files\Common Files\Common Files\Apple
C:\Program Files\Common Files (x86)\Common Files\Apple

Hope this helps.

Feb 9, 2011 6:35 AM

Reply Helpful

Feb 13, 2011 2:38 PM in response to J_Shiff In response to J_Shiff

I managed to solve my problem, but I didn't manage to run iPCU. So, as I said, I managed to run it once, but not after that. So that first time I created a profile configurafion (for my college's wireless), but I had to restart my iPod software, and I the configuration installation on my iPod was lost. I recently found out that a configuration profile is an XML file, and I've searched my computer if maybe it didn't delete itself upon uninstallation of iPCU, and it didn't 🙂
So, what I did was upload it on a server, and typed the URL in my iPod, and it worked, it asked me to install the configuration 🙂
So, if anyone by any chance has already made a configuration profile on his iPCU, and he needs to install it again, but cannot run iPCU anymore, he can upload it somewhere and do what I did. If he needs a server, he can contact me, and I can upload it for him (janko@anor.irb.hr)

The path of my configuration profile (Windows 7) was: C:\Users\Your username\AppData\Local\Apple Computer\MobileDevice\Configuration Profiles

(You have to have "Show hidden files and folders" enabled)

Feb 13, 2011 2:38 PM

Reply Helpful
User profile for user: J_Shiff

Question: iPhone Configuration Utility Error