Announcement: Update to iOS 12

Enjoy a faster and more responsive experience as well as fun new features, like Memoji and Camera Effects.
Get iOS 12 > https://support.apple.com/ios/update

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: app store "unable to purchase" / not like the real iTunes store

I constantly get an "unable to purchase" message when I am trying to download apps. I have a full signal, i know I am putting my password in right and I know they are iPad compatible cause some are iPad apps.

Apple stated that we will have the real iTunes store but all I get are recommendations for albums that came out in 2006.

Any suggestions on what to do?

iPad 32GB Wifi only, Windows XP

Posted on

Reply

There’s more to the conversation

Read all replies

Page content loaded

Jun 29, 2010 11:27 AM in response to Jisatsu6189 In response to Jisatsu6189

It happens to most of us once in a while but it seems like those ppl who get it a lot end up having some issue with their payment method. Any chance the CC you have on file with Apple on your iTunes account expired or something along those lines?

Jun 29, 2010 11:27 AM

Reply Helpful (2)

Sep 23, 2013 5:25 PM in response to Jisatsu6189 In response to Jisatsu6189

I've had the same problem for several days after upgrading to iOS 7, in some cases I was able to download a few apps, but when trying to download a few specific apps, I kept getting the message 'Unable to Purchase [program] could not be purchased at this time. Please try again later.'.


I tried to log out and back into App Store, I restarted my iPhone, I changed my settings to download updates in he background, checked my credit card details etc, but nothing worked. I started noticing today that the apps had an icon showing that they had already been downloaded but were not on my phone (cloud with a down arrow), but no matter what - I'd click the button to download, would be prompted for my password, waited a few seconds, and then I'd get the message again - 'unable to purchase'.


I got a tip from a friend to change the language on my phone (I'm in Norway, using the Norwegian App Store, but phone settings set to English (US) language). Changed the language to Norwegian, and voila - the apps downloaded fine!!


Actually ALL the apps I had been trying to download in the past few days downloaded automatically...

Sep 23, 2013 5:25 PM

Reply Helpful

Sep 26, 2013 3:49 AM in response to Jisatsu6189 In response to Jisatsu6189

I also had this issue on my iPhone since upgrading to IOS 7. None of the solutions above helped. I was unable to download any app from Appstore.


Finally I managed to come up with a solution.


If you have enabled "General->Restrictions" an have the "Require Password" option set to "Immediately", then try to set the "Require Password" to 15 minutes instead.


This solved my problem and I have confirmed that if I change back to "Immediately" the problem reappears.


Hope this helps someone...


Regards,


L.A.N

Sep 26, 2013 3:49 AM

Reply Helpful (1)
User profile for user: Jisatsu6189

Question: app store "unable to purchase" / not like the real iTunes store