10 Replies Latest reply: Feb 18, 2014 6:56 PM by kelculus
Jisatsu6189 Level 1 (70 points)
I constantly get an "unable to purchase" message when I am trying to download apps. I have a full signal, i know I am putting my password in right and I know they are iPad compatible cause some are iPad apps.

Apple stated that we will have the real iTunes store but all I get are recommendations for albums that came out in 2006.

Any suggestions on what to do?

iPad 32GB Wifi only, Windows XP
  • MuddyBulldog Level 2 (215 points)
    It happens to most of us once in a while but it seems like those ppl who get it a lot end up having some issue with their payment method. Any chance the CC you have on file with Apple on your iTunes account expired or something along those lines?
  • houndoggie Level 1 (0 points)
    I had this problem yesterday. I solved it by doing this:

    Settings>Store>Sign Out.... then exit settings, go back in and sign in again.
  • aszart Level 1 (0 points)
    Just to confirm I was having exactly the same issue and the Settings->Store logout/login approach fixed mine too.
  • seanys Level 1 (0 points)
    I fixed this by just logging in to "View Account" in "Settings / Store".
  • Isaac-gabriel01 Level 1 (0 points)

    thanks

  • Cookietk Level 1 (0 points)

    I've had the same problem for several days after upgrading to iOS 7, in some cases I was able to download a few apps, but when trying to download a few specific apps, I kept getting the message 'Unable to Purchase  [program] could not be purchased at this time. Please try again later.'.

     

    I tried to log out and back into App Store, I restarted my iPhone, I changed my settings to download updates in he background, checked my credit card details etc, but nothing worked. I started noticing today that the apps had an icon showing that they had already been downloaded but were not on my phone (cloud with a down arrow), but no matter what - I'd click the button to download, would be prompted for my password, waited a few seconds, and then I'd get the message again - 'unable to purchase'.

     

    I got a tip from a friend to change the language on my phone (I'm in Norway, using the Norwegian App Store, but phone settings set to English (US) language). Changed the language to Norwegian, and voila - the apps downloaded fine!!

     

    Actually ALL the apps I had been trying to download in the past few days downloaded automatically...

  • L.A.N Level 1 (0 points)

    I also had this issue on my iPhone since upgrading to IOS 7. None of the solutions above helped. I was unable to download any app from Appstore.

     

    Finally I managed to come up with a solution.

     

    If you have enabled "General->Restrictions" an have the "Require Password" option set to "Immediately", then try to set the "Require Password"  to 15 minutes instead.

     

    This solved my problem and I have confirmed that if I change back to "Immediately" the problem reappears.

     

    Hope this helps someone...

     

    Regards,

     

    L.A.N

  • himmel2064 Level 1 (0 points)

    I was having all the same issues and this was the one that worked for me.

  • Nugh Level 1 (0 points)

    Yep, this one did it for me too. There's some gremlins in this OS7...

  • kelculus Level 1 (0 points)

    I have no idea why, but this worked for me too. I had tried all sorts of other tricks, but this is the only thing that worked. Thank you SO much for posting this.