10 Replies Latest reply: Aug 6, 2010 12:33 PM by digitalcassette
mudgewah Level 1 (0 points)
I have a brand new shiny iPhone 4. Yesterday, it was activated on the network. I turned it off and on and the activation started, I could make calls etc. But the Facetime icon, and Camera icon have vanished.

I have checked config (settings/phone/facetime).
I have checked restrictions (settings/general/restrictions - phone and facetime are greyed out, and cannot be changed).
I have checked all pages.
I have plugged it into XCode and looked at the logs.
I have rebuilt it (twice) from scratch as a new iPhone.

When I did a rebuild, it seemed to have the camera initially, but I synced the phone it lost the camera icon. I can't find any logged error information, or relevant topics on the net. What the **** is going on? I used the camera all weekend (while waiting for my number to port) and it took photos from both front and back cameras beautifully - so it clearly works. As does the video - again both front and back.

I would really like some advice. I thought it may be installing the GMSeed version of iOS4 from XCode when I rebuilt, but I checked with a colleague, and the OS Version 8A293 is identical. I'm using Vodafone UK. As is my colleague.

iPhone4, iOS 4, Camera,Facetime,Vodafone UK
  • mudgewah Level 1 (0 points)
    I have to check this out, but when I spoke to Apple they said this is probably a corrupted IPSW file. Will confirm.
  • rollcenter Level 1 (0 points)
    My camera app went missing last night. I used it a few hours earlier, the phone was not turned off and this morning I noticed it missing from the home screen. I've restarted the phone with no change.

    iTunes says the phone is up to date. The applications are grayed out under iTunes Apps tab and I can't adjust anything. The camera app does not show up on any of the screens that are visible without scrolling.

    Syncing the phone did nothing to change the situation. I have not restored yet. I'm hoping to avoid this.
  • rollcenter Level 1 (0 points)
    Called tech support. Restored the phone to a backup and in the last legs of sync all the apps would not install for an unknown error (0xE8003FFE) that Apple is looking into.
  • rollcenter Level 1 (0 points)
    Senior Tech support got on the line and asked if there were any Restrictions enabled. Earlier yesterday I did set restrictions on Safari and YouTube, NOT Camera. When we disabled restrictions the camera magically appeared.

    Synced phone to iTunes and all is back together as before, with the camera operational. Might be a bug with restrictions.
  • mudgewah Level 1 (0 points)
    Complete reinstall with a fresh IPSW file. Worked for a few minutes, but while moving apps around, changing background image, and logging into various apps, and the camera was gone again.

    Going to call Apple yet again...
  • mudgewah Level 1 (0 points)
    I've been told to take it back to apple. Clearly whatever is wrong with my phone is not resolvable without a screwdriver.
  • mudgewah Level 1 (0 points)
    Nope. Totally weird, didn't go to Apple and cancelled appointment because 3 days after the last rebuild the camera just started working. Outlined the whole experience here: http://www.wawra.co.uk/node/9 but still. Weird. Will update if anything else happens.
  • Plys1111 Level 1 (0 points)
    I have the exact same problem..

    I did a restored and step by step install new profile from zero. What I found is if you remove Email "exchange" account from Mail all camera and facetime came back..

    I think this is a issue which should report to Apple support.

    I tried with iPhone Unlock from UK and it also have the same problem
  • neuroanatomist Level 7 (31,690 points)
    Plys1111 is correct - I suspect you have an Exchange (corporate email) account, One of the security policies of Exchange is the ability to disable the camera on mobile devices. It worked for a while after the reinstall, until your phone accessed the Exchange server which disabled it.

    You need to contact your Exchange Server admin / IT department and ask them to remove the camera restriction.
  • digitalcassette Level 1 (0 points)
    The problem IS related to exchange but I'm not entirely sure how as of yet.

    I have 2 exchange accounts setup (both are connected to gmail to sync contacts). When I deleted one of them my camera application came back and so did all camera functionality. The one that I deleted is a corporate gmail account. Will do more testing but please let me know if this relates to your issues as well.