Previous 1 2 Next 17 Replies Latest reply: Aug 10, 2010 6:17 PM by PAHU
mccreedy Level 1 Level 1 (0 points)
Hi everyone.
I have recently upgraded to Snow Leopard and since then I haven't been able to print. In the office we have a Canon IR C2880i and I connect via our internal network. I have tried downloading the new Canon ppd's and the UFRII v2 but to no avail. When the printer is installed and I try to print, a dialogue box comes up saying that the computer cannon connect to the printer.

Any ideas as how I can solve this one?

Thanks in advance
Danny

Mac OS X (10.6.4)
  • satcomer Level 4 Level 4 (1,110 points)
    Open System Preferences->Print & Fax and delete the printer and then reset the printer system. Then re-add the printer again to see if you can print to it.
  • PAHU Level 6 Level 6 (15,750 points)
    Hello Danny,

    The UFRII v2.10 driver uses bidirectional communication to determine the availability of the Canon device. If there is a problem with this communication then you will not be able to print. To therefore check this communication function, select to print a document from an application like Preview, and within the print dialog change the menu from Preview to Special Features. In this panel you will see an image of the copier and under this view will be the button Printer Info. Press this button - you will briefly see a message stating "Acquiring information" and then the Printer Information pane should appear showing the device configuration and paper availability.

    If the Printer Information fails to be obtained then this explains why you have not been able to print. You mention that you upgraded to Snow Leopard. If you had the UFR2 driver working on Leopard before upgrading to Snow Leopard then there will still be driver files that could be interfering with this operation. While the reset printing system mentioned by satcomer will remove your current printer queues it will not stop this error caused the UFR2 Backgrounder service, which is responsible for this bidirectional communication. Therefore you will need to manually trash the associated files for the UFR2 driver from your Mac and start again.

    According to the UFR2 User Guide on page 2-8, the driver can be removed from the Mac by trashing the following folders. Note that you should delete the print queue first, by opening Print & Fax, selecting the iRC2880 in the Printers list and pressing the minus button.

    System Volume > Library > Printers > Canon > UFR2
    System Volume > Library > Launch Agents > jp.co.canon.UFR2.BG.plist
    System Volume > Library > Printers > PPDs > Contents > Resources > en.lproj > CNTD**Z*2.ppd.gz
    (where * indicates the printer model and 2 indicates the language of driver used)

    With these files removed you can then empty the trash, although you may have to open Activity Monitor and stop the 'UFR II Backgrounder' service before you are able to remove all the files from the trash.

    With these files removed you are now ready to install the UFR2 v2.10 driver again. Once you have installed the driver files you can add the printer queue, selecting IP > LPD for the protocol. Once the queue is created you can then select to print from Preview again and check the Printer Info function before actually pressing the Print button. If you are able to obtain the printer info then you can okay this window and select to Print the document.

    Hope this helps you but if not then please reply.

    Pahu
  • mccreedy Level 1 Level 1 (0 points)
    Hi satcomer/PAHU.
    Firstly, thanks for your response.
    Ok, well before I upgraded to Snow Leopard I wasn't using UFRII drivers, I was using a ppd downloaded from the Canon site. After upgrading my iMac I had to reinstall the printer as our IT dept changed it's IP, and that is when I had the problems. I tried using the old ppd that I was using before, and using generic printer profiles, all the other ppd's, downloading new ones... I tried everything!! I got various results, like the printer churning out 45 blank sheets, no communication with the printer at all, low quality black and white....etc etc. So I suppose what I need is to completely remove all drivers and find the one which works on OS X 10.6.4 for the IR C2880i. May I just state that I am in Spain, not in the US... don't know if that changes anything.

    Many thanks! This is driving me crazy, hope we can find a solution soon!!!
  • PAHU Level 6 Level 6 (15,750 points)
    Hi Danny,

    Thnx for the update. If you were using the PPDs previously then you should be able to continue doing so with Snow Leopard. Unlike the UFR2 or PS driver that Canon makes, the PPDs did not have to be written for Snow Leopard so whatever you had previously should work. Here is a link to the latest PPDs that Canon is offering.

    http://support-au.canon.com.au/contents/AU/EN/0100267504.html

    One concern regarding your recent info is the output of blank sheets. This can occur if you use a Postscript driver (aka PPD) but the printer does not support Postscript. But if you are confident you were using the PPDs previously then this symptom is most likely due to some other cause.

    At this stage I agree that you should remove the UFR2 driver using my previous information. Then download the PPDs via the link above and run the installer to copy the files to the correct location on the Mac. With the PPDs installed you can select to add the printer queue, using IP > LPD or HP Jetdirect-Socket. Then in the Print Using menu, after choosing 'Select Printer Software' type 2880 to short-list the search. Ensure you select the model showing "Canon iR C2880/C3380". Any other C2880 models in the list could cause problems if selected.

    See how that goes and reply if needed...

    Pahu
  • satcomer Level 4 Level 4 (1,110 points)
    First make sure your Mac can see the printer. Get the IP of the printer and then put that IP into your favorite browser window. The networked printer's wiki should come up, this will surprise you IT department!

    Now go to System Preferences->Print & Faxing and delete the printer. Then right click in the pane a do a reset printing system. Then re-add the printer using IP adding version discussed in the the Apple article Mac OS X v10.6: Mac 101 - Printing. See if any thing mention in the article helps you.
  • mccreedy Level 1 Level 1 (0 points)
    Hi guys.
    Ok, I did what you said satcomer, and the IP I had wasn't working. The IT department changed the IP from 10.0.34.35 to 10.0.35.34 to avoid miscellaneous people printing and using our paper/ink etc. I deleted the printer and added it again using this new IP and there was the problem. All the PC's in the dept. are using the new IP, but when I typed both into Firefox only the OLD one came up with info. I have added the printer again, using the OLD IP and the UFRII v2 drivers and IT HAS WORKED!!!!!!!!!!!!!!!!!!!
    The only problem is that I tried to print a sheet from Word and it missed off a bit of the text, for some reason. Any ideas?

    Thanks again... you are my saviours!
  • PAHU Level 6 Level 6 (15,750 points)
    Within Word, click File > Page Setup. For the 'Format for' menu, select the name (or IP address) you have set for the UFRII driver. Still in Page Setup, check that you have Paper Size set to A4 and the scale set to 100%. Click OK to save these settings.

    Now select to print (File > Print) and change the menu from Copies & Pages to Paper Handling. Tick the box 'Scale to fit paper size' and ensure the destination paper size shows A4. Now press Print and see how that looks...
  • mccreedy Level 1 Level 1 (0 points)
    Hi PAHU,
    It's not a problem with the page size, it is actually missing out chunks of text. I'll have a play around and see if I can spot the error. Maybe it's something to do with the settings after installing the printer.

    Thanks again
  • mpayne Level 1 Level 1 (0 points)
    Just found this thread after having upgraded to SL, and now can't print to our Canon.
    There are a bunch of PPDs for Canon, all except for the one you listed to delete. I am going to empty all of the Canon PPDs, reinstall the v210 drivers and hope this works. Otherwise, I will be staying overtime.
  • PAHU Level 6 Level 6 (15,750 points)
    The PPDs shown above are for the UFR2 driver. Canon also makes a PPD-only set for the imageRUNNER series that have a different prefix (CN**X1.PPD.gz) to the UFR2 driver PPDs. And since May 2010 there is a PS3 driver that supports the iR C2880i. So there are a number of drivers available depending on the configuration of your copier. So if you have no luck with reinstalling the UFR2 v2.10 driver then please reply.
  • PAHU Level 6 Level 6 (15,750 points)
    mccreedy wrote:
    It's not a problem with the page size, it is actually missing out chunks of text.

    What application are you using and what are the files types, ex PDF, DOC, RTF?

    I'll have a play around and see if I can spot the error. Maybe it's something to do with the settings after installing the printer.

    There are a number of settings available within the driver under Quality > Quality Settings that can assist with images not printing correctly but there is not that much that usually helps with missing text. You could try opening the Quality menu, selecting Quality Settings and changing the Graphics Mode to Raster.
  • mpayne Level 1 Level 1 (0 points)
    PAHU,

    our printer is actually the 4080i but I presume we are all having similar issues.
    I have d/l the latest driver at the Canon site for 4080i under SL.

    Still trying to print gives me the message, that the printer is not compatible.

    What's odd is that everyone else here under SL 10.6.2 prints fine with the 2.0 driver.
    My installer is for 10.6.4... 2.0 driver nor 2.1 (UFRII) work.
    We are stumped here.

    I was about to delete ALL the CN*X1.PPD.gz, not just the 4080 one to see if it works, but I haven't gone there yet.


    edit: we have deleted all the previous Canon related (as described in the manual) files numerous times to be sure.

    Message was edited by: mpayne
  • mpayne Level 1 Level 1 (0 points)
    D/L'd the PPD from late 2009 on Canon site, and we seem to be working now.
  • RNDishman Level 1 Level 1 (0 points)
    Pahu:

    You seem to be the expert in the Canon iR C2880i as it relates to the Mac. For what it is worth, a couple of years ago I experienced a problem getting my Mac (pre SL) to communicate with my office's Canon C2880i, but an exhaustive search via Google lea me to many discussions that you had written to many people, that helped me to find a driver that would allow me to print (albeit not the "normal" Canon driver for my printer). You should know that many find your help useful, even months or years after you provided that help. Your assistance has not gone unnoticed.

    As luck would have it, my computer recently began having issues printing to this same printer and I, as many others, have begun to wonder if it had something to do with the upgrade from 10.6.3 to 10.6.4. My error came in the form of a pop up screen (much like a syntax error) listing a "cupstomcdUFR2" error with a slew of technical data I cannot even begin to understand. A bit different for other's errors and I do not recognize how they see "error -83" (for example - not a real error number). Regardless, my print options now have shrunk to zero. I have tried everything you have suggested to others, except the PS option which my printer does not support (at least is not shown when I use the web to access the printer as you have suggested to others). I have gone into my "Library" and deleted the files you suggested and re downloaded the "new" driver from canon for this printer, still the same error. I have tried other drivers that I thought might work, but most random picks either did not work to even allow the printer to communicate, or the print was colorless. Seems I recall the original driver that I did get to work always gave me a pop-up requiring a user name and password. I also just used "1" for the user name and left the password blank. Not sure what driver I used, but at least it worked. Well, not anymore.

    BUT, either in this or another help string, you listed the web link for the UK version of the C2880i. Much to my surprise, when I went to print a color "test" document, it worked. Not sure why, not sure for how long. But, for now at least, it does work. I have begun a long download of a much larger 10.6.4 file which apparently has some "fix help files" in it in order to help troubleshoot certain problems. The file is much larger than the normal update Apple sends out. If I have print issues again, I will run the download. One forum site suggested that this file may help as it has done for others. We will see - or hopefully NOT see because your UK driver works!!

    I just wanted you to know of my issues and what fixed (hopefully) it for me. But, any thoughts or suggestions would be helpful, in case I or others have more problems. I look forward to your response!!

    R/
    RND
    Virginia, USA
Previous 1 2 Next