Previous 1 2 Next 15 Replies Latest reply: Aug 11, 2010 11:23 AM by navstr
oclear Level 1 Level 1
*I am having several problems with my yahoo mail since i updated to os4 on my iphone 3gs. the main problem is i cannot send any email. the error message i keep gettin is "a copy has been placed in your outbox. The sender address 'my email' was rejected by the server". has anyone else got this problem?*

iPhone 3GS, iOS 4
  • Catnhat44 Level 1 Level 1
    Yes, I developed the same problem when I upgraded my iPhone to 4.0

    I see the header and the first few lines in the preview, but when I attempt to open it, there is no message body. There are also no attachments.

  • oclear Level 1 Level 1
    any ideas where we can get an answer to our problems? I am seriouslt thinking or reverting back but i like the features of os4!
  • Steve Friend1 Level 1 Level 1
    Same issue here. Very annoying.
  • Psycho B Delic Level 1 Level 1
    Since upgrading my 3gs to OS4 ALL my mail accounts have stopped being able to see attachments or the body of the message. Gmail, Yahoo, Exchange. So far, haveing failed to find a solution I have simply deleted the accounts as getting notifications of emails you can't see is pretty irritating. I tried deleting and reinstating the accounts to no avail. Glad I'm not the only one with this problem - but no nearer a solution.
  • Psycho B Delic Level 1 Level 1
    Of course - if you just reboot the phone the message body/attachment problem resolves itself - It's just like a windows PC in that respect. How quaint.
  • baztiddy Level 1 Level 1
    I'm having issues too. Since updating to iOS4 I have had the following problems with my Yahoo Mail account:

    - Push no longer works. 15 minute 'fetch' is the best I can have.

    - If I get 1 message it says I have 2, if I have 2 it says 4 etc (even though the actual number of messages in my Inbox is correct).

    - "ghost" emails. No sender, no message, but it's in my Inbox.

    - You move a message to a folder and it takes about 5 minutes to appear - if at all. Some messages have totally disappeared on my phone, but are visible when I look online. Syncing doesn't change this.

    - Sometimes a message will be successfully moved, but when I go back to my Inbox it's still there. I open it and it says the message can't be downloaded. I delete it and get a message saying it can't be moved to Trash. But then it's no longer in my Inbox.

    So, in essence, iOS4 has really messed up Yahoo Mail.
  • Musictech Level 1 Level 1
    After much research I found this on CNET and it seems to work. Follow these steps exactly.

    On your iphone, delete your Y! Mail Account.
    Turn off and then turn on iPhone.
    Add your Account back to your iphone.
    Turn iPhone off.
    Go to your Computer and log out of your Y! Mail, Messenger, and any mail notification software you have.
    Log back in to your Yahoo Account.
    Turn iPhone on.
  • newford Level 1 Level 1
    I had a similar problem, could send and receive emails via wifi, receive but not send on 3G. In the end i deleted the yahoo account from my phone and created a new account by selecting other rather than Yahoo from the add account list and inputting all the settings manually . Settings used:

    Adress +Your email+

    Incoming mail server (host name)
    user name +your email+

    outgoing mail server

    Hope this helps
  • I'mBack2Mac Level 1 Level 1
    I tried this (except with US settings) and it only synced in my Inbox (no folders) and it thought all of my messages were unread. Needless to say, I deleted this setup and did some more research.

    Yahoo suggests deleting the mail account on the iphone and turning it off. Then going in and changing your Yahoo! password using your PC. Then add the account back to the iPhone. According to Yahoo!, this process resets the synchronizing between the device and the account.

    I'm just trying this now, I'll post an update if the push lasts more than a day or two.
  • mritter36 Level 1 Level 1
    Re: 2 msgs when there is one and the ghost msgs: I have found a solution that seems to work, although it's crazy and I do hope gmail gets this problem really solved soon. Solution: when those two situations occur, open your spam mail. There may be nothing there or spam msgs will download and you can then delete - it doesn't seem to matter which. When you close the spam mail, Voilà! Your inbox is corrected. Like I said, it makes no sense but it works
  • vistaphotos Level 1 Level 1
    Having the same issue with iPod Touch 3G, none of the suggestions here work Was happy with the product, now HATE it, not being able to send mail makes it pretty useless in my eyes.
  • I'mBack2Mac Level 1 Level 1
    So after changing my password for my Yahoo account, I am now consistently getting my e-mails pushed to my phone. It has been several days and usually by now the temporary fixes would no longer work. This seems to be a permanent fix.

    Here are the steps recommended by Yahoo! which are part of this link (

    If there are problems, consider going through this process to make a clean password which can be the source of some problems:

    1. Delete the Yahoo! ID on currently on your iPhone.
    2. Turn off your iPhone.
    3. Log into your PC and change your password. Many errors care caused by the way the iPhone encrypts some characters. Please ensure your new password has no special characters (any character which is not a letter or a number, such as @ or *). This will reset our registration systems and ensure that Apple treats your ID as a new connection.
    4. Turn your iPhone back on.
    5. Set up your Yahoo! account on your iPhone using the Yahoo! option. Please make sure that you enter your new password when setting up the account.
    6. Make sure that your iPhone is not set to Manual Push. To verify this, please take the following steps:
    1. Open Settings and Select Mail > Auto Check
    2. Ensure that Auto Check is not set to Manual.

    Those steps should trigger a re-sync between your Apple Device and our systems. Try mail again.
  • vistaphotos Level 1 Level 1
    Thanks for the tip. I think I tried it before, but tried it again to be sure. Sorry to say that it makes no difference My solution for now is to run Yahoo Mobile mail in Safari
  • easterndiver Level 1 Level 1
    Thank You, Out of all the other tips, as good they were and made sense and I tried them, __this is the one that worked for sure for me and my iPhone 3Gs__
Previous 1 2 Next