6 Replies Latest reply: Aug 7, 2010 4:43 AM by Baldy1965
ronny.vos@skynet.be Level 1 Level 1 (0 points)
I installed ios 4 on my iPhone 3G yesterday and now my WI-FI is disabled. I can not enable my WI-FI. I tried to reset my network settings but bad luck. I still have no possibility to enable my WI-FI. Is this one of the many problems in ios 4. is there a solution for this problem?
Thanks in advance.
eRVe

iPhone 3G, iOS 4
  • Southernpolo Level 1 Level 1 (0 points)
    I'm also having the same problem on my 3GS. I upgraded to iOS4 and had no problems at all for a few days. Halfway through the day yesterday (Monday) it just stopped working completely. It will not pick up my home network, nor any of the other networks that are in the area. My router seems okay- none of my other computers are having any issues - just my phone.

    I've turned the 3GS on and off, turned airplane mode on and off, and also turned off Wifi connections, and even synced my phone to see if it might kick everything back in gear, yet to no avail.

    Any solutions out there?
  • DH87 Level 1 Level 1 (0 points)
    Yup I'm having the same problem...
  • Southernpolo Level 1 Level 1 (0 points)
    Just tried ONE MORE TIME to reset my network settings..and it worked this time. We'll see how long it holds up - pretty sure I've read that it might "forget" again in other threads...
  • michaelg66 Level 1 Level 1 (0 points)
    I have and had the same problem...my wifi came back after
    many network resets only to have lost it again after an app
    crash.
  • Stefan P. Level 1 Level 1 (0 points)
    Yea. I am having a similar problem. The phone sees my wifi networks, but when I click on them and it prompts me to give a password, afterwords it says "could not connect to network..." I just jailbroke my phone and downloaded iOS4, but the problem started occurring right before I jailbroke the phone (right after i updated firmware to iOS4).

    I have tried network reset

    I have tried checking routers, etc.

    I have tried "reset all settings"

    I have tried hard reset

    any ideas...?
  • Baldy1965 Level 1 Level 1 (0 points)
    I am having the same problem. Any answers