Skip navigation

Netflix won't go into full screen mode in Firefox.

60203 Views 51 Replies Latest reply: Feb 11, 2012 12:49 PM by heatherfromvi RSS
1 2 3 4 Previous Next
jafraga89 Calculating status...
Currently Being Moderated
Jun 29, 2010 8:36 PM
So I'm not sure if this is the right place to post this but anyways. I just used migration assistant to transfer everything from my old 13" macbook 2008 to my new MBP 15" 2010. So after solving one problem with silverlight that wouldn't even let me stream movies from netflix because I was getting the error N8156-6013, I've now run into another problem . One I start streaming a movie on my laptop within firefox and want to go full screen I can't. The video will either stop for a second and continue on normally, or the browser window will go completely black (although the sound is still working.) One remedy I have found is turning the automatic graphics switching off; However it's strange since it works in safari just fine and I don't have a problem watching other things in full screen. Any help/suggestions would be greatly appreciated. Thanks.
Macbook Pro 15", Mac OS X (10.6.4)
  • Templeton Peck Level 9 Level 9 (57,705 points)
    Currently Being Moderated
    Jun 29, 2010 9:03 PM (in response to jafraga89)
    I'm not sure if this is the right place to post this but anyways.


    Nope. Neither NetFlix or Firefox are Apple products. Try the Firefox forums: http://forums.mozillazine.org/index.php?c=4
    iMac 2.66Ghz, 2.66Ghz MacBook Pro, iPhone 4, Mac OS X (10.6.4)
  • 123walter Level 1 Level 1 (15 points)
    It does it with Safari as well. Go to Library/Application Support/Microsoft/...and DELETE Playready folder. Reboot and watch yer movie. I have also watched Netflix movies on my TV using component cables and ipad.(Mac comp cables with power plug)
    Macbook Pro, Mac OS X (10.6.3), Ipad, Iphone, MBP
  • RichardFranklyn Calculating status...
    Currently Being Moderated
    Aug 8, 2010 11:55 PM (in response to jafraga89)
    exact same problem here - 2010 15" HD graphics mbp, plays in Safari but when attempting fullscreen in Firefox: flash of white, then screen goes black while audio keeps playing. Tried deleting FF/silverlight and all associated files and reinstalling several times - absolutely cannot fix this.

    This is MOST CERTAINLY an issue with the Mac and not FF/silverlight - this is a brand new, clean install of OS X on a new computer. jafraga89, your observation about the graphics switching is a good lead - this "genius innovation" is likely the cause of the problem.

    I have been having major issues with this computer (imovie kernel panic/crash when trying to capture files from camera harddrive, Windows virtual machine that was in sleep mode crashing/irretrievably corrupted after the VM woke up from sleep in a different graphics card than it fell asleep in, kernel panic/crash trying to install other apps). I ran a full hardware diagnostic that came up clean, so I did a clean OS X install and now this. I am also getting audio glitches/pops and horizontal lines across the screen while watching streaming netflix in Safari.

    Majorly not impressed - i want to return this computer but i've had it for about a month now so technically too late...
    15" 2.66 GHz MBP 1680 x 1050, Mac OS X (10.6.4)
  • sailthegnar Calculating status...
    Currently Being Moderated
    Aug 23, 2010 12:53 PM (in response to jafraga89)
    I'm having the same exact problem coming from the same exact background. A data migration from my old macBook pro to a 2010 macBook pro, has caused the same Netflix viewing problems to a T. This must be some kind of universal issue, because the details of your problem are identical to mine. Has anyone had luck resolving this issue?
  • coreyfs Calculating status...
    Currently Being Moderated
    Aug 27, 2010 11:25 PM (in response to jafraga89)
    I have the EXACT same issue as well. It worked fine until I migrated data that was on a 24" iMac to my mbp. It will work if you go to system prefs and energy saver then uncheck auto graphics card switching. That is fine other than the lower battery life. I am thinking about creating a new user and copying just my files to the new user, not the backup files
    15" MacBook Pro Mid 2010, Mac OS X (10.6.4)
  • miekBuk Calculating status...
    Currently Being Moderated
    Sep 13, 2010 8:36 PM (in response to coreyfs)
    I have what appears to be the same situation. Profile and programs for Silverlight moved from another computer for Netflix. Request for full screen goes to black screen w/ no full screen but sound. And changing to "Energy Saver", "Automatic Graphic Switching" to un-checked allows full screen to work on Netflix.
    mac pro 15, Mac OS X (10.6.4)
  • vancouveryogi Level 1 Level 1 (85 points)
    Currently Being Moderated
    Sep 23, 2010 11:12 AM (in response to miekBuk)
    I was having the same issue (full screen playback wasn't working). In my case upgrading Silverlight (http://www.microsoft.com/getsilverlight/) fixed the problem. It now works like a charm, even with my dual monitor setup.
    MacBook Pro, Mac OS X (10.6.4)
  • hettie Calculating status...
    Currently Being Moderated
    Oct 2, 2010 12:15 AM (in response to jafraga89)
    I have exactly the same issue with a machine I've had a little more than a month. I unchecked the automatic graphics switching in energy saver, but I still have the problem with fullscreen going black with audio running. I'm wondering if anyone has found a different solution or if there's a step I'm missing. the thing is, I'm smart enough to google my problem and try a couple of simple-seeming fixes, but I really don't know &#%^. could someone take a minute explain every last little step they took to solve this problem? it would be much appreciated...
    macbook pro 6, 1, Mac OS X (10.6.3)
  • vancouveryogi Level 1 Level 1 (85 points)
    Currently Being Moderated
    Oct 2, 2010 7:21 AM (in response to hettie)
    @hettie - have you tried upgrading Microsoft Silverlight (http://www.microsoft.com/getsilverlight/). I had the same issue and upgrading this software fixed the issue.
    MacBook Pro, Mac OS X (10.6.4)
  • lurckio Calculating status...
    I'm running the very latest Silverlight version on a brand new Macbook Pro (3 weeks old), but I'm still getting this. It works fine in Safari and Chrome - looks like a firefox specific bug to me.
    Mac Pro, Mac OS X (10.6.4)
  • lljk Level 1 Level 1 (0 points)
    Watching in Safari 5.0.3 worked for me.
    Macbook Pro, Mac OS X (10.6.2)
  • mtbenson Calculating status...
    Currently Being Moderated
    Dec 14, 2010 7:57 PM (in response to jafraga89)
    Having the exact same problem, using Firefox. Fill screen does work in Safari, though. I'm getting tired of troubleshooting this and guess I'll just use Safari for Netflix...
    MacBook Pro, Mac OS X (10.6.5)
  • mattgilbertnet Calculating status...
    Currently Being Moderated
    Jan 4, 2011 9:46 PM (in response to miekBuk)
    miekBuk's suggestion of unchecking "Automatic Graphic Switching" in "Energy Saver" System Preferences worked for me.
    MacBook Pro, Mac OS X (10.6.5), FF 3.6.13, latest Silverlight as of Jan 3 2011
  • KVillalobos Calculating status...
    I have had the same exact problem as the one in this post. Two of the posts are correct for me. Netflix did work in full screen mode in Safari as well as going into your system preferences/energy saver/ and unchecking the automatic graphics switcher worked perfectly.
    17" unibody macbook pro, Mac OS X (10.5.5), NEW
1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.