8 Replies Latest reply: Aug 14, 2010 4:37 AM by manuelgarciia
tiggerjamesward Level 1 Level 1 (0 points)
I found out there was a new iPod touch software (4.0) and itunes said that i needed to update to get 4.0 so i downloaded and installed it and done everything it said but when i try to run it says "Entry Not Found" then it says "itunes error 7 (windows error 127)". Is there anyway to fix this? If so please tell me how because i really want ios4 for my ipod touch 3g.

Message was edited by: tiggerjamesward

Acer Extensa 4420, Windows Vista
  • b noir Level 9 Level 9 (71,995 points)
    i downloaded and installed it and done everything it said but when i try to run it says "Entry Not Found" then it says "itunes error 7 (windows error 127)".


    That sounds like trouble with your Apple Application Support, tigger.

    Just doublechecking that before proceeding ... what dll file is being referenced in the "Entry not found" message? (For example, CoreFoundation.dll, webkit.dll, etc.) Precise spelling, please.
  • omargt1 Level 1 Level 1 (0 points)
    im having trouble. i recently brought the new iphone 4. when i connected it to itunes it wouldnt inport the songs. just the apps. i decided to update itunes to the new verison 9. when install it it said installed successful but the problem is when i open itunes its informing me that

    [itunes.exe-entry point not found]
    the procedure entry point
    _CFRunLoopGetWindowsMessageQueueMask could not be located in the dynamic link library CoreFoundation.dll.

    after that this pops out.......

    itunes was not installed correctly.please reinstall itunes.
    Error 7 (windows error 127)

    thanks for the help.
  • b noir Level 9 Level 9 (71,995 points)
    Yeah, that's trouble with your Apple Application Support, omar.

    Which Windows OS are you using? XP, Vista or 7? If it's Vista or 7, do you have a 32-bit or 64-bit version?

    (Those things make a difference to how we go about trying to fix this one.)
  • xero1420 Level 1 Level 1 (0 points)
    hi im having the exact same problem. im using vista home premium.

    PLz help me thank you
  • tanner roy Level 1 Level 1 (0 points)
    ya im having the same problem it starts with procedure entry point _CFRunLoopGetWindowsMessageQueueMask could not be located in the dynamic link library CoreFoundation.dll. followed with i tunes not installed correctly. please reinstall. error 7 (windows error 127) i have windows xp with a 64 bit. please help me use my i phone!
  • chewingyu Level 1 Level 1 (0 points)
    I am having a similar problem. The message I got was a pop up window for "iTunes.exe - Entry Point Not Found" was "The procedure entry point__CFConstantStringClassReference could not be located in the dynamic link library CoreFoundation.dll"

    After clicking 'OK' I get another pop up window with message "iTunes was not installed correctly. Please reinstall iTunes.

    Error 7 (Windows Error 127)"


    So, what do I do now? Actually what caused this in the first place??!
  • hankryd Level 1 Level 1 (0 points)
    As hinted in the other replies, the apple support software is out of whack. Use the iTunes installer to remove iTunes, then use your control panel add/remove programs to remove the Apple updater, support software, and quickTime (basically anything with Apple in the name). The iTunes installer will put them all back.
    Run a good quality registry cleaner for good measure to clean up any mess left behind. Now re-install iTunes with the same installer you started with.
    I guess the iTunes installer could have used a bit more testing to detect and fix this. Anyhow this procedure fixed this problem for me.
  • manuelgarciia Level 1 Level 1 (0 points)
    Hi, can somebody please explain what can I do to get my itunes working again? I'm having the same trouble, everytime I try to open iTunes, a pop.up window shows up saying "itunes.exe point of entry not found, cfconstantstringclassreference in the dynamic link library corefoundation.dll, and then another one saying windows error 127, itunes was not installed correctly

    This all started when I downloaded the latest itunes version, i've tried everything, installing the corefoundation.dll file, installing and uninstalling itunes, quicktime, mobilme, and the rest of the components, and it just won't work. Please Help!!!