6 Replies Latest reply: Jun 30, 2010 2:48 PM by a4n
a4n Level 1 (0 points)
Hello,

1. I can't save any file to desktop or move any file to desktop.

2. If I klick the Icon "Desktop" in the Finder-Window I get the Message "There is no default application specified to open the document “Desktop”." and the option "Choose Application".

Any ideas to solve the problem?

a4n

MB Pro, iMac, Mac OS X (10.6.4)
  • JaimieV Level 2 (490 points)
    In Finder, go to your home folder (the one named after you) and Get Info on the Desktop folder there. What do you have for permissions, at the bottom?
  • a4n Level 1 (0 points)
    Thank you for the hint.

    Opened "Get Info" and checked the permission. The Permission are ok ... but the Desktop folder is not a "folder"! It's a package (General, Kind).

    Is it possible to change from "Kind: package" to "Kind: folder"?
  • macieks72 Level 1 (20 points)
    I think that you should go again to the "Get info" on the Desktop folder and check the checkbox named "Locked"

    Message was edited by: macieks72
  • a4n Level 1 (0 points)
    Thank you for the hint.

    Opened "Get Info" and "locked" is not selected but ...

    "Get Info" says the Desktop folder is not a "folder"! It's a "package" (General, Kind).

    Is it possible to change from "Kind: package" to "Kind: folder"?
  • macieks72 Level 1 (20 points)
    I don't know, but i have some idea: you can delete this folder in Terminal.app and create again.
    1. Backup your Desktop files.
    2. Run Terminal and type here:
    rm -rf ~/Desktop
    mkdir ~/Desktop
  • a4n Level 1 (0 points)
    Thank you all.

    With your hour help the problem is solved now!

    1. I trashed the "Desktop".
    2. Logout
    3. Login
    4. New folder "Desktop" appears with the right kind. It's now a folder.

    a4n