11 Replies Latest reply: Jul 12, 2010 11:30 AM by Ralph Johns (UK)
chex0809 Level 1 Level 1 (0 points)

I am a new Mac user running the latest verison of iChat.

I sign on with an AIM account and have no problems IMing people, but then in the middle of the conversation I will receive an error message saying, "The message ...... cannot be delivered. An AIM service error occured."

Even if I log out of iChat and restart it, the problem persists.

I am also often disconnected from iChat and have to repeatedly sign back in.

I tried changing the port to 443 as recommended in some other posts, but I still cannot get rid of the problem.

If anyone could help, it would be greatly appreciated. Thank you!

MacBook Pro, Mac OS X (10.6.4)
  • itchache Level 1 Level 1 (0 points)

    I have exactly the same problem!

    Changed port numbers. Deleted cache & preferences. Deleted, added, re-deleted and re-added my .mac account info... (and even though i deleted related information in keychain before, iChat kept filling either my account name or my account password. huh?). Anyway, nothing helped.

    So i decided to open a new account at aim.com. It worked fine for the first day, but the day after i wasn't able to send text messages anymore.

    For the time being, i have just stopped using iChat. So frustrating!
    Any help would be VERY appreciated.
  • itchache Level 1 Level 1 (0 points)
    I forgot to say my iChat version is 5.0.3 (745).
    Thanks again!
  • Ralph Johns (UK) Level 9 Level 9 (70,165 points)
    Hi to both of you,

    In System Preferences > Security > Firewall is you Firewall On ?

    If On, have you set the Advanced Button to Allow Signed apps and added iChat to the List ?

    Changing the port to 443 requires that you Press the Enter key to "Set" the port change.
    Some find the SSL has to be on to do this change as well.

    However the SSL server at AIM is not as reliable as the main server and it may pay to Deselect SSL to see if you get a better login.

    iChat uses the Port 5190 also on the UDP Protocol to do certain Text Chats (Direct IMs when you send Files or Pics)

    Do you have the ports iChat uses open in your Router or Modem combined device if the modem routes ?
    Port 443 will be below a threshold of port 1024 in most devices allowing you to Login but you may still have issues sending files and Pics as the Text chat will then change ports.

    8:44 PM Thursday; July 1, 2010

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • itchache Level 1 Level 1 (0 points)
    Hi Ralph,

    Thanks for your fast reply.

    Firewall - OFF.
    Changing ports - In order to be confirmed in my iChat I turn SSL on, change port number to 443, click enter to approve, and turn SSL back off. Port change seem to be approved as the number does not change back to 5190.
    Router/Modem - hmmm... I am afraid that a complicated question for my (average minus) technical knowledge. Unfortunately have no idea how tho handle this thing.

  • Ralph Johns (UK) Level 9 Level 9 (70,165 points)

    Start by telling me the make and model and any version number of the Modem and if separate the router as well.

    It would help if you sated if the modem was DSL or Cable.
    Cable modems tend not to route (Not setting up) whereas DSL ones tend to be combined modems and routers.
    There are implications if you are using two routing devices.

    9:01 PM Thursday; July 1, 2010

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • itchache Level 1 Level 1 (0 points)
    Hi again,

    DSL connection with TNN Aztec 600E.
    Wi-fi based upon a Linksys WRT54GS unit.

    One more recent discovery: I can text chat with few of my buddies without any problem. I get the error when i try to chat with few others, or when i use "New Chat..." and type in a name which does not appear in my buddies list... which makes me think that it's a modem/router problem (but, as I said, my technical knowledge is very limited).

  • itchache Level 1 Level 1 (0 points)
    One more finding: I have just connected to two other networks. I still get an AIM service error.
  • Ralph Johns (UK) Level 9 Level 9 (70,165 points)

    Sorry for the delay.

    On this page it tells you the default Access Info for the Aztech

    You need the info nearer the top.
    Just under the bit the Web Browser header pic is the IP and then the User ID and Password.
    The default IP shows as which, however, is different from the Pics
    You would type this into your Web Browser like you would apple.com

    If the does not work use (this is a standard IP based on the pic below showing the LAN IP starting at
    The User ID and Password are both "admin"

    First can you just confirm Access ?
    I have read some discussions Boards that suggest some IPs send this out with Restricted access and in Bridge Mode (Not routing).

    I need to know if it is Routing as two Routing Devices on the LAN can be an issue.

    If your devices set up pages look like the Link I have sent you to can you also confirm whether UPnP is Enabled ?


    For this one http://portforward.com/english/routers/portforwarding/Linksys/WRT54GS/AIMTalk.htm the IP is
    The User ID is blank and the Password is "admin"

    The first Linksys Pic on the site shows only the top part of the Status page.
    Can you tell me if it looks different from the pic. (i.e is it set to Automatic DHCP ?)

    The bottom part of the Page tells you if the LAN side (to computers) is doing DHCP (Issuing IPs).
    Can you confirm it is doing this ?

    In System Preferences > Network > Advanced Button (s you are WiFi) > TCP/IP tab you should see that your computer is getting (most likely - but at least the first three parts will be the same)

    Can you confirm this please ?

    The Mac can only display one IP here.
    It may well be getting one from the Modem as well as the Linksys will pass an Routing info from there on to any computers.

    Next go to the Administration Page (tab across the top) and tell me if UPnP is enabled here ?
    Enabled it if it is Not (Save Settings).

    Next go to the Wireless page.
    In here should be options to change the channel it is using.
    Just tell me if this is still set at a channel in th e middle of the range ?
    You may be getting interference form other nearby networks.

    In Security turn Off the Firewall and change the Setting for Responding to Anonymous Requests (ping Blocking - iChat sends a Ping and needs this Allowed).
    You may not have a firewall depending on which version of the WRT54GS you have.

    Most DSL modem route.
    Confirm yours is by trying to Access it.
    Confirm whether it is doing UPnP or not. (UPnP is the simplest method of Opening the ports)

    The Linksys does not do UPnP by default so Enable it.
    The Wireless channel may be getting interference but I want to know where we are starting from.
    The Security page Block Pings (Anonymous Requests from the WAN port) and needs to allow these for iChat.
    If it has a Firewall in here then this can interfere with iChat Video Chats.

    8:16 PM Sunday; July 4, 2010

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • Ralph Johns (UK) Level 9 Level 9 (70,165 points)

    On this one can you tell me what sort of Networks you are talking about ?
    Internet Cafe ?
    Friend's house ?

    8:17 PM Sunday; July 4, 2010

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • itchache Level 1 Level 1 (0 points)
    Hi Ralph,

    I apologize for the time it has taken me to get back to you.
    Thank you VERY MUCH for your elaborate answer!
    I am not really familiar with all those configuration parameters and how to approach them, so I printed your answer and currently waiting for a friend to come over and have a look.
    Meanwhile, I just stopped using iChat. Too capricious for me (one time it workd, another time it does not, so on and so forth).

    Thanks again for your help!
  • Ralph Johns (UK) Level 9 Level 9 (70,165 points)

    Very simply. (i.e without the why and wherefores)

    Modems and routers.
    These can act like Hardware firewalls if the ports certain apps use are not opened.
    This is because most domestic devices only have the first few ports (up to port 1024) open as default.

    This allows the router or modem if it routes, to hand out IP addresses to other routers and computers.
    If both your modem and router are doing DHCP then all the devices connected get an IP from each.
    This means the Computer gets two IPs, one from the modem and one from the router. (The router will pass on any Routing info from the Modem).
    Computers can only display One IP an on a Mac this is in System Preferences > Network > Advanced Button > TCP/IP tab.
    It means the computer "thinks" there are two connections to the Internet.
    This can also be caused by being WiFi andf Ethernet to the same "router"

    Mail and Web Browsers will ignore the fact there are two connections.
    However iChat needs to see only one Connection to the internet.
    Text chatting is not so bad as most server do let you login from multiple computers or even multiple applications.
    This means you can have the Buddy List open on two computers as will tend to see the Buddy's IMs on both.
    For Video and Audio Chat though the connection Process involves a check to see if the place the Visible Invite went to is the same place that is responding to the Connection process (there is a behind the scenes invite in this process).

    If iChat is sitting in two Networks it will sometimes make the connection and sometime not.

    7:30 PM Monday; July 12, 2010

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"