Previous 1 2 3 Next 44 Replies Latest reply: Jul 11, 2010 2:52 AM by b noir
StoneSour94 Level 1 Level 1 (0 points)
Hi,

Recently I've been getting my iTunes up and running after a series of computer-related disasters. After getting all of my music into the library and organized, I connect my iPod Touch (3rd Gen., Firmware 3.1.3) to sync, and possibly download the OS 4 update. I get an odd error message saying that I need to uninstall both iTunes and AMDS and reinstall iTunes.

So I go to the control panel and attempt to remove. ERROR: Fatal error during installation. I tried to repair it, but I learned that the AppleMobileDeviceSupport.msi file and containing folder are non-existent, and is only listed in the registry. I even tried to use CCleaner to remove everything iPod-related. Still nothing. I'm afraid to format my computer also. You name it, I've tried it. Help please? =(

Dell, Windows XP
  • Noah Elias Level 1 Level 1 (0 points)
    this is a common problem with iTunes 9.2, iOS 4 and Windiws 7. The point is, that the Apple Mobile Device Support (AMDS) ver. 3.1, which is included in iTunes 9.2, has a fatal error and is not installing correctly. And if you install an older version of AMDS (3.0.1), it is not cooperating with the newest iTunes .... Look in some other threads where this problem is described.

    So, the solution is:
    First look in the "services" that AMDS is inactive
    then uninstall AMDS through the system manager

    you don't need to uninstall iTunes 9.2
    then follow the steps in this blog:
    http://randomwindowstips.wordpress.com/2009/12/08/windows-7-itunes-9-software-is -not-installed/
  • StoneSour94 Level 1 Level 1 (0 points)
    Thanks for the info, but that didn't solve my problem. I'm using Windows XP, but I think the real problem is that the path to the AMDS file had been deleted somehow. I've tried to stop the service but I had no luck with that. I even tried to get rid of it by stopping it in the Task Manager Processes but it just keeps reappearing. I have absolutely no idea what to do next.
  • Noah Elias Level 1 Level 1 (0 points)
    there is a solution for that path-problem in another thread here - i found it accidentally by looking for my problem, but as it was not my problem, i did not try or even bookmark it. Maybe you should go through the threads and look for it.
  • b noir Level 9 Level 9 (72,020 points)
    I think the real problem is that the path to the AMDS file had been deleted somehow.


    Is the message saying that the AppleMobileDeviceSupport.msi file is missing, Stone?

    These sorts of msi-related troubles have gotten more complicated to deal with ever since Microsoft pulled the Windows Installer CleanUp utility from their Download Center on June 25.

    Let's try Googling. (Best not to use Bing, I think.) Look for a working download site for at least version 3.0 of the Windows Installer CleanUp utility. After downloading the utility installer file (msicuu2.exe), scan the file for malware, just in case. (I use the free version of Malwarebytes AntiMalware to do single-file scans for that.)

    If the file is clean, to install the utility, doubleclick the msicuu2.exe file you've downloaded.

    Now run the utility ("Start > All Programs > Windows Install Clean Up"). In the list of programs that appears in CleanUp, select any *Apple Mobile Device Support* entries and click "Remove".

    Quit out of CleanUp, restart the PC and try installing iTunes 9.2 again. Does the install go through properly this time?

    (If you do find a clean download site for the correct version of CleanUp, please don't tell me where it is. Without wishing to sound paranoid (although I grant it does sound paranoid), there is a non-zero chance that posting links to download locations for the utility here at Discussions leads to that download location being shut down.)
  • Sky19view Level 1 Level 1 (0 points)
    Thanks for this Noah
    It worked for me although there are still error messages - at least iPod and iPad now sync - It has taken me hours to solve this
    It really is time that Apple joined the real world and realized that their products are purchased for serious business applications and therefore require foolproof and non buggy software which works or is corrected within 48hours if there is a problem
    Richard
  • StoneSour94 Level 1 Level 1 (0 points)
    Thank you, b noir, I trust your advice would solve my problem. The first time I tried to google the windows installer utility cleanup from a website, it downloaded, but came up with the error saying "Access is denied", having to do with the windows script thingy. The file looks like it should be working but it's just that error that gets on my nerves. Should I keep on googling or will it keep giving me this error with every time i download this file from different websites? I greatly appreciate the help.
  • b noir Level 9 Level 9 (72,020 points)
    but came up with the error saying "Access is denied", having to do with the windows script thingy


    Hmmm ... is the error code on that one an 800A0046?

    If so, try installing CleanUp by doing a "Run as administrator", as per:

    [Error "800A0046 - Permission Denied" when installing the Windows Installer Cleanup Utility in Windows Vista|http://www.winhelponline.com/articles/170/1/Error-800A0046---Permission-D enied-when-installing-the-Windows-Installer-Cleanup-Utility-in-Windows-Vista.htm l]

    If you can get her installed, can you remove the busted AMDS with CleanUp?
  • StoneSour94 Level 1 Level 1 (0 points)
    It wasn't that error at all, but a completely different one:

    __________________________________________________
    Windows Script Host [x]
    X Loading your settings failed. (Access is denied. )
    [ OK ]
    __________________________________________________

    From each website I download this from, I get this same error. The file name is msicuu2.exe. I'm stuck with this issue. Again I appreciate the help.
  • b noir Level 9 Level 9 (72,020 points)
    Interesting ... the first thing I'd suspect with that one is that your VBScript on the PC has been deregistered. (CleanUp needs a properly functioning VBScript in order to work correctly.)

    Although the following document is about a different issue, it has instructions in it for reregistering VBScript. See the *For Windows 2000 or Windows XP:* section of the *Register the VBScript engine again* section for instructions:

    [iTunes and QuickTime for Windows cannot be installed without Visual Basic Script (VBScript)|http://support.apple.com/kb/TS1331]

    After reregistering your VBScript, can you get you CleanUp installing/launching?
  • StoneSour94 Level 1 Level 1 (0 points)
    Nope. =/
    Same frustrating error. I was almost sure that the VBScript is not the problem.
  • b noir Level 9 Level 9 (72,020 points)
    Doublechecking something ... does your XP user account have full admin rights? Or is it just a Power user or other non-admin account?
  • StoneSour94 Level 1 Level 1 (0 points)
    Full-admin rights.
  • b noir Level 9 Level 9 (72,020 points)
    Okay. Even though you've got admin rights, plausibly you might have lost permissions on one of the Windows script host registry keys.

    Let's check your permissions.

    In your start menu, click Run.
    Type regedit and hit enter.
    Expand HKEYCURRENTUSER
    Expand Software
    Expand Microsoft
    Expand Windows Script Host

    Right click on the "Settings" key and select "Permissions". Does your User account, your Administrators Group and the SYSTEM account all have Full Control on the KEY?
  • StoneSour94 Level 1 Level 1 (0 points)
    Another problem. (Ughhhhhhh.)
    I've gotten as far as expanding "Microsoft", and Windows Script Host is absolutely nowhere to be found..will this be a problem?
Previous 1 2 3 Next