6 Replies Latest reply: Aug 7, 2010 8:25 PM by ecolucci
MrTeagan Level 1 Level 1 (0 points)
My iMac will freeze on occasion when the screensaver starts on my login screen, fast user screen. How can this be disabled so it never starts the screensaver?

IPhone 4, iOS 4
  • Roger Wilmut1 Level 9 Level 9 (70,210 points)
    System Preferences>Desktop & Screeen Saver>Screen Saver and set the 'Start screen saver' slider to 'Never'. And keep the mouse out of whatever the 'Hot Corner' is (usually bottom left but check in the same pane - don't have it set to 'top left').
  • MrTeagan Level 1 Level 1 (0 points)
    If you have two users both logged in, and the computer "locked" on the fast user login switch panel, I get a random screensaver (not the one selected on either user), and it usually locks up my mac after a while. I like having the screensaver when my account is not on the login screen, but actually on my desktop, I just want to disable it on that login screen.
  • Stephen Carson Level 1 Level 1 (0 points)
    We are having the same issue. Our iMac will freeze on the login screen sometimes when the screen saver comes on. We typically have multiple users logged on. Help!
  • John Miller10 Level 1 Level 1 (0 points)
    I activated the root user in Snow Leopard (using /System/Library/CoreServices/Directory Utility.app) and logged in as root.

    Then I opened System Preferences.app/Screensaver and discovered, as I thought I would, that the screensaver there selected was the one that was being displayed in the loginwindow screen after a fast user switch.

    I now tried to disable the screensaver in in the Screensaver pane of System Preferences by moving the slider for screensaver activation to "Never." For test purposes I changed the selected screensaver too.

    Upon logging out as root and resuming normal (multi-user) use of the computer I found that I had not succeeded in disabling the screensaver in the loginwindow screen. But the screensaver displayed is the one that I selected as root.

    I am puzzled. And I would like to know the identity of the file in which the preferences governing screensaver activation and display are being written and read by the system.
  • ecolucci Level 1 Level 1 (0 points)
    I have the same problem in that I cannot seem to eliminate my login screen saver. I followed the same procedure as John Miller by logging in as root and--I thought--disabling the root screen saver in System Preferences and then rebooting my computer. However after logging in again as myself, using fast switcher to lock the screen, and walking away from my computer for a couple hours, I found upon my return the root login screen saver "staring" me in the face again. How do I eliminate this screen saver? Yes, my account's screen saver is set to "Never."
  • ecolucci Level 1 Level 1 (0 points)
    Fortunately, I still have a couple weeks remaining with Apple Care so I contacted Apple support last week to report this--as it turns out--bug. I was informed that a solution most likely would be incorporated in a future OS update.

    I also stumbled upon an alternative to using fast user switching that does not engage the root screen saver when locking the computer display. If you start Keychain Access and go to Preferences from within the Keychain Access menu option, then select the General tab if it is not already selected, you can check the option that reads Show Status in Menu Bar.

    Once the Keychain Access status appears in the Menu Bar, you can pull down a list of commands with the command at the top of the list reading Lock Screen. For whatever reason, Lock Screen does not result in the root user's screen saver activating. Obviously, this is not a solution to the problem with using fast user switching as discussed in this thread, but it is an alternative means to lock the display.