2 Replies Latest reply: Jul 4, 2010 10:04 PM by motc
motc Level 1 (5 points)

I'm hoping someone can help me with this.

I have a MacBook Pro, OS 10.5.8. I recently downloaded a number of music software demo's, and after checking them out, proceeded to throw away the ones I didn't want to keep. (I used the application Find Any File to help locate all the files associated with the programs.)

One of the files couldn't be trashed – I got a message saying it was still in use. I then tried to Repair Permissions and got a message saying it couldn't be done because, "...the underlying task reported failure at exit". I shut down the Macbook, restarted, and the application was bouncing up and down on the dock. I control clicked on it and force quit. It disappeared from the dock, but I still can't repair permissions or throw away the file, because I'm getting the same messages. When I control clicked on it in the Dock, the top line, which was grayed out, said "Application Not Responding".

I thought I was being careful when I selected the files to be thrown away, and the demo that this file came from was not open when I threw away the other files, unless it was running in the background somehow. After that I ran TechTool Deluxe and it passed all the tests.

In the meantime I've purchased the music software I wanted, but don't want to install it without being able to repair permissions and start with a clean slate.

Any idea how to get rid of this thing? Any help would be greatly appreciated.

iMac Intel Core 2, Mac OS X (10.4.11), 2GHz,1GB,150 GB. Also iBook G3:900 MHz,640 MB,40 GB
  • motc Level 1 (5 points)
    A little more info to my above post: When I select the file and do a Get Info, it says that it's an "Application (Universal)"
  • motc Level 1 (5 points)
    Well, this problem seems to have resolved itself. I talked to support at AppleCare. They suggested booting from the original Install CD. Although when I tried to repair permissions with the Install CD, I got the same message, when I restarted from the startup disk and repaired permissions again, it worked. Not only that, but the very long list of permissions that normally has to be repaired (since I updated from 10.5.5 to 10.5.8) had cleared, and there were no permissions that needed to be repaired. After that, I downloaded a couple Apple software updates, and three permissions had to be repaired. I suspect, as time goes by, more permission repairs will be added to this list.

    This seems to be an issue with Leopard - for me - since updating to 10.5.8. Wonder when they'll resolve it?