Previous 1 2 Next 17 Replies Latest reply: Nov 13, 2013 5:04 PM by Askarzadeh
Lessandro Level 1 Level 1 (0 points)
iPhoto cannot import your photos because there was a problem downloading an image. This is what I get when I try to import all. When I try to import image by image, I get the error, "Unreadable Files: 1. The following file could not be imported. (The file is in an unrecognized format.) What the ****? I also tried ImageCapture and it did not work. I know it is not my memory card from my Kodak v1073 because I used my friend's macbook pro and it imported the images just fine. If I take out the memory card and use the camera's memory, it imports the photos just fine. What could be the problem? I keep my photos in a shared library on my computer so my wife and I don't have to have separate libraries and I have never had a problem. I just found out that if I just take pictures on the camera my computer will import them, but if I take any video and then try to import the images on the sd card or the videos on the sd card, I will get those errors.

Message was edited by: Lessandro

Mac Mini Intel 2009, Mac OS X (10.5.6)
  • Old Toad Level 10 Level 10 (120,220 points)
    iPhoto has problems with large video files. How big are those video files? Did you use the SD card slot on your friend's MBP to test out the memory card by itself or just plug in the camera via it's USB cord?

    Once you get all of the files off the memory card reformat it using the camera and run a test with photos and videos. Also see if a card reader will be able to see all of the files and upload them to a folder on the Desktop. Actually that's the safest way to upload from a camera.


    OT
  • t0ddl Level 1 Level 1 (5 points)
    I've had the same problem with a kodak camera I just purchased. A number of others have had trouble with kodak cameras of various kinds, and it seems to a problem with OS 10.6.4. Since I found it quite annoying that a new camera couldn't be read by iphoto, I reinstalled Snow Leopard, then went through the downloads in the support section to find 10.6.3 and installed that. Problem solved, maybe not worth the effort since a card reader worked fine as well. I'll be a little reluctant to install 10.6.5, and hope they mention a kodak fix in their release notes.
  • Lessandro Level 1 Level 1 (0 points)
    t0ddl, thx. I may just have to suck it up and get a card reader. I just feel aggrieved because it seems to be going through cycles. When I had leopard, my camera worked fine. Then after the initial upgrade to Snow Leopard, I had trouble importing my videos. Then another update and it was fixed. Then another update and it was again not working. You can see this by an older post I made in Sept of 2009 here: http://discussions.apple.com/thread.jspa?threadID=2161512&tstart=0
  • Old Toad Level 10 Level 10 (120,220 points)
    FWIW using a card reader is the preferred method of most professional photographers. It saves wear and tear on the camera's ports and insures that the files are safely uploaded to the hard drive. This workflow also allows you, if you so desire, to rename the files to something more informative than IMG_001.jpg, etc. I use the date the photo was taken in the international date format: YYYY-MM-DD-001.jpg. You can use a file renaming app like R-Name. It works best if you upload after every shoot so the date is the same for all files.

    I have noticed that there have been a number of posts on the subject regarding Kodak cameras. I don't know if that says anything about the camera or the system software.

    If you use SD or SDHC memory cards, WalMart has a very nice (and small) card reader for $10. It's a Targus. It can be plugged directly into a laptops USB port or with a 12" cable.

    It's also available online here: http://www.buy.com/prod/targus-usb-2-0-secure-digital-card-reader-and-writer-min isd-card/q/loc/101/206721686.html and at Amazon.com: http://www.amazon.com/Targus-Digital-TGR-SD20-Secure-Reader/sim/B000FRXHNA/2

    Message was edited by: Old Toad
  • Old Toad Level 10 Level 10 (120,220 points)
    What is the brand and size of your memory card? Another Kodak user just reported the same problem and was using an 8GB San Disk. It could either be the brand or the size that's not getting recognized. Let us know what you're using?
  • t0ddl Level 1 Level 1 (5 points)
    Hi,

    I am using a 32 gb Sandisk microSD in a Sandisk SD holder. After reverting to OS 10.6.3, it works fine. Thanks for the tip on the card reader.
  • Old Toad Level 10 Level 10 (120,220 points)
    This definitely is a 10.6.4 problem with Kodak cameras. All who are experiencing this should report the problem to Apple via http://www.apple.com/feedback/iphoto.html.
  • Lessandro Level 1 Level 1 (0 points)
    My sd card is a PNY Optima SDHC 4GB. I followed the link you sent me and reported the problem. Weird how certain updates fix it, then further updates rebreak it. My sd card should be fine though, as it imports fine via camera usb on my friend's macbook pro.
  • Old Toad Level 10 Level 10 (120,220 points)
    Your profile shows you at 10.5.6. Download and install (or reinstall if that's the case) the Mac OS X 10.5.8 Combo Update. See if that will help.
  • TallmanG Level 1 Level 1 (0 points)
    I"m having the exact same problem with a Kodak V603. I sent a feedback message to Apple. My wife is going to take the computer and camera to the Genius Bar. If they have a solution, I'll try to post it.
  • Boan Rubalcava Level 1 Level 1 (0 points)
    I have the exact problem but with my iPhone 4! I can't take out the HD of the iPhone and import them that way. Any suggestions?
  • herbshirt Level 1 Level 1 (0 points)
    Exact same problem.

    I've tried reinstalling iTunes. My iPhone 'has a problem downloading the image' so none of my images are able to imported. Since my camera packed it in all my recent photos are on my phone.

    Plug the phone in, iPhoto recognises the images and downloads the preview but then I hit Import, "There was an error downloading the image'.

    So so frustrating.

    Anyone?
  • Terence Devlin Level 10 Level 10 (128,135 points)
    Search the forum. A lot of folks have resolved this with a simple restart of the phone. Others needed to do a reset.

    Regards

    TD
  • Jamiemack Level 1 Level 1 (0 points)
    Restarting the iphone resolved the issue for me.

    Thanks
Previous 1 2 Next