Previous 1 2 3 4 Next 264 Replies Latest reply: Jan 11, 2016 5:14 PM by Ninebris Go to original post Branched to a new discussion.
  • MichaelBlythe Level 1 Level 1
    I'm running a 3G and encountering the same issues as you all since the upgrade. I have tried to connect to different wi-fi routers and get the same issue whether security is enabled or not.


  • Babytwister Level 1 Level 1
    Same problem here. At first my iPhone 3G won't detect at all, I searched all solutions, finally I took it apart and reflow the wifi with heat gun. I only heated for 10 seconds (supposed to be 30 sec). It works for a day, and than not working again. I should've heated for 30sec. Now, it connects to wifi without security only, wifi with security will have MSG saying unable to join. Crazy! This is not iphone's hardware problem, it should be software. Maybe download too much stuff, and I always believe softwares do have virus like PC. If restore not work, I will reflow again. You can find instructions on YouTube of how to reflow.
  • Andrea Rimicci Level 1 Level 1
    twosheds55 wrote:
    My iPhone won't log onto my home or work WiFi. It recognizes them and I have put in the correct passwords but I just get an alert saying "Unable to join the network...".

    Check if your router has some firmware update available. It happened some routers were not correctly handling WPA2 authentication by iPhone (and correctly handling other devices), and updated their firmware. To confirm this is your problem, just change your wifi authentication to something more relaxed, as WPA or WEP pre-shared key, and test connection.
  • Kensico Level 1 Level 1
    I tried absolutely everything! No success.
    I took my iPhone 3G to an Apple Store. Two Genius types could not fix it!

    I gave up and gave in after 2+ years, I replaced it with an iPhone 4. All systems work great.

    Solution: Add money!
  • Twitcher777 Level 1 Level 1
    I ran into this problem out of the blue after a few years of my router(s) working fine with iPhone3's and 4's.
    I tried all of the above helpful solutions, but it seemed that they only worked for a few seconds (the ones that worked at all). I tried some other nice tricks too (reserved IP's in my DHCP for my two iPhones) and nothing seemed to work.
    What I finally noticed, was that there was an SSID now BOOMING into my home called "WIRELESS". Not sure who this is or how they are able to get such a strong signal into my home, but I get 5 bars from them. At any rate, I started to think 'interference'. Because EVERYTHING had worked fine for so long and nothing had changed on my end, this made some sense. Not much you can check, but the first thing I did was change my wireless (the 2.4gHZ side) from AUTO on the channel selection to a forced channel (I picked 7). This worked immediately.
    Hope this helps you guys.
    BTW, the "WIRELESS" SSID, was not passwd protected and works fine, I'm just paranoid about WHO that is.
    Best of luck, hope this works for you.
    -I use WPA2 Personal
  • deano_thfc Level 1 Level 1

    I had the same problem it drove me nuts. I finally worked out that i had to go into my router settings, i have a netgear DGN2000 and there i disabled mac filtering, i then entered the mac address of the i phone and hey presto it worked

    Hope this helps.

  • deano_thfc Level 1 Level 1

    Hi i had the same problem ended up being the Mac filtering in my router settings, i turned it off and then entered my phones Mac address manually saved it and it finally started working.

    Hope this helps, oh my router was a Netgear DGN2000.

  • emilyfromfrankfort Level 1 Level 1

    OK I too have this problem with my 3G.  Won't recognize any wifi that it used to.  I am typing on a Mac laptop at home using the wifi.  My phone is sitting next to me and won't pick up the airport signal.  Now it seems to me after reading these posts that no one can decide if it is a hardware or software issue.  It also appears that this has been an issue for awhile now.  I have scoured the web looking for a fix.  Nothing works.


    Apple why haven't you fixed this problem?  Why is the 3G phone now obsolete with no mention on your homepage?  Why are you no longer supporting it?  Why why why.

  • emilyfromfrankfort Level 1 Level 1

    OK took it to the Apple store last night and the guy looked down into the hole where the earphones plug in and immediately said "oh water has gotten down in there".  The wifi is fried on this phone and cannot be repaired!

  • tigfromwasilla Level 1 Level 1

    This is FAR from incorrect, possibly... I live  in Alaska and I've gotten my phone wet numerous times for days on end. My wireless worked great until I upgraded to new software.

  • Gavin420 Level 1 Level 1

    The problem could be the MTU setting in your router, it should be 1400.

    One normally changes this to allow PS3 or xbox to connect to network games.

    If using NETGEAR got to advanced>WAN Setup> MTU Size.

    Link to NETGEAR MTU discussion


    Otherwise do a hard reset on your router..

  • FrustratedFan Level 1 Level 1

    I was having the same issue - found something that worked for me. I tried going to my iPhone 4 settings, under General and the reset (at bottom) then I reset the network settings.  Then I retyped in my password and all is well!

  • whitephantom Level 1 Level 1

    That worked for me.  Thanks a lot Frustrated Fan!

  • JamesFinch Level 1 Level 1

    Going into my router security settings and simply clicking apply was enough to fix this problem for me. I changed no settings. If you can't click apply or save on your particular router's security settings page, try just clicking into your passphrase box, putting a space in and then backspacing it out. You should be able to click apply then.


    Without doing anthing at all on my iPhone 3GS (latest iOS 5), it reconnected within a few seconds and I was happily downloading 20 MB+ apps again at breathtaking speeds...

  • Debfrommo Level 1 Level 1

    Frustrated fan's solution worked for me. I tried that first because it appeared to be the easiest solution for me, a beginner. I have an iPhone 3GS. Thanks, Frustrated Fan!

Previous 1 2 3 4 Next