Previous 1 11 12 13 14 15 Next 264 Replies Latest reply: Jan 11, 2016 5:14 PM by Ninebris Go to original post Branched to a new discussion.
  • Emma Glaisher Level 1 (30 points)

    Similar problem here. iPhone 3GS, Wifi has worked find since I got it last Christmas. Now, it is struggling to see work and home networks which were fine before. Also in places where Wifi is available, friends can see the networks, my phone just doesn't seem to pick it up.


    I can still use Wifi but need to be physically near to the source - has anyone else had this variant? I have dropped the phone on occasion (I drop most things...) so suspect it may be physical damage.

  • Randraos123 Level 1 (0 points)

    If you know for sure that your password for your WI-FI network has not been changed, and you have tried multiple times to connect although it always says "Unable to join network", i know a solution to your problems.


    Step 1 - Settings > Network


    Step 2 - Click on the right arrow next to your home network


    Step 3 - Click "Forget Network"


    Step 4 - Reboot your router


    Step 5- Reconnect by entering your password again in your home network that you select


    These five steps should work, if it still does not work, repeat it once more.

  • hlp_pls Level 1 (0 points)

    I have read all the threads to this entry and tried numerous solutions including rebooting my router( many times, checking the Wi-Fi settings on the router, doing a Network reset on my iphone etc. Nothing worked. The interesting issue is that I have Wi-Fi connection on my iPad and the television which also receives its programmes via Wi-Fi is working fine.

    So the problem seems to afftect the iphone only.

    I have an iPhone 3Gs and my daughter an iPhone 4. Both are affected. The problem started suddenly on Monday evening.

    The operating system has been updated regularly and is now on 6.1.3.

    There is no option on both phone to "Forget this Network", so I tried the "Other" option and tried reentering the connection detail that work for the iPad. it doesn't even recognise the Password which I know is correct. No luck!

    This seems to be an iPhone problem and it is not limited to one type of phone only.

    Any more suggestions?

  • fromsouth Level 5 (4,430 points)

    yes, try on other network, and troubleshoot accordingly. If you have no problem on other network, troubleshoot your network, If you do - troubleshoot your iphone.

  • hlp_pls Level 1 (0 points)

    Thanks, but my home network is working fine as I said for the iPad and television. The problem seems to be with the iPhones only. I tried resetting both, but it didn't help. What do you mean by "troubleshoot"?

  • Lawrence Finch Level 8 (35,018 points)

    hlp_pls wrote:


    Thanks, but my home network is working fine as I said for the iPad and television.

    That is irrelevant. Each device connected to a router can respond differently.  There are many possible reasons that the router will work with some devices and not with others, and the problem can still be the router.


    Which is why the advice to try it on other WiFi networks is important. If it works on other networks then the problem is almost certainly your router or the phone's settings for your specific router.

  • fromsouth Level 5 (4,430 points)

    hlp_pls wrote:

    What do you mean by "troubleshoot"?

    A lot of things, but there is no point to go there, until you try your phone on another network.  "my home network is working fine as I said for the iPad and television" That is incorrect assumption. Proceed with my advice and try another network or continue your way without me.  I actually am pretty sure that I know the answer to your problem, but as you can see I do not throw that answer at you, until I verify it.


    Thanks for help Lawrence!

  • hlp_pls Level 1 (0 points)

    I just reset the router to its original factory settings (by pusing on the reset button at the back). this depends on the router model you have (check your manual). And it worked. The iphone not only recognised the home wi-fi network but also accepted the password which it didn't before.

    Let's hope this lasts...


    So it seems the problem was with the router after all. Even though it's odd that so many iphone users have experienced the same problem especially after the latest update to iOS 6.


    Message was edited by: hlp_pls

  • Lawrence Finch Level 8 (35,018 points)

    hlp_pls wrote:


    So it seems the problem was with the router after all. Even though it's odd that so many iphone users have experienced the same problem especially after the latest update to iOS 6.


    Not odd if you understand how routers work. Every time a device connects to a router it needs an IP address. If it already has one it connects immediately (assuming its "lease time" hasn't expired). If it doesn't have one it requests one from the router. A process in the router called a "DHCP daemon" accepts the request and assigns an IP address. The device then uses this assigned address to connect. In most consumer-grade routers the DHCP daemon is unreliable, and will eventually quit working. Devices that are already connected aren't affected, because they already have an IP address. But a new device, or one whose lease has expired, or that doesn't have an IP address will not be able to connect. You can tell this has happened by going to Settings/WiFi and tapping on the ">" to the right of the network name. If the IP address begins with 169.254 this means that the router failed to assign an IP address, so the device generated on on its own to create an "ad hoc" network.


    Resetting the router restarts the DHCP daemon, so devices without IP addresses will again be able to connect.


    When you update a device some settings in memory are cleared, including the IP address. Thus, right after ANY update (not just to iOS 6), or if you Reset Network Settings or Reset All Settings or restore the phone it will need a new IP address. If it can't get one it won't be able to connect to the network. It will appear to connect for about 30 seconds while it sends the request, but will then time out and self-assign 169.254.random>.<random>.

  • hlp_pls Level 1 (0 points)

    Thanks a lot! It's useful to know how the router works and the DHCP "demon" ;-)

    I'll bear this in mind with the next upgrades.

  • David_L. Folender Level 1 (0 points)

    So what about this though. I havew an iPhone 4 running 6.1.3 and I have no problem on my home netework whatsoever. However, I all of a sudden have trouble getting on every other WiFi network including networks I've been using for a long time.


    It's intermittent though as I am sometimes able to join new networks and sometimes not. I am also sometimes able to join familiar networks and sometimes not.


    Any ideas anyone?


    Thanks in advance!

  • hoges1 Level 1 (0 points)

    hey, my problem is that my phone (iPhone 4, os 6.1.3) now all of a sudden won't detect wifi- networks. i'm posting this using my home wifi network on my macbook pro, and it's working fine. i regularly connect to other networks outside my house, and my phone won't detect these either. i tried resetting the network settings to no avail.

    as it doesnt even detect the network, i cant use the "press arrow next to network name"-fix as described in earlier posts, as no network name comes up...  seems i have more in common with David_L. Folender's post...




    thanks in advance

  • fromsouth Level 5 (4,430 points)

    Unfortunately you have nothing in common with David. In his case plain reset network settings may fix a problem (too many networks in memory). In your case it is very likely to end with iphone repair. Before you go to the store though - try to restore your phone and see if that will fix it. (make sure to back up before restore). If restore does not work out, then time for repair/replacement.

  • wkholi Level 1 (0 points)

    i finally found where the problem is with " unable to join network " error message , after months of research and trying every single trick on the net not working , the problem is with channel overlapping from the router . i have downloaded " inSSider " network analyzer and found that my home network is overlapping with four other networks , though when i try to connect from another place where there is no channel overlapping it connects just fine . most routers use 2.5 Mhz frequency , so you get a lot of overlapping there , but if you try to connect from a 5 Mhz router , its fine . so you could download the inSSider app for pc and check for the channel where there is no channel overlapping and use this channel . This is a hardware issue anyway , if the wifi circuit and wifi antenna are ok in your phone then you should not have any problem connecting , but if either of them are faulty , you will get that error . so you either fix it or taking it to apple to replace it . and it is possible that when you go to apple store you would not see the problem , thats what happened to me , that is because they probably have a 5 Mhz router and that would rarely interfere with other networks .

  • Opieshuffle Level 1 (0 points)


    Re: iPhone won't connect to WiFi


       Dec 28, 2011 10:31 AM    (in response to twosheds55

    I was having the same issue - found something that worked for me. I tried going to my iPhone 4 settings, under General and the reset (at bottom) then I reset the network settings.  Then I retyped in my password and all is well!




    This worked for me too just today. iPhone 4S

Previous 1 11 12 13 14 15 Next