Previous 1 2 3 4 5 Next 264 Replies Latest reply: Jan 11, 2016 5:14 PM by Ninebris Go to original post Branched to a new discussion.
  • Sosa828 Level 1 (0 points)

    If you go into setting, then go to general, then go to reset, then select reset network settings it will fix the problem.

  • crashloots Level 1 (0 points)

    I had the same problem too..

    guys try this .. mostly it should work ..

    Do this:


    Settings> General> Network> Wi-Fi> Ask to join networks: OFF (Turn it OFF).


    This incresed my "browser handshake speed and new page load speed faster". in simple it eshtablishes the connection WAY TOO FAST than before..


    although the download speed remains the same...


    once again only the intial connection with internet on wifi got faster when i opened my safari from scratch...


    I am really happy now.


    Please let me know if it work for you guys and spread the word on other forums as i see plenty of similar complains.

  • crashloots Level 1 (0 points)

    i guess the reset network settings option does this aswell and hence all users get thier wifi back ,


    but my option mentioed above may be an easier option without losing your network passwords.


    on the downside you may need to always find a wifi access point yourself and not get an auto popup for an available wifi access point

  • osxgirl Level 1 (0 points)

    My husband and I both have iPhones - I have a 4, he has a 4s.  We are using Verizon Fios, have wireless turned off on that router (but DHCP is distributed from it), and we have an Airport Extreme that supplies the wireless network.  Security is WPA/WPA2.


    We have 4 Macs (17" MacBook Pro, 15" MacBook Pro, Mac Pro, Mac Mini) and 2 iPads (1 & 2) in addition to the 2 iPhones.  Everything has been able to connect with no issues - until yesterday.  My husband said his phone couldn't connect, and asked me to check it out.  Mine wouldn't connect either.  He had upgraded to iOS 5.1, I was still on 5.0.1.  No changes whatsoever had been made to the network, and everything else, including the iPads, could still connect without any issues. (Don't know off the top of my head the iOS version for the iPads.)


    I have tried everything in this and multiple other threads about this issue (with the exception of the freezer and oven methods that have been mentioned - if we have to resort to those, then it's a HW issue, and I will be going to Apple and insisting on help! Besides, both of our phones started this at the exact same time, which tells me there is something else going on.) Nothing has worked.


    Finally, I read in one of the other threads that someone had tested the wifi on their phone by setting up an ad hoc network with their Mac and connecting the phone to it.  The phone was able to connect, and after that, they were able to go back to their main wireless network and the phone finally connected.


    I tried this.  My phone did connect to the ad hoc network.  When I tried to connect via the Airport Extreme network again, however, it still would not connect.


    Then I decided to try one other thing.  In setting up the ad hoc network, it tells you to set the channel to 1 or 2.  I had used 1.  So I went in and set the Extreme to manual - channel 1.  When I tried, my phone connected instantly.  I changed the Extreme back to automatic for the channel, and the phone would not connect.  Changed it back to channel 1 again, and again, the phone connected instantly.


    Mind you, I had tried changing channels earlier, as that is one of the suggestions both in other threads and in the KB article from Apple.  But the suggestions tend to be to set the channel to 11 or 10, and that you should stick with the higher channels.  After I tried 11, 10, and 9, I figured that was not the solution and quit trying additional channels.


    But channel 1 evidently works.


    Initial evaluation would make one think this was a HW problem, but....  it happened on both of our phones at the same time, which is too much coincidence for a HW issues - especially on 2 different models of phone carried by two different people to very different places and kept in different circumstances for the most part (except when we are home, obviously, but most of the time, we are off at work - my husband keeps his phone with him all of the time, while mine stays in the car while I am at work.) 


    All of this leads me to the conclusion I've seen from some others - that this is a firmware bug, and that some issue triggers the bug.  In this case, I would think that we likely had something in our home network that triggered it.  I haven't tried other channels to see if any others will work.


    The next step is to put in a bug report with Apple.  I would highly suggest that EVERYONE experiencing this problem do the same, and put as much detail of what the exact problem is, the troubleshooting you have done, and what, if anything, made the wifi on the phone work again.  This is the only way that they will look into the issue and find a solution - the more tickets they get for the problem, the more likely it is that they will do something.  Also, just calling in to support and getting help with the problem does NOT get this kind of ticket submitted.  Developers should know how to submit this... if you are not a developer, you can still submit a bug report by going to the feedback section of the Apple site ( ) and selecting "bug report" as the type of feedback.


    Please, everyone, do this.  This problem obviously needs fixed, and it won't happen if people do not submit this as a bug.

  • Lawrence Finch Level 8 (35,085 points)

    It's much more likely that the default channels are overloaded in your area, so setting it to channel 1 gets around this problem. I have Verizon FiOS and connect 2 phones to my WiFi network with no difficulty. So it's a very odd bug that only affects you.


    Another possibility is that you have interference from some nearby device that is messing with your WiFi. Cordless phones are a common cause of this.

  • osxgirl Level 1 (0 points)

    This would have been my assumption as well if it weren't for the fact that a) SO many people are having the same problem, and b) this problem did not affect any of our other wireless connections, including our two iPads.  This happened only with our iPhones.  As stated above, our Mac Pro, two MacBook Pros, Mac mini server, and two iPads (along with a NAS, 3 TiVos, and a network printer) have no problem connecting even when the channel is left at automatic.  I also tried the channel set manually to 11, 10, and 9, and again, none of the devices connected wirelessly had any problems - except the iPhones.  An overloaded channel would affect our entire wireless network, not just the iPhones.


    I would agree that overloaded channels MIGHT play into this - it could be that the iPhone is more sensitive to crowding on the channel.  But that still indicates a bug to me - if iPads and OS X devices can handle it, then the iPhones should as well.


    The above arguments apply to the idea of wireless interference as well.  Both types of signal issues should affect the entire network equally, not selectively target the iPhones.


    With wireless interference, the exception might be if we were trying to connect the phones closer to a source of interference than the other devices sit.  That is not the case either.  I was sitting at the Mac Pro and my husband was sitting in front of his MacBook Pro when trying to connect the phones.  I was using the iPad connected wirelessly to read forums while trying to connect the iPhone.

  • Vorocity Level 1 (0 points)

    This might be obvious, but I was having this problem today as well with one iPhone on my home wifi. We also have another iPhone, 3 iPads and a bunch of other pc's etc which work fine.  Anyway, nothing I tried would allow me to get the iPhone on the wifi, and then I did a cold boot of the phone. Boom. Perfect.

  • Angie'siphone Level 1 (0 points)

    I have tried all of the solutions everyone has offered, but I'm still haven't difficulty.  I click my router, type in the password, it shows that it is trying to connect, but never actually makes the connection.  The little circle thing just keeps going around and around.  I am having this problem at my house, my boyfriend's house and out in public places that offer free wifi.


    I have reset the network settings, tried a cold boot and reset the route several times.

    Any suggestions?

  • Angie'siphone Level 1 (0 points)

    *still having difficulty.

  • Lawrence Finch Level 8 (35,085 points)

    If it happens with all WiFi hotspots the problem is your phone, not the router. Try removing the case, on the chance it is shorting the antenna (part of the metal band around the phone).


    You say you have Reset Network Settings. Next try Reset All Settings. If you still have the problem and your phone is not jailbroken Restore the phone by connecting to iTunes and click the Restore button in iTunes. When asked choose to set up as a new phone rather than restoring backup.


    If the problem still exists you have a hardware problem; take it to an Apple store for diagnosis.


    If the problem is resolved by restoring as a new phone try restoring the backup (right click on the phone's name in iTunes and choose Restore from Backup). If the problem comes back you have corrupt data in iOS; you will have to restore again as New, then manually add back your music, apps and other content.

  • phillyphil Level 1 (0 points)

    I've had similar issues.  3 weeks ago, all Apple devices (iPhone 4, 2 iPod touches, and MBPro 10.6.8) could connect to the Internet except my MacMini running 10.7.3.  It was showing up as connected to the network but when I would run diagnostics, internet and server would show up red and then turn to green and the diagnostics would tell me that the internet was working fine - which was a lie.  In that case, I removed an Airport device from the network that I was using to extend the network and it started to work for some reason. 


    Then I just updated my MacMini with a few updates the other day, including the new Java security update, and wham - now nothing except my MacMini will connect. Tried rebooting, tried a clean restart on my iPhone running iOS5.1, tried cycling WiFi off on off, removing all remembered networks - and nothing.  It shows that is connected to the network but no internet access.  All the IP address info, DNS and search domains all look good. 


    Apple is really ******* me off these days.  I won't even mention the iPhone battery issues.

  • nanotazzy Level 1 (0 points)

    I solved this issue by going to my router's setup page (found by typing in the web address but every router is different. check the bottom or side of your router for this address).


    I then went to the tab labeled Attach Devices.


    I manually typed in the Wi-Fi Address for my iPhone 3GS found under the Settings application on the phone. Just go to General Settings > General > About and then you should find the Wi-Fi Address (ex: A9:09:77:98:18:45).


    Hope that helps

  • RJRCO Level 1 (0 points)

    My iPhone 4S will not connect to my home wifi any longer.  Just started today, has connected with no problem since I got it, why now?  I did find a bandaid, but shutting off the "cellular data" in Settings-General-Network.  When you shut off the cellular data, the wifi appears!  Not sure why this just started!  Does Anybody know what happened?  Was it due to the last OS update?

  • Stg531 Level 1 (0 points)

    I have tried everything, resetting this, restoring that, and nothing has worked.  Our internet went out yesterday and the entire house was affected.  This morning everything was back to normal (iMac/iPad) except for the fact that all our iPhones are unable to connect to our WiFi network.  I spent literally all morning on the phone with our cable provider and cellular provider and could not come up with a solution.  We ran diagnostic tests on the router..a-okay. 

    I went to the Apple store today and did a diagnostic test on the phone..all checked out great, even the WiFi worked fine.  The problem lies in a glitch in our iPhones (4 and 4s) and our home network.  Our router is fine.  I have an appointment this evening with an Apple Genius....lets see what I find out.  I'm printing all the previous posts and taking them with me.

  • Stg531 Level 1 (0 points)

    Just wanted to ask if anyone out there found a solution.  Thx.

Previous 1 2 3 4 5 Next