4 Replies Latest reply: Jul 12, 2010 3:55 PM by KJK555
LiveToFly Level 1 (5 points)
Hello all,

I am having trouble with my mac, it is a brand new imac with 10.6.4 os x snow leopard on it. I have lost the password to my User's account and need to recover it. I do not have the CD anymore and was wondering if anyone had something that could do the job. Otherwise I thought about using Single User Mode on the mac, to gain access to a shell account. I have tried the following techniques:


/sbin/mount -uw /
passwd root


The two problems I am having with this is that, one it is not changing my User's password and two it will never get past /sbin/SystemStarter . For some reason I type it in and it just stops there. Nothing else loads and the command never enters. Could it be that it just takes a long time to use? I am not sure.

The second technique I tried was


fsck -fy
mount -uw /
launchctl load /System/Library/LaunchDaemons/com.apple.DirectoryServices.plist
dscl . -passwd /Users/username password

## Replacing the ^ username and password ^ with my account and new password


This again failed with no success. I am not sure what exactly happened with this command but something didnt work.

After that I tried a mix of the two using the SystemStarter commands before the second technique, still with no success. Does anyone have a solution to this problem that could be used to recover my lost User password. I am not looking to reset the Root password because one cannot log in as the root user in multi user mode.


Message was edited by: LiveToFly

Imac, Mac OS X (10.6.4), Single User Mode Help?