13 Replies Latest reply: Oct 3, 2010 3:37 AM by aRIng
Jaden Pretzlaw Level 1 Level 1 (0 points)
I'm trying to download and install OpenOffice for Mac. Every site I go to gives me a .dmg file and when I try to open it, I'm prompted with a message that says it isn't recognized. Is there something I'm missing here?

MBP, Mac OS X (10.6.4)
  • 1. Re: OpenOffice for the Mac
    Kappy Level 10 Level 10 (226,855 points)
    Not sure what you are downloading, but the version you want is here.

    The error you receive suggests you have a defective download. Try again. If you are having trouble opening .dmg files then there may be a disconnect between the filetype and the associated application needed to open them. Select any .dmg file. Press COMMAND-I to open the Get Info window. In the Open With section you should see Installer as the default application. If it isn't the default then from the drop down menu find /System/Library/CoreServices/Installer. Select it and click on the OK button then click on the Change All button.
  • 2. Re: OpenOffice for the Mac
    Jaden Pretzlaw Level 1 Level 1 (0 points)
    I was able to follow your instructions quite easily and when I did that, it still gave me an error when I tried opening it. Here's what it said "The operation couldn't be completed. (com.apple.installer.pagecontroller error-1.) Couldn't open "OOo3.2.1_MacOS_x86_installen-US.dmg". Quite simply, all I did was download the file from the website you gave me, changed what it used to open the file to "installer", applied the change all and that's it. Not sure what else can be done. What do you think?
  • 3. Re: OpenOffice for the Mac
    Kappy Level 10 Level 10 (226,855 points)
    Well, that's surely a puzzle. Where is the file? Any chance there's another copy of the file in the same location?

    You might want to do this as a start:

    Repairing the Hard Drive and Permissions

    Boot from your OS X Installer disc. After the installer loads select your language and click on the Continue button. When the menu bar appears select Disk Utility from the Installer menu (Utilities menu for Tiger, Leopard or Snow Leopard.) After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list. In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive. If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the installer. Now restart normally.

    If DU reports errors it cannot fix, then you will need Disk Warrior and/or Tech Tool Pro to repair the drive. If you don't have either of them or if neither of them can fix the drive, then you will need to reformat the drive and reinstall OS X.

    If no help then try booting into safe mode and then try to open the disc image.
  • 4. Re: OpenOffice for the Mac
    Jaden Pretzlaw Level 1 Level 1 (0 points)
    So I was able to boot up from the disk and do the disk repair and to repair the disk permission, with no errors detected but it still gives me the error when I try to open that .dmg file. Would you suggest that I reinstall the Mac OS X?
  • 5. Re: OpenOffice for the Mac
    Kappy Level 10 Level 10 (226,855 points)
    Have you tried in safe mode?

    Let's not yet reinstall OS X. I would suggest downloading a utility such as TinkerTool System, Onyx. or Snow Leopard Cache Cleaner to clear out all system and user caches to be sure this isn't the result of some cache corruption.

    I would also suggest this:

    Rebuild LaunchServices Database

    For Tiger users

    Open the Terminal application in your Utilities folder. At the prompt paste in the following command in its entirety:

    /System/Library/Frameworks/ApplicationServices.framework/Frameworks/LaunchServic es.framework/Support/lsregister -kill -r -domain local -domain system -domain user
    Press RETURN.


    For Leopard and Snow Leopard users

    Open the Terminal application in your Utilities folder. At the prompt paste in the following command in its entirety:

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user
    Press RETURN.


    Message was edited by: Kappy
  • 6. Re: OpenOffice for the Mac
    Jaden Pretzlaw Level 1 Level 1 (0 points)
    I was able to run the laptop in safe mode and also run a cache cleaner on my system and yet the problem still persists. I tried that other method too with opening the terminal and imputing that command message and I didn't see anything result from it. Is there another step that I missed in the process?
  • 7. Re: OpenOffice for the Mac
    Jaden Pretzlaw Level 1 Level 1 (0 points)
    Hmmm, I just located something interesting...in the lower right corner of my browser I see a message "One active download (1 hour, 15 minutes remaining). I clicked on it and there's a file downloading and its the same file I've been trying to open all this time with the installer. The file size is 170mb so I'm guessing that's the OpenOffice suite, what I'm curious on is why it never popped up that it was downloading to begin with. I bet the error message was prompting me because it was already downloading?
  • 8. Re: OpenOffice for the Mac
    dbsneddon Level 4 Level 4 (1,525 points)
    Rather than OpenOffice, you might consider NeoOffice from http://neooffice.org/

    Dave
  • 9. Re: OpenOffice for the Mac
    Kappy Level 10 Level 10 (226,855 points)
    Aha. That means you are trying to open a file that has not finished downloading.
  • 10. Re: OpenOffice for the Mac
    Jaden Pretzlaw Level 1 Level 1 (0 points)
    Hmm, to further this discussion, I need some more clarification. So the .dmg gets downloaded without any problems through my browser, it's a rather large file so that makes sense that it's a executable file? But when it finishes it won't let me click on it to initialize the set-up? Why is that so? It continues to prompt me with the same error that it was before, leading me to believe that there's something still wrong with my computer.
  • 11. Re: OpenOffice for the Mac
    Jaden Pretzlaw Level 1 Level 1 (0 points)
    So I figured out why I wasn't able to initiate anything with that .dmg file, apparently it was a image that needed to be mounted via the disk utility application. When I opend that up and brought in the .dmg file then clicked on it "presto" it recognized the file, mounted it and I was able to install the program. Thanks for your help on this matter!
  • 12. Re: OpenOffice for the Mac
    gnwiii Level 1 Level 1 (10 points)
    There is also "IBM Lotus Symphony 3" -- yet another fork of OOo freely available (currently beta test version).
  • 13. Re: OpenOffice for the Mac
    aRIng Level 1 Level 1 (0 points)
    This was very helpful for me. Thank you very much!