9 Replies Latest reply: Jul 6, 2010 5:47 AM by KXsig
manowak Level 1 (0 points)
Hello All-

I've been trying to help someone with a brand new OS X 10.6.4 MacBook Pro. A couple of days ago, in trying to build & run some software from /usr/local/src/..., we were getting some funny complaints about permissions not being properly set to read some associated files. OK, we tried changing the permissions of the directories to be world readable, e.g., did a "sudo chmod -R a+r /usr/local/src/...". And that didn't work. We knew someone else who had the same problem with the same software, and had gotten it to work by changing the group ownership to admin. This part, I didn't see, but the person's who's laptop this is went off and later ran a chgroup on the same directories. Since then, the whole machine won't boot up into anything other than single user mode. We've tried everything we could think of, and dig up on the forums. We ran through all the Apple Support pages suggestions for what to do when all you get is the grey screen.We've cleared the PRAM & NVRAM. Did somehow we screw with the permissions on the disk? Finding some of the discussions on the forums, following the path of:

mount -uw /
chmod 775 /
chmod 1775 /

doesn't help. I would try to repair disk permissions and/or the disk, if I could boot off the install disk, but we can't.

The boot stays stuck on the grey screen (which it's been doing now for the past 10 minutes, after having tried clearing the PRAM & NVRAM), or, it eventually stops and throws up the little box saying that it's encountered an error, and the machine has to be rebooted (which is what it did the last time we tried to boot off the install disk). (It's the same error box that I got after my own MacBook Pro got zapped by a power surge.)

So, given that we can only get into single user mode, anyone have any suggestions? I'll post more diagnostic information, if there is something that we can get via single user mode that people would like to see.

MacBook Pro, MacBook Pro
  • Neville Hillyer Level 4 (1,865 points)
    Is there any important data on this new Mac? If not why not reinstall everything?

    If there is important data perhaps you could find a way to back it up and then reinstall.

    Have you tried the disk repair instructions that the single mode screen invites you to use?
  • manowak Level 1 (0 points)
    Yes, we have tried the fsck (no errors detected). One of my more linuxy friends
    has spent about two hours digging through things, trying to run various repairs,
    change permissions, etc. No luck. He is convinced that there is something amiss
    with the master boot record.

    There is nothing important on this machine, since it's only a week old. However,
    we really can only get to single user mode, and we can't get it to see the install disk at all.

    If someone can point us to a forum on how to do a complete reinstall from single user mode, that would be helpful, since that's the only way we're rebuilding this thing.
  • Neville Hillyer Level 4 (1,865 points)
    The boot volume must not have 'ignore ownership on this volume' selected although this appears unlikely.

    The boot volume must also be readable by everyone.

    Why not insert the install DVD, start from it and reinstall everything.
  • Neville Hillyer Level 4 (1,865 points)
    oops - I see that you cannot start from the DVD.

    Why not return it to Apple?
  • Neville Hillyer Level 4 (1,865 points)
    Your DVD drive may not be working.

    I sometimes install Leopard from a copy of the installer on my hard disk with the following:

    sudo /Volumes/20-B/System/Installation/CDIS/Mac\ OS\ X\ Installer.app/Contents/MacOS/Mac\ OS\ X\ Installer /Volumes/20-B/System/Installation/Packages/OSInstall.mpkg

    As you will see the volume I install from is called 20-B. I am not sure if this will help you. It allows me to install in the background. This is faster and more reliable than installing from a DVD.

    Please note that this is for Leopard - Snow Leopard may be different.
  • Neville Hillyer Level 4 (1,865 points)
    I assume from what you said that you have followed the advice on the following:


    My understanding is that it should boot from DVD with the c key held no matter what you have done with the disk.
  • KXsig Level 2 (305 points)
    Hi there,

    Other startup key shoot would be OPTION held down + Power button - this should show you possible boot volumes. With your install DVD inserted this option should bring you internal HD and Install DVD.

    As N mentions Power button + "c" would force DVD/CD startup.

    Other then Power button + SHIFT (that would bring safe boot), and the fairy tales Power button + SPACE BAR (would bring extension manager), COMMANDOPTION+SHIFTDELETE (that would force CD/DVD startup) and others - that you could give it a try - I would bet in a hardware failure.

    Good luck.
  • manowak Level 1 (0 points)
    Well, after attempting every different kind of startup possible with a Mac, and doing all sorts of repairs and permission changes, we got this laptop to come back up (into something other than single user mode) once. At which point we ran a disk repair, and disk permissions repair, and then tried to reinstall the system. And then it died again. We're going with the hypothesis of it being a hardware issue, so back to the store it is going to go. (Unless someone has a last minute clever suggestion...)
  • KXsig Level 2 (305 points)
    Hi M,

    Repair disks and permissions should be done in a safe boot or - better if - from another startup boot volume.
    As a last resource you could dismount the computer and see what's going on with this S keyboard key this is somehow locked!! Try to boot with machine upside down!
    Pay to see if someone come up with something clever then this now...