Previous 1 2 Next 18 Replies Latest reply: Aug 26, 2014 8:14 AM by jlfpeters
Martin Nelson Level 1 (50 points)
If I go to a PDF link in Safari, it insists on trying to open the with Adobe Acrobat, which isn't currently licensed for my computer. When this doesn't work it crashes Safari. How do I get it to default to preview? PDFs on my computer are defaulted to open with Preview already.

Martin

2 x 2.26 GHz Quad-Core, Mac OS X (10.5.8), FCP 7, QuickTime Pro 7.6.4
  • Carolyn Samit Level 10 (103,365 points)
    HI Martin,

    Right or control click a PDF file you have saved on the hard disk, then click: Get Info.

    From the "Open with" pop up menu click: Preview then click: Change All.








    Carolyn
  • Martin Nelson Level 1 (50 points)
    I'm already set up that way and still Safari wants to use Acrobat. I realize I can download the pdf and then open it with Preview, but if it's just a restaurant's menu or the like, I would rather take advantage of Safari's ability to open it in a window.
  • Carolyn Samit Level 10 (103,365 points)
    Ok...

    Try this.. Delete the file HD/Library/Internet Plug-Ins/PDF Browser Plug-in.  

    Relaunch Safari.







  • Martin Nelson Level 1 (50 points)
    That sounded like that would do it, but there isn't such a file in that folder. Nor is there one in that path under my user folder.

    Martin
  • Carolyn Samit Level 10 (103,365 points)
    Unless you need Adobe Acrobat Reader installed, move the app to the Trash.

    Also, go to Safari/Preferences - General. Make sure Safari is set as your default browser.








  • andyBall_uk Level 7 (20,490 points)
    Hi

    try

    defaults read com.apple.Safari WebKitOmitPDFSupport


    in Terminal

    or just lose the safari.plist & if that was it, pdf's will work again
  • Martin Nelson Level 1 (50 points)
    Carolyn Samit wrote:
    Unless you need Adobe Acrobat Reader installed, move the app to the Trash.

    Well, I do sometimes need Reader. And it works fine if I simply choose, outside Safari, to open a file in it rather than in Preview. Part of the problem may be that I've got two startup disks on my Mac and the other one (where I don't have this problem) has Adobe CS4 with Acrobat Pro installed and licensed. I can't license it on this startup because of Adobe's licensing limit.
    Also, go to Safari/Preferences - General. Make sure Safari is set as your default browser.

    Tried that, Carolyn. Seems to make no difference.

    The exact message, btw, is "Before proceeding you must first launch Adobe Acrobat and accept the End User License Agreement.



  • Martin Nelson Level 1 (50 points)
    andyBall_uk wrote:
    try

    defaults read com.apple.Safari WebKitOmitPDFSupport


    in Terminal

    Tried that. Didn't work. Got this back from terminal:

    The domain/default pair of (com.apple.Safari, WebKitOmitPDFSupport) does not exist

    or just lose the safari.plist & if that was it, pdf's will work again

    Tried that. Still crashes.

    All these ideas sound great. So far, I'm still in a bad way though.

    Martin
  • andyBall_uk Level 7 (20,490 points)
    Interesting -

    same thing in a new account ?

    ---

    What actually is there in Internet Plug ins ? (you can select them all, copy, and it'll paste just the names here)

    Wonder about input managers & login items & launch agents/daemons too - but let's see the plugins first.
  • Martin Nelson Level 1 (50 points)
    andyBall_uk wrote:
    same thing in a new account ?

    Don't know. I'll try when I can.
    What actually is there in Internet Plug ins ? (you can select them all, copy, and it'll paste just the names here)

    VerifiedDownloadPlugin.plugin
    Silverlight.plugin
    RealPlayer Plugin.plugin
    QuickTime Plugin.webplugin
    QuickTime Plugin.plugin
    Quartz Composer.webplugin
    nsIQTScriptablePlugin.xpt
    NP-PPC-Dir-Shockwave
    JavaPluginCocoa.bundle
    JavaPlugin2_NPAPI.plugin
    Flip4Mac WMV Plugin.webplugin
    Flip4Mac WMV Plugin.plugin
    flashplayer.xpt
    Flash Player.plugin
    AdobePDFViewer.plugin

    Martin
  • andyBall_uk Level 7 (20,490 points)


    AdobePDFViewer.plugin

    Quit Safari, move that out, try again.
  • Carolyn Samit Level 10 (103,365 points)
    I've tried that myself without much success.
  • Martin Nelson Level 1 (50 points)
    andyBall_uk wrote:


    AdobePDFViewer.plugin

    Quit Safari, move that out, try again.


    That did it, Andy. Thanks.

    Martin
  • Carolyn Samit Level 10 (103,365 points)
    I'm whistling in the wind. I suggested that in a prior post.
Previous 1 2 Next