3 Replies Latest reply: Jul 9, 2010 3:02 AM by Bass.Star
Bass.Star Level 1 Level 1 (0 points)
I've got an iPhone 3GS that does not backup. It all started last fall when I upgraded my PC to Windows 7 64-bit. Before that, backups were slow, but still worked on Windows XP 32-bit. Since then, I have no current backup. This creates a problem because I can't upgrade to iOS4 without a backup. And I can't restore the iPhone to factory settings without a backup. Heck, I tried setting an appointment at the Genius Bar and the one thing they won't support is backing up!

The main issue is that the backup goes EXTREMELY slow. Too slow, considering it is an in-use phone that can't be left backing up for days on end. Now, last night I did try another backup, with the intent that I could leave it for well over a day. When I checked this morning, it looked as if the backup process had completed. But when I went to the Devices backup list in Preferences, it was listed as Unknown, backed up on 12/31/2000

Now, just a little troubleshooting info that I've tried:
-I've tried on a different PC running WinXP
-My main PC backs up my iPhone4 and my 1st-gen iPod Touch (OS 3.1.3) perfectly fine. So, I know there's not a PC issue preventing backing up.
-I've tried resetting Sync history and resetting warnings
-I disabled sending troubleshooting info to Apple (read one website that said that may cause a hang-up)
-I tried a powered USB Hub
-I switched to my brand-new never-used USB cable that came with the iPhone 4
-I removed ALL media and the largest apps from the iPhone, so as to make the backup as small as possible
-I have the exact same issues with a 1st-Gen iPhone, so I feel the problem isn't phone-specific.

Is there anything that I can do to get this data backed up? I desperately want to upgrade to iOS4, and I'm willing to do a factory reset to see if either will fix the problem, but I don't want to do either without a proper backup.

Thanks in advance for any help.

iPhone 3GS, Windows 7