Previous 1 2 3 Next 110 Replies Latest reply: Feb 4, 2016 10:24 PM by hooshang1335 Branched to a new discussion.
blizzardkmb4 Level 1 Level 1
About two weeks ago the wireless range on my MacBook suddenly fell dramatically, so I have to be about twice as close to the router to receive signal, corresponding to a four-fold decrease in signal reception.

Let's say X is the old wireless range. When the laptop is within 1/2X, the internet works perfectly. When I am at distance X, the network doesn't appear. When I am at 3/4X and try to connect to the network, I get "Connection timeout" notices. Sometimes after I enter in my password and click "Connect," the "Network Preferences" window reloads the password prompt dialog box, with an empty password. If I turn off the AirPort and turn it back on, the network often fails to appear unless I move back to within 1/2X.

The wireless router is 3Com, with WEP encryption. I am 99% sure that the problem is with my computer, because my brother's similar black Macbook gets wireless in the old areas with no problems. I'm using and for DNS.

I've tried: Forgetting the wireless network and then reconnecting to it, powering off and on the router, manually entering the network name and password, and none of these steps has worked. I would appreciate if you could tell me other steps I can take to troubleshoot the problem, including possibly checking for damage to the wireless antenna. Thanks very much!

White late 2008 Macbook, Mac OS X (10.6.4)
  • Side_Step_Society Level 2 Level 2
    Well this is strange.

    I encountered pretty well the EXACT same problem on my late '06 Mac mini about a week/two weeks ago.

    It started when I was in Windows 7, I noticed my signal was quite low. 2 bars out of...5? I've always had 5 full bars in the past, nothing's changed with my network set up either. I thought Windows was tweaking out or something, so I tried rebooting into OS X, nope, signal was no better, actually worse, one bar in the Airport icon. I as well got Connection Timeouts and the network wouldn't appear, etc, etc.

    So, I thought maybe I had dislocated the antenna when I had the mini apart previously. So, I opened it up, double checked my connection, seemed to be connected fine. I let the computer sit unplugged for 1-2 days (can't recall how long exactly) and reset the SMC and the PRAM and booted it back up. I had full wireless signal again, for awhile. Eventually it started "draining" down again. And it seemed every time I booted to Windows then back into OS X, it would REALLY "drain".

    Then I noticed one day while in Windows 7, whilst the computer was heating up from some graphic intense programs, my wireless signal seemed to increase. Which leads me to believe perhaps some solder is weak somewhere, however, I also noticed there's been times when it's hot that it doesn't increase the signal strength.

    As of now, I have full bars, and it seems to be sticking around. The last thing I did was left the computer on (In Windows) overnight and all day, downloading some large files, and I don't know if maybe the increased activity heated up the Airport card/antenna and fixed something, but everything seems to be in order right now. I can boot back and forth between Windows and OS X without my signal dropping and it doesn't seem to be fluctuating like it was.

    Have you tried resetting your SMC and PRAM? If not, try giving your Airport card a big task to do for awhile and see if anything should change. That might sound ridiculous, but hey, seems to be holding up for me.

    Best of luck!
  • blizzardkmb4 Level 1 Level 1
    Thanks for replying. How do I reset the SMC/PRAM?
  • thewk Level 1 Level 1
    I also have this same problem with Macbook 2006. There is something about the heat. I did take out the Airport card and try it in my Fujitsu Siemens Amilo li2727, works perfectly so the card itself is probably not broken. I swapped Fujitsu's card to Macbook and used Xubuntu Linux which works perfectly and the signal does not drop, I can't use this card with Mac OS X because there is no drivers, but I have ordered new card in hope that it fixes the problem.

    Weird thing is that Fujitsu's original card didn't work well with it and Macbook's one works perfectly, and apparently situation is same vice versa
  • blizzardkmb4 Level 1 Level 1
    Does that mean that I could take the Airport card out, swap it into my brother's macbook and rule out the card as the source of the problem?
  • thewk Level 1 Level 1
    Well yes you should be able to do that if it physically fits, according to what I have heard newer Macbooks may have smaller card, but as long as it has mini PCI-E and fits otherwise you should be OK.
  • blizzardkmb4 Level 1 Level 1
    I tried resetting both the PRAM and SMC and neither of those helped, unfortunately... unscrewing my brother's wireless card and trying it in my laptop to see if the card is the problem.
  • blizzardkmb4 Level 1 Level 1
    I unscrewed and removed the wireless card. Unfortunately, my brother's laptop had screws that were too difficult to remove, so I couldn't remove the wireless card from his laptop. When I screwed in the card again and fired up the laptop, it worked in the usual range for a period of about ten minutes and then stopped working again. It's still working within the usual range.
  • NobreAngel Level 1 Level 1
    My MacBook is having the same issue as yours. Actually my airport just connects to the wifi when my MacBook is very near to the router. I don't know what is happening here but I have almost sure that the problem is from my MacBook's airport card. :/
  • dsam7 Level 1 Level 1
    Mine too has recently been experiencing a weak signal ( or no signal at all!) unless I am close to the router. I have tried all the advice offered on other Mac posts without success. Is replacing the wireless card the only solution I wonder?
  • NobreAngel Level 1 Level 1
    What macbook model is yours? I see that everyone that is experiencing this issue, the MacBook model is from 2006.

    And this problem started to happen about a month ago with me, I think.

    I wonder if Apple is aware of this situation.

    I'm considering about to replace my AirPort card but I'm going to wait a lil'bit to see if Apple is going to make a recall or something, because I see that a lot of people is having the strange issue.
  • Side_Step_Society Level 2 Level 2
    I imagine the same card used in the MacBook was also used in the mini, and perhaps in the MacBook Pro (depending on model/configuration options available at the time), perhaps even Mac Pro, tough to say. I wouldn't say this is just a MacBook problem.

    I'm going to go out on a limb and say the Airport cards used in some (or even most) '06 Macs (including, but not limited to, MacBooks and minis) have some solder failing somewhere.

    Hopefully this thread can lead to some sort of fix/answer.
  • NobreAngel Level 1 Level 1
    I think you are right. I think it's affecting the airport card used in '06 Macs. I just said about '06 MacBooks because I see a lot of complaining about their airport and mine is also a macbook, the first gen actually, and this issue is driving me crazy too 'cuz I see a lot of complains about the airport, same symptoms and no answers.

    I want my airport working and I need it working. That's the only way I can connect to internet and blue cables around the house isn't a good thing to do and to have. I just can connect to the internet with the airport just very close the router and it's really frustrating.

    I wish that Apple says something about this issue, 'cuz I don't think it's normal to have a lot of complain about the same issue and with an especific generation of Macs. Please, correct me if I'm wrong.

    My temporary solutions are: get cable internet or use your Mac very close to the router and be patient if the connection drops even it's being so near to the router.
  • blizzardkmb4 Level 1 Level 1
    It's possible we are having different issues. I went to the Genius Bar, they told me that it's possible that my wireless network isn't picking up my laptop properly. They said try adding a DHCP Client ID, and if that doesn't work, resetting the wireless network settings. Doubtful those will work, but we'll see when I try it out tonight.
Previous 1 2 3 Next