1 2 Previous Next 16 Replies Latest reply: Apr 1, 2012 6:31 AM by sdqwerty
ku-man Level 1 Level 1 (95 points)
I keep getting this message every time I open iTune, "Do you want the application "iTunes.app" to accept incoming network connections? I have set accept in security preferences, what is it all about? Thanks Alex

Macbook Pro 15 2.4GHz Intel Core i5, Mac OS X (10.6.4), Mini iPod/Lacie D2/iPhone 3G/Time Capsule 500GB
  • 1. Re: Incoming network connections message
    shushtime Level 1 Level 1 (30 points)
    You probably want to yes to that. Incoming network connections will be used when you try to use the itunes store and sharing features.
  • 2. Re: Incoming network connections message
    ku-man Level 1 Level 1 (95 points)
    I did say yes but it keeps asking me every time I open itune, quite annoying. By the way, my firewall is turned on, it happened right after I turned on my firewall, I also change the setting to allow itune for connections, still doesn't work. Thanks Alex
  • 3. Re: Incoming network connections message
    zeroink Level 1 Level 1 (0 points)
    I had this problem where Growl constantly asked me to give incoming network permissions.

    This is what I did, and maybe it can resolve your issue:

    Go to you System Preferences>Security (unlock bottom left)>Advanced>

    Scroll down to find iTunes.app. Highlight it, then click on the "minus button" to remove it. Click Ok.
    Reboot.
    Open iTunes.
    It will ask again about accepting incoming network connections.
    Click accept.
    Reboot.
    Open iTunes.
    It should not pop up again, since the exception was recreated. (hopefully!

    Good Luck!
  • 4. Re: Incoming network connections message
    ChrisMD Level 1 Level 1 (0 points)
    I tried this hint, and it didn't work. I just wanted to add this for those who see this in the future. Maybe something specific to Growl allowed it to work, but it didn't work for iTunes for me. I posted a feedback notice to Apple, regarding the issue.

    It would be nice if there was a (hidden) preference that could be toggled regarding enabling or disabling this check, so that users could disable until the bug was fixed.
  • 5. Re: Incoming network connections message
    JimN Level 2 Level 2 (255 points)
    I had the same issue and followed the above note provided by "zeroink" but you'd only have to manually add it if you don't have "Automatically allow signed software..." checked.
    Not sure which version of OSX you're running however, this is what I found running OSX 10.6.4 and iTunes 10 (67):
    I went in to "Firewall" / "Advanced" and if you have checked "Automatically allow signed software to receive incoming connections" then just simply do the following:
    - remove iTunes from the list and reboot.
    - once rebooted, start iTunes again, it will automatically register itself into that window (because its signed software) and will allow incoming connections without your intervention.

    Hope this helps.
  • 6. Re: Incoming network connections message
    Anders Vessel Level 1 Level 1 (0 points)
    If you have changed anything within the iTunes package, E.g. the icon, then this will go on forever.

    Download the iTunes installer from Apple.
    Drag current iTunes from the Application folder to the Trash.
    Empty Trash
    Install iTunes again using the just downloaded installer.
  • 7. Re: Incoming network connections message
    darius_shane Level 1 Level 1 (0 points)
    I have an even better solution for you. No uninstalling or re-downloading.

    In security (located in system preferences) Click the firewall tab followed by the advanced button down the bottom. Check all the applications you want are set to allow incoming connections. Close security preferences. Then open a finder window Navigate to -> Macintosh HD -> Library -> there will be a file called, com.apple.alf.plist delete it, reboot and your done. Deleting this small file re-builds the Firewall preferences and you will no longer be asked to accept incoming network connection every time you open an app. As long as the app your opening is on the list in the firewall tab your good to go Email me at shane.shanus@gmail.com if this worked for you
  • 8. Re: Incoming network connections message
    macmom42 Level 1 Level 1 (20 points)
    darius_shane, did you happen to check to make sure your firewall was still on after you got rid of that preferences file? Deleting it does not actually "rebuild" anything, it just creates a new prefs file and starts over from scratch with no signed software in the list at all. In my case all of the signed software that was there before was gone and my firewall and stealth mode had been turned off (I know they were both on previously). So yeah, with no firewall turned on, of course I wasn't asked to accept any incoming network connections! Thank goodness for Time Machine so I could put back the old prefs file.

    Message was edited by: macmom42
  • 9. Re: Incoming network connections message
    adamrc Level 1 Level 1 (0 points)
    Uninstalling it and reinstalling it was the only solution that worked for me.
  • 10. Re: Incoming network connections message
    George Paphitis Level 1 Level 1 (60 points)
    I concur changing anything in the Contents pkg. results in the annoying incoming connection message. I used the hack to restore color to the icons in iTunes and got my colors back along with the annoying message on every launch of iTunes. Undoing the hack removed the message for me. I now have another annoying message on quitting iTunes something about an iTunes plugin unexpectedly quitting. This message has plagued me even before and after the aforementioned hack. The only iTunes plugins I have are G-Force and Whitecap...extra visualizers from outside of Apple source.
  • 11. Re: Incoming network connections message
    lab_rat Level 1 Level 1 (0 points)
    Thanks it worked for me.
  • 12. Re: Incoming network connections message
    gazrsvr Level 1 Level 1 (0 points)

    Kept being asked if I wanted Growl to accept incoming network connections, and google search bought me to this solution. Worked a treat, thanks.

  • 13. Re: Incoming network connections message
    Hamdani Milas1 Level 1 Level 1 (5 points)

    darius_shane, your plist removal tip worked for me, thanks. After Effects CS5.5 was constantly asking to allow incoming network connections upon launch although this was enabled for AE in Advanced Security Prefs. It would seem like a minor issue but the annoyance level had reached such a pitch of intensity that something simply had to be done.

    :-)

  • 14. Re: Incoming network connections message
    sungwook Level 1 Level 1 (0 points)

    I recently find out how to solve this.

     

    Create your codesign first using "keychain access" and then type the below commands in "Terminal"

    sudo codesign -f -s your_codesign_certificate_here /Applications/iTunes.app/

    codesign --verify -vv /Applications/iTunes.app/

     

    That's all!!

1 2 Previous Next