Previous 1 2 Next 21 Replies Latest reply: Feb 12, 2014 10:12 PM by JimmyShade
christena181 Level 1 Level 1
I have searched all over the internet for some information on the problem I'm having with Safari. It started when I downloaded Safari 5 (I'm running OSX 10.6.4). Sometimes when I type an address into my URL window or click an often used website from my home page "graph" Safari goes to a completely different website. For instance, I was trying to check the weather and clicked on the page on my "graph" and Safari went to Mapquest. So, I typed in into the url window and it still went to Mapquest. So, I opened up Firefox and checked the weather. On occasion, Firefox will pull the same trick as Safari after Safari has sent me to a wrong URL - sometimes it won't.

This past weekend, I was trying to go to Twitter and typed in the URL window and Safari went to some AOL Realty site (that I have never been to) and even after the page loaded, it clearly said on the URL window. Another time this weekend, again trying to go to Twitter and typing it in the URL window, Safari went to Chrysler's website (again was what the URL window said after the page got done loading).

What the heck is up with this????? Safari was slow to load and getting 404 errors when I first updated it to 5, so I've done all of the cache and cooking clearing, reset Safari, reset permissions, etc.

Again, I use Safari as my default browser, so when this happens I will open Firefox and sometimes it will do the same thing that Safari is doing and sometimes it won't. So, not sure if it's a browser specific problem or an OSX problem. My Macbook Pro is about 6 months old and I don't visit sites that are spam or hack type sites at all.

I use my Macbook Pro both at home and at work, so it happens with both my home and work wireless routers.


Macbook Pro, Mac OS X (10.6.4)
  • Carolyn Samit Level 10 Level 10

    You aren't alone. One thing you can do is provide feedback here.

    Safari was slow to load and getting 404 errors when I first updated it to 5

    Safari users find using OpenDNS Free / Basic beneficial to avoid redirects.

    Avoid url's autocompletion: The url's you see when you start typing a web page address are collected from your History and Bookmarks. One way to avoid that is to turn on Private Browsing from the Safari Menu Bar, Safari/Private Browsing. In private browsing, Safari won't remember the pages
    you visit, your search history, or your autofill information.

  • christena181 Level 1 Level 1
    I will turn on private browsing and see if that helps. I have been to Mapquest and used it quite a few times; however, I don't recall ever having gone to AOL Realty or Chrysler.
  • Carolyn Samit Level 10 Level 10

    Definitely try OpenDNS. If you haven't actually navigated to the AOL Realty or Chrysler site, it could be your ISP is using their DNS numbers and re-directing you.

    OpenDNS works.

  • Flunky Carter Level 1 Level 1
    I have this EXACT same problem.

    Every once in a while, I'll type and although is what shows up in the address bar, it's actually loading… because I get one of those google 404 error pages. Nothing works, restarting safari, restarting the airport… The only immediate fix that I've found is to flush the cache using "sudo dscacheutil -flushcache" in the terminal. Even then the problem resurfaces all to soon.
  • jsw15 Level 1 Level 1
    My Macbook does exactly the same thing - when I type in an address on Safari it will sometimes out of the blue take me to a completely different site - one that I have never been to. It happens a lot and is very frustrating, especially when I need to get something done. I have no idea why it does it and how to fix it - eventually the problem goes away on it's own but as I said it's very frustrating and inconvenient! I'm also very new to Apple so if anyone has any easily digestible advice I would be very grateful!
  • Mel Magree Level 1 Level 1
    I too have this wrong destination in both Safari and Firefox. I updated my website with a link to my blog; I clicked on the link and was taken to the New York Times Company. I forget whether I was using Safari or Firefox. I switched to the other and typed in the URL of my blog and was again taken to New York Times Company. This also happened a few days ago but I think it cleared up.

    To check if the problem was at our ISP, I tried it on my wife's computer and went right to my blog.

    The OpenDNS may be a solution, but I really don't want to bother with one more piece of software. I would like the existing software to work properly in the first place.

    Whatever happened to the "Computer for the Rest of Us". At least Macs don't crash several times a day like the mainframes I worked on a hundred years ago:)

    - Mel
  • Mel Magree Level 1 Level 1
    Carolyn Samit gave this suggestion at

    "From your Safari menu bar click Safari / Preferences then select the Security tab. Click: Show Cookies. Delete all cookies or delete the cookies associated the sites you have problems accessing.

    "Quit Safari.

    "And, open a Finder window. Select your Home folder in the Sidebar on the left. Now open the Library folder then the Caches folder then the folder. Move the cache.db file from the folder to the Trash.

    "Relaunch Safari.

    Bingo! It worked!

    But what about the poor user who gets flummoxed by this kind of workaround! It's big enough nuisance for those of us who have some deeper experience.

    BTW, something similar also works for Firefox. I deleted the files from Library->Caches->Firefox->Profiles
  • andyBall_uk Level 7 Level 7
    But what about the poor user who gets flummoxed by this kind of workaround! It's big enough nuisance for those of us who have some deeper experience.

    Hi Mel

    Often, using Safari-Reset Safari... with just cache & cookies checked will suffice, although the 'remove all cookies' option does just what it says, rather than the selective way you followed.
  • Mel Magree Level 1 Level 1
    Hi, Andy,

    Being the compulsive programmer I always was, I just jump from one idea to the other and don't keep good notes. A good way to do the wrong thing over and over:)

    However, I do think I cleared cookies and Safari still went off to the wrong site.

    Whatever, between Carolyn and your suggestions, I hope more people spend less time with this problem.

    - Mel
  • Krag Level 2 Level 2
    You can try setting your DNS to google (in Network/Advanced/DNS tab)
  • hoffmajd Level 1 Level 1
    i have the same problem. It is infuriating and it is recurring, i've gotten rid of it a few times but i never remember how i did it. Sometimes a simple reboot suffices. Either way I am a long time and loyal mac user, for over 15 years, and this is really starting to get on my nerves. They need to fix this bug immediately. It's be going on for long enough. If anyone has a good suggestion on how to fix this please pass it along
  • turtleman Level 1 Level 1
    OK, this is now happening to me. Yesterday (4/10/11) my bookmark for started going to the New York Times site. I tried typing the url by hand and even did a google search for and clicked on that link. Same result. I read this thread and did everything suggested (cleared cache, cleared history, deleted cookies for nyt and foxnews, trashed the cache db, restarted Safari, restarted my computer and it is still doing it.

    I'm using an iMacG4, running OS 10.4.3, Safari 5.0.4.

    I don't really want to try OpenDNS, beacuse I'm not really computer savvy enought to understand what that will do.

    This is really frustrating.

    Any other suggestions?
  • turtleman Level 1 Level 1

    I'm using an iMacG5, not G4 as I erroneously stated above.

  • turtleman Level 1 Level 1
    OK, it's cleared itself up...or something I did fixed it. However, the address/URL in the address bar still has the NYT logo (the Gothic T) in front of the URL (instead of the Fox News Logo).

    The whole thing is bizarre.
Previous 1 2 Next