13 Replies Latest reply: Nov 1, 2012 10:31 PM by Eric1007
abner goodwin Level 1 (0 points)
I work for the Help Desk at a medium sized company. We have a small group of Mac users who are scattered between a couple of departments. Recently, we replaced about 7 user's old iMacs that ran Leopard with new ones that run Snow Leopard.

These users connect to a network share on a Windows Server 2003 file server and work with various files and folders. They have They have full access on the share permissions and read and write access in the NTFS permissions for the files and folders that they work with on the share. Up until they started working with their new computers, they had no problems.

_The Challenge:_
The users have started having issues when they're moving, deleting, renaming, or performing some other action to a folder or files in a folder that had been previously worked on by themselves or someone else at some point that day. When they try to complete the action, they'll either get prompted for the credentials of a local user with administrator rights, or they'll just get an error stating something like the following: +"You don't have permission to rename the item "foo"."+ If administrator's credentials are provided, they get the error anyway.

When I look at the open files listed on the share in the server, I see that the files and folders in question are locked by the last user who worked on them. So now when a user is unable to work with certain files or folders on the share, I have to have the last person who worked on the file or folder log out of their machine, or I have to manually release the lock from the server side. This is not an ideal solution for this issue. Does anyone have any suggestions that they could offer to resolve this?

_Extra Info:_
The Macs are bound to an AD domain.
The new Macs are all running Adobe Creative Suite 5.
Files are created, edited, and manipulated by a user, THEN moved on to the share.
All of the new iMacs are Late 2009 models and their OS is up to date.
The user's local accounts are not administrators.

_Stuff I've tried to resolve this:_
* Replacing the smb.conf file from Snow Leopard with the one from Leopard.
* Testing using an iMac that is not bound the domain.
* Using different shares than the one that the issue was first observed on.
* Testing using a local administrator's account on the iMac.
* Enabling/Disabling streams on the iMac.
* Contacting an Apple "Genius" who told me that it was a Windows problem.

iMac Late 2009
  • K.M.123 Level 1 (0 points)
    Were you ever able to solve this problem. I'm having similar issues since upgrading to snow leopard. Four macs connect to a Windows Server 2003 for shared files. Each user has full permissions & when we "get info" it shows read & write permissions. Two of the computers were running 10.4, two were running 10.5. Everything worked properly until upgrading to snow leopard. Some files let me copy, move, delete. Others either just hang up or we get a "no permission" error. Also getting a "pdf is in use" error, even when the file/folder doesn't contain a pdf. We had our IT rep check the server who said everything is in working order. They don't represent macs any longer but feel that it's a mac problem. I would have to agree since this problem only started after the upgrade, and the one machine that was not upgraded (still running 10.5.8) is not dealing with these problems.

    Lastly, I would install 10.5 back on all of the computers if I could, but the leopard disk that came with one of the computers wouldn't work with the 2 machines running 10.4 and I didn't see it available at the apple store. I'll buy it if it's still available, but why wouldn't the disks that I have work?

    Thanks for any help
  • Holly Anne Balish Level 1 (15 points)
    I'm also having a similar problem, but only with new folders created by the user on the Snow Leopard machines. We typically connect to the Windows shares via SMB or CIFS and I've seen the problem with both. Right now, we're working around it by having the users do a Get Info on the folder and unlocking the lock under Sharing & Permissions.
  • PK Tjo o Tjim Level 1 (0 points)
    Same problem here; only difference is we have a Linux Samba server rather than a windows server.

    The Mac shows no locking or read-only tags, but windows users see the files as read-only. It generally just happens on directories that are created by the Mac.

    Files and directories can be deleted from the Finder or SMBCLIENT on the Mac.
  • CJMayville Level 1 (0 points)
    I have the exact same problem. This has been going on for months now. My Snow Leopard machines try to copy working files up to a 2003 Windows SMB file server and they get a "no permission" response. This happens copying, moving, and renaming files on the server. It's not a 100% thing either, but it happens frequently. When it does happen, I notice through a Windows Free application called Unlocker identifies the files as having been locked by the SYSTEM process with PID 4. I can unlock the files and then the user can copy their data, but a few hours later it happens again with a different folder. There are posts all over the web with similar issues like this, but no one has any sure-fire solutions. My Mac users are beginning to lose patience. I need something soon. Any ideas would be appreciated.
  • WDeignan Level 1 (0 points)
    We're getting the same thing. Our Windows server is 2008 instead of 2003, but otherwise the symptoms are identical. Dismounting the drive from the Mac running 10.6.4 closes the phantom file handle, but that's obviously not a long term solution since it interrupts work and requires closing any legitimately open files first.

    Maybe 10.6.5 will improve the situation? I'm seeing rumors it should be out shortly.
  • Digitallabels Level 1 (0 points)
    Hey Guys.

    Try this/ go in to sharing and turned on file sharing then options....
    Turned on Share files and foulders using AFP and SMB option on.
    Give Users: read & write
  • jg.gt11 Level 1 (0 points)
    Has anyone tried the above fix? (I will be trying it tonight on a few machines I'm having a simillar issue... (CIFS file share :/)

    Here is another suggestion from a forum:

    On the server share giving you problems in the security settings>advanced>owner select other user or group and type network service. Make the owner "NETWORK SERVICE" and check off replace owner on subcontainers and objects. I tried both xls and doc files and they both saved to the SMB directory and also to subdirectories of the shared directory after I made this change. I'm running 10.6.2 on the Mac and WinServer2003

    Message was edited by: jg.gt11
  • here2serve Level 1 (0 points)
    We are having the same problem. The tough part is that it happens so randomly. It mostly happens when a file on the DC share is moved/edited. We will be moving the shares to a Mac-mini and sharing over afp. Our design group is wasting too much time with the current set up.
  • MacMan08 Level 1 (0 points)
    Has anyone found a working solution for this yet, I have the same issue as Abner goodwin, and have not found a workaround yet, except if we wait a day or so, we are free to do with file/folder as we want. that is not feasible.

    If anyone has found a working solution, please post.

  • Michael.Kyllonen Level 1 (0 points)
    I have Windows7 -server at home. I was just running to the same problem all the time.. couldn't rename or edit files... I surfed to my Win7 screen and took Indexing off from that external disk I'm accessing.

    just unchecked 'Allow files on this drive to have contents indexed in addition to file properties' ... now it's working again!

    Hope it helps somebody.

    Br, Michael K
  • slowfranklin Level 3 (640 points)
    For everything else then occasional ad-hoc file access from Macs, don't use CIFS, period. Use AFP with an AFP server of choice.
  • Jarek Bingo MacGee Level 1 (5 points)

    The problem has to do with how the Mac OS does file open calls for things like quicklook. I used to run into this issue at a client site, before I was able to convince them to use Thursby's ADmitMac. Since getting them updated to the latest version, the errors went away.

    If you don't need the full Active Directory package, they have another product, DAVE, that is just a replacement for Apple's SMB (and includes DFS support).

    Just my $.02
  • Eric1007 Level 1 (0 points)

    Bingo!  Thanks jg.gt11

    This worked for me. I was getting permission errors when I tried to open files from Macs running Snow Leopard and Lion, that were stored on a Win2008 R2 server.

    Interestingly, you do get some error messags but if you plow ahead it changes ownership to Networ Service and permissions are established for Mac