3 Replies Latest reply: Dec 2, 2005 8:27 AM by ~Bee
scooterama Level 1 Level 1 (0 points)
First off, Im a newby, Im sorry, I've switched to Mac, and now Im fumbling!
Anyway, Im running tiger since it came out,
Safari is sooo slow, worse than 56k, I checked my cable speed online, its good, and my PC laptop works fine on wireless.
Now explorer also runs fairly slow as well, but safari is almost dead, ( i started submitting this on sunday ;0)
Anyway, chat...slowly... for...me...

Thanks in advance

G5 DUAL 2, Mac OS X (10.4.3)
  • ~Bee Level 7 Level 7 (31,095 points)
    scotterama --
    Welcome to Apple Discussions !!

    Here's my list of the first basic things to try.
    I hope it helps you.

    First off, when you update Safari you should be careful that any third party "Internet Enhancing" apps are still compatible. Programs like SpeedDownload, iGetter, PithHelmet, Acid Search, Safari Enhancer all needed updating starting around 10.3.9. Also Norton apps (with the "possible" exception of NAV) became incompatible about 8.6 or 9.0. Definitely not good for OS X. Virex can cause problems as well.
    Please check to see if you have any of these apps, and let us know.

    Also, here's my laundry list of things I do if & when Safari slows down.

    1. Empty your cache & History settings via the Safari menu

    2. Trash your Icons Folder:
    HD>Users>Home>YourName>Library>Safari -->Icons
    Restart Safari and a new folder will be automatically regenerated.
    (This folder saves favicons of all the sites you visit. Needs cleaning periodically -- or you can change that file's preferences to "Read Only"
    rather than "Read & Write." This will keep it from growing in size.)

    3. You might want to check all three "autofill" preferences in Safari. Sometimes those lists gets very long and need pruning. (I turned all autofill boxes off, and have no problems.)

    4. Launch Font Book and check all fonts for duplicates. A duplicated font will have a bullet beside the font family and you can resolve duplicates by selecting the font and at the menu bar, go to Edit > Resolve Duplicates.
    Do this for each font with a bullet next to it.

    If you're still having problems:

    5. Shut down your computer . . . unplug the computer, modem, and router, if you have one. Let everything sit for 2-3 minutes. Plug everything back in, start up your modem & router, then restart your computer.

    Hope this helps. Let us know how you're doing after the above, OK?
  • Christian Streck Level 1 Level 1 (5 points)
    Last night I did the final thing on the list of suggestions, turned off the computer and modem (pulled the plug), let it sit without power for a few minutes and then started back. Safari is back to its old speedy self. Thanks
  • ~Bee Level 7 Level 7 (31,095 points)
    Christian --
    Thanks for posting in here with your good news.