7 Replies Latest reply: Sep 9, 2010 4:16 PM by imdoc
outdors1 Level 1 Level 1 (0 points)
For some reason my phone has stopped sending from my GoDaddy account. It gets stuck in the outbox and I get an error message that says, "The recipient "example@sample.com" was rejected by the server. This account works in Outlook fine with the same set-up below. Also this happens on Wi-fi and 3G.

I'm set up at as:
smtpout.secureserver.net
SSL Off
Server port 80

iPhone 3GS, iOS 4
  • Sammy Jo Level 1 Level 1 (0 points)
    Exact same thing is happening to me. Probably on godaddy's end since you and I are having the same problem? I haven't called them yet, but I was thinking about it. Only problem is, I don't want to call from my iPhone 'cause I want to refer to it while on the call with godaddy, and their silly support line is long distance. </end whining> Anyway, can you post again if you receive any word on this issue? Thanks.
  • modular747 Level 6 Level 6 (17,715 points)
    Many smtp servers reject mail sent via mobil devices. You may do better using the AT&T SMTP server:

    Settings > Mail.... > (your GoDaddy account) > SMTP > Primary Server (smtpout.secureserver.net) > Off. Other SMTP Servers > AT&T SMTP Server > On
  • Sammy Jo Level 1 Level 1 (0 points)
    Thank you, modular. This has fixed my problem. Many, many thanks. Did not feel like sitting on hold with godaddy and paying for that long distance support line! Have a good weekend.
  • modular747 Level 6 Level 6 (17,715 points)
    You're welcome.
  • LarksHead Level 2 Level 2 (200 points)
    I know this is not much help, but I seem to recall when setting up my original iPhone, I had issues. GoDaddy had some helpful iPhone-specific documents on their online support.

    Regards,
    -Peter

    Message was edited by: LarksHead
  • LarksHead Level 2 Level 2 (200 points)
    OK. This is weird.

    When I tried to send something from my iPhone 4 GoDaddy account to my office email address (which I don't have configured into the iPhone), I got a message that I had no password in my email config with directions to go to Settings>Email>etc. and put one in. I did that, but the verification timed out with no response from the server. I gave up. About 10-15 minutes later, I heard a "swoosh" from the phone and the email showed up in my office client.

    Did GoDaddy fix something on the fly? I don't think I did.

    Looking at the headers on the email, it appears to have been sent from secureserver.net, which I believe is Godaddy's SMTP.

    You might want to try it again.

    -Peter
  • imdoc Level 1 Level 1 (0 points)
    I was having the same problem with my iphone 4 (iOs 402) and fixed it following modular747's advice:

    Settings > Mail.... > (your GoDaddy account) > SMTP > Primary Server (smtpout.secureserver.net) > Off. Other SMTP Servers > AT&T SMTP Server > On

    thanks! Hope the OP finds their fix too.