Previous 1 2 Next 20 Replies Latest reply: Oct 12, 2010 2:49 PM by ShaunSforza
Rusty Dave Level 1 Level 1 (0 points)
At random times when I open any different application, the clock jumps forward 5 hours. It was ok with the version 3 software, but once I finally got the OS4 installed, its been wacked out. Any ideas why? Or how to keep it from happening

Macs and PC, Mac OS X (10.5.8)
  • mac4ever Level 2 Level 2 (295 points)
    Do you have your time zone set in Date and Time settings?
  • Merryl Level 1 Level 1 (0 points)
    I am also having this problem. I did not have it before the iOS4 update. However, the time on mine resets 4 hours into the past.

    It happens at random times, but today it ALWAYS happens when I do a total restart, meaning shut it off and turn it back on. I DO have a time zone set. It will almost always happen when using some applications.

    This is very infuriating.

    I have a 2nd generation iPod Touch that's been in service for a couple of years.
  • nunz7777 Level 1 Level 1 (0 points)
    I also have this problem. Mine is set 3 hours ahead.

    Message was edited by: nunz7777
  • Merryl Level 1 Level 1 (0 points)
    I just did a full restore and it SEEMS to have fixed the problem. Worth a try! Kinda mad at Apple for not mentioning this sort of thing, but maybe it will help you guys without costing you $30.
  • jmerritt1963 Level 1 Level 1 (0 points)
    I am having this problem as well. My clock resets 5 hours behind.
  • eisbaerke Level 1 Level 1 (0 points)
    Same problem here, my clock jumps 2 hours ahead, change time or timezone (Brussels GMT+1) has no effect ...

    Message was edited by: eisbaerke
  • Merryl Level 1 Level 1 (0 points)
    Have any of you tried doing a full restore? It's been a couple of days for me and that seems to have fixed the problem. Plus stuff seems to be running a little faster these days.

    Doing a full restore is ugly but I didn't lose any data or apps. It just took a couple of hours.
  • nunz7777 Level 1 Level 1 (0 points)
    How exactly do you do full restore? How come it takes a couple hours? Thanks.
  • GretchenAnne Level 1 Level 1 (0 points)
    The same thing just happened to me. I just got an iPod touch a few weeks ago and within the first few days, the date and time started changing at random-- in fact, mine kept resetting to January 1970. The date and time on my laptop (2005 Apple iMac G4 laptop) are set correctly too. Each time it changes, I reset the date and time back to the current date and time and make sure the time zone is correct, but sometimes within seconds and other times after a few minutes or hours, it changes back to 1970. It seems like after I use an application for more than 30 seconds, it reverts to 1970. I know that sometimes apple products reset to 1969-1970 when the battery dies (the internal clock can no longer keep current time without battery power), but this isn't the case for my iPod touch; the battery was working the entire time.

    It is quite an annoyance because when the date is set to 1970, it causes applications to act batty-- they either crash, are very slow to open, or don't function correctly. It's more than just wanting the time to be correct-- I wouldn't care, if it wasn't for the fact that applications don't work well if the time is incorrect.

    I updated the system on the iPod Touch to the newer 4 version right after I got it. I thought my iTunes was up to date, but this morning I realized that there was a newer version available, so I updated that. I also followed what others who had written in forums had said about syncing my iPod to the computer again after waking the computer up. I thought maybe it would have solved the problem-- but after syncing and unplugging the ipod from the computer, I opened up an application and used it for about 5 minutes. After closing the application, I saw that the time had reverted back to 1970 yet again! (FRUSTRATING!) Anyway, I got rid of that application (an airhockey game). The time stayed current for about 3 hours, but the time changed back to 1970 just a minute ago.

    I really have no idea what is causing the problem or how to fix it exactly. I'll try the total restore as the previous posters suggested. If that doesn't work, I'm going to take it to the Apple store to see if they can fix it.
  • Merryl Level 1 Level 1 (0 points)
    To do a full restore:
    - Start iTunes and plug in your device.
    - Under Devices, click on your device.
    - On the Summary page there are two buttons: 'Check for Update' and 'Restore'.
    - Click Restore.
    - The system will back up your device, then reset it to factory specs, then restore from the backup. This takes QUITE a while, depending on how much stuff you have on there.

    Doing this seems to have solved the problem for me. I haven't had it randomly change the time in the 6 days since I posted my message.

    Message was edited by: MacOldtimer
  • GretchenAnne Level 1 Level 1 (0 points)
    I tried the restore of my iPod last night... and so far, at least for the last 8-10 hours, it has kept the current time! Thats the longest that it has kept the time since I got it! Thanks for the advice
  • Froggy3hope Level 1 Level 1 (0 points)
    Im so glad I'm so glad I'm not the only one with this problem! Hope that the reset works!
  • gocyrus Level 1 Level 1 (0 points)
    I am a new developer. I just upgraded to iOS 4 when it came out. The clock resets turns 5 hours every time I boot up my iPod touch.

    I manually reset my clock. Shut down. Reboot iPod touch and it resets the current time back 5 hours. My time zone is set to Chicago.

    I think I found where the bug lies. When you click on Maps, the time resets back 5 hours. There must be a bug in location services or the Maps program included with the iPod touch.
  • MissAnthropy Level 1 Level 1 (0 points)
    Yes! Mines keeps going forward one day. Keeps the same time curiously enough. And I haven't been able to pinpoint exactly what causes it to do that. It's not when I sync it. It must be when I open certain apps like someone else said. I too, began having this problem when I upgraded to 4.0. I am officially over 4.0! It's causing my apps to freeze up or not load properly, it's messing with the date now and today, it decided to erase all the events I added to my calendar!!! I can't take it! Does anyone know how to "downgrade" back to the 3.0 series of software!!?? I would much rather go back to that!

    Message was edited by: MissAnthropy
Previous 1 2 Next