Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: The wifi network requires a WPA2 password - 2018

I've experienced this problem on both my MacMini and my MBP running Mojave and previously on my MPB running High Sierra.


The Mac would not connect to a WIFI access point, claiming the wifi network requires a WPA2 password.


This was very annoying as :

a) the wifi had worked previously

b) the access point was working with other devices, e.g. my Android tablet and phone

c) the password was correct, as I could view the access point through my MacMini's wired ethernet connection.


There's a lot of advice on this problem and it's been persistent. I tried all of the usual suggestions without any success:


  • Forget the WIFI network, remove it from System Preferences - then reboot
  • Delete Spaces preferences in the Library folder - then reboot
  • Rebooted the WAP/router
  • Change the WIFI password on the router


But then I found the solution.


Open System Preferences / Network / WIFI / Advanced / TCP/IP and then click the Renew DHCP Lease.


The wifi instantly connected.

I hope this helps some with this annoying issue.


David


PS I'm on Mojave 10.14.2 and so this may not work on other MacOS versions but it's worth a try.

Posted on Dec 24, 2018 9:41 AM

Reply
There are no replies.
User profile for user: dkpwatson

Question: The wifi network requires a WPA2 password - 2018

Welcome to Apple Support Community
  • A forum where Apple customers help each other with their products. Learn more.
  • Sign up with your Apple ID to get started.