Previous 1 6 7 8 9 10 Next 194 Replies Latest reply: Feb 4, 2016 11:21 AM by computer dr Go to original post
  • ViccaBoy Level 1 Level 1

    Thanks for ur info i also do it wrongly.. but now it work just fine.. i LOVE U!

  • carbon1 Level 1 Level 1

    Rigelface you are a winner thank you so much for saving my marriage. your solution worked

  • c1roderick Level 1 Level 1

    I did not read all of the posts to see if this solution has been posted but I was having the same issue and tried EVERYTHING on here. NOTHING worked. finally all I had to do was go to the apple icon and click on "software update" I had two updates available. I updated everything and once it was done I had no issues connecting. I put it in sleep mode, closed out of things, and shut my computer down (when I did any of these before I would run into issues conecting) I did all of this with not one problem connecting. Hopefully it's that easy for you too!

  • SocialGen Level 1 Level 1

    Wow. Same problem. Like often happens when a Mac quirk shows up I just wasted hours of my life and finally got it to work. I'll share the steps I took. First it worked two days ago at the same coffee shop, the only thing that had changed was the password, however no matter how many times I entered the password in the different forms. Nothing. All I got was a not connected... due to the "self assigned IP address" message. I attempted the tricks that people posted here: 1) Turned off and back on the wi fi ... nothing 2) restarted the computer... nothing 3)I went into System Preferences > under TCP/IP I changed the Configure IPv4 to "Using DHCP Manually" and used an IP address close to the one from my other mac which was connected just fine... almost nothing... the green light went on and it said connected under wi fi in the left panel of the preferences... but no actual connection 4) I changed the Manual IP address to Match my working Connected Mac... almost nothing... the green light again went on and it said connected under "wi fi" in the left panel of the preferences... but no actual connection 5) I deleted "Wi Fi" from the left panel and recreated it using the + and - buttons on the bottom of the left pane and hit renew DHCP address, but it recreated the same 162... IP as before and still not working 6) I changed the from a 162... to a 192... nothing 2) I hit Renew DHCP Lease... nothing same IP.




    Here's what finally worked: Again in System Preferences>Network> I turned Wi-Fi off, Went to Advanced>TCP/IP>Configure IPv4 and changed it to off, hit "OK", Highlighted Wi-Fi in the left column, hit the - sign on the bottom left, deleting it, then hit the + and created it. I got a message saying there is no assigned IP address so I went back into >advanced>TCP/IP and turned on Using DHCP, Hit "Renew DHCP Lease" and it finally created a brand new IP address 10..... and if finally F'n worked.


    Jeez Apple get it together. This is a ridiculous problem.


    I hope my struggles actually help someone

  • BDAqua Level 10 Level 10

    What version of OSX was that?

  • rbruce1932 Level 1 Level 1

    Beautiful! Worked perefctly after your fix. Thanks very much.

  • zacharee Level 1 Level 1

    Here's a solution:

    try disconnecting from the network and then go to "join other network" in the wi-fi menu. type in the name of your wi-fi network and type the password (you also need to tell what type of network security your wi-fi has). Hit the connect button and it should work.

  • JenniferH Level 1 Level 1

    Awesome. Such a simple fix. Why didn't I think of it. You sir, are the genius here.

  • catfishmass1 Level 1 Level 1

    Another MBP with sleep = can't connect to wifi. Usually when I have this problem I can get back to my network after attempting to connect to others in my list. Today, it didn't. Neither did trashing preferences, networks, nothing. It finally just came back after numerous restarts and letting the computer "rest" ... so in other words magic. This has been a known issue with MBP for many OS updates, why has this problem not been fixed!?

  • Maff48 Level 1 Level 1

    Watch this YouTube and it will be fixed. Just type it on the search bar, first video and it will be fixed


    "NJ Mac Magic helps Elaine with her MacBook Pro Wireless problem"

  • nismoskyz Level 1 Level 1

    Thank you so much for sharing your workaround SocialGen...


    Followed your posted steps and it finally works, thanks!!!

  • Wilsuma Level 1 Level 1

    This worked great for about 30 seconds. Over and over again. Now I find that I must renew the DHCP lease ( System pref/Network/Advanced/TCP/IP/ )  every 10 - 30 seconds. Very strange.






    17" MBP 10.6.8

  • Wilsuma Level 1 Level 1

    This Helped but only for 10 - 30 seconds. I have to keep renewing the DHCP Lease to remain connected.





    17" MBP 10.6.8

  • amcd134 Level 1 Level 1

    Great fix! Thank you for solving this problem ... ugh!

  • Kamthorn Level 1 Level 1

    Go to network preference>advanced>tcp/ip> use DHCP With manual ip , assign any random ip like


    by miladmasoodi - 1/26/12 12:20 PM


    Works with my iMac

Previous 1 6 7 8 9 10 Next