3 Replies Latest reply: Jul 12, 2010 10:59 AM by Katrina S.
Tanya Depass Level 1 Level 1
Hello all,

I'm getting the following error now when I plug in my iPhone 4 or try to open iTunes:

"The folder 'iTunes' is on a locked disk or you do not have write permissions for this folder". I checked the permissions and they appear to be right, so I'm not sure what to do.

I did not change anything, and all I've done is set up Windows Media Center today. Once I was done trying it out, I started getting these messages from iTunes. I tried uninstalling, reinstalling and making sure I was the folder owner via the other help topics, but I'm still getting this error.

I also can't uncheck the "Read Only" option. I uncheck it, the security applies but its right back on the iTunes folder.

Can you uninstall Windows Media Center? Or make sure it hasn't made itself the default media player? That's all I've done differently with my computer and I can't get this stupid error to stop, open my iTunes or synch my phone.

Help!

Custom Built PC, Windows 7, Also have a macbook
Reply by Katrina S. on Jul 11, 2010 10:39 AM Helpful
+all I've done is set up Windows Media Center today+




Well, that's good to know. Sounds like WMC takes control of the music folder in a rather nasty way!




Give your Windows UserID full control and ownership of the top-level Music folder, and make sure to check the box to apply the changes to all subfolders. The symptom of not being able to uncheck Read-Only and make it stick tells me your windows userID doesn't have control.



Here's what I'm talking about:
http://helpdeskgeek.com/windows-7/windows-7-how-to-delete-files-protected-by-tru stedinstaller/
The article's title is how to delete files, but it has the screenshots you need to fix permissions so you can edit files.





P.S. Forgot to mention, you need to restart itunes so it will read the new permissions settings.

Message was edited by: Katrina S.

All replies

  • Katrina S. Level 7 Level 7
    +all I've done is set up Windows Media Center today+




    Well, that's good to know. Sounds like WMC takes control of the music folder in a rather nasty way!




    Give your Windows UserID full control and ownership of the top-level Music folder, and make sure to check the box to apply the changes to all subfolders. The symptom of not being able to uncheck Read-Only and make it stick tells me your windows userID doesn't have control.



    Here's what I'm talking about:
    http://helpdeskgeek.com/windows-7/windows-7-how-to-delete-files-protected-by-tru stedinstaller/
    The article's title is how to delete files, but it has the screenshots you need to fix permissions so you can edit files.





    P.S. Forgot to mention, you need to restart itunes so it will read the new permissions settings.

    Message was edited by: Katrina S.
  • Tanya Depass Level 1 Level 1
    Thanks Katrina!

    I followed the steps from the Apple rep I wound up speaking with. I had to do a clean uninstall/reinstall of iTunes and related components before I got it to work. I also had to make sure my Admin account was the "owner" of the iTunes file folder.

    It was a pain but I finally have iTunes up and running, and luckily I didn't have to re-do all of my play lists or re-import anything.
  • Katrina S. Level 7 Level 7
    Excellent news! Thanks for the points.