1 2 3 4 5 6 7 Previous Next 92 Replies Latest reply: Apr 5, 2014 8:01 AM by Anthony Moore4 Go to original post
  • 45. Re: iPhoto library won't sync to iPhone 4
    iMikeyMike Level 1 Level 1 (0 points)
    This worked for me: Deleted 'iPod Photo Cache' that was in the 'iPhoto Library' package (right clicked on the file, selected 'Show Package Contents').
  • 46. Re: iPhoto library won't sync to iPhone 4
    jackcu Level 1 Level 1 (0 points)
    I've got it working now, but not by doing any of the things in the various threads - all of which I'd already tried without success. See if this works for you:

    I connected my iPhone4 which had iPhoto syncing turned off (because it never finished any sync or backup with it on). I thought I'd try one more time and was surprised when I turned iPhoto syncing back on , that it actually worked. I then tried it with my iPod Touch, and it worked. I then tried it with my Apple TV, and it worked. At this point I had not changed anything - one minute (well - several weeks) it didn't work, then it did.

    The only thing I did differently was to turn iPhoto syncing back on on my iPhone4.

    Weird.

    Glad it's working again but no idea what fixed it.

    Good luck!
  • 47. Re: iPhoto library won't sync to iPhone 4
    Jaae Level 1 Level 1 (0 points)
    Had the exact same problem after updating my iphone 4 to iOS 4.1. Interestingly, it'd sync certain albums, but not others.

    Previous to the update, I had no problems syncing my aperture photo albums.

    Tried reinstalling itunes 10.0 (had just installed 10.0.1 too). Didn't help.

    Eventually it dawned on me that I had just added 4 photos to a smart album around the same time that the sync didn't work.
    Since it was just 4 pictures, I removed them from the smart album, and it sync'd fine!
    Then re-added them one at a time back to the album... syncing in between each add. Eventually found the offending photos. Just "made duplicates" of the offending photos via Aperture's "Make Duplicate from this Version" (or something like that). Added the newly-made duplicates to the smart album... boom.

    I guess if you don't want to go through the hassle of sifting through a large album, you could just select them all and duplicate them all into another album, then sync the new album.

    Hope this helps!
  • 48. Re: iPhoto library won't sync to iPhone 4
    detlevq Level 1 Level 1 (0 points)
    Tried this one myself after searching for solutions for weeks now and it worked for me no problem. Right clicked on the IPhoto Library icon in the pictures folder on my Mac, showed package contents and there in was a folder called IPod Photo Cache. Moved it to the Trash. Synced my phone and found that iTunes did not attempt to sync photos. Looked at sync options in iTunes for Photos and found that it was now unchecked. Checked the box and clicked apply in bottom right corner which started a full sync and unbelievably it synced my photos too. Disconnected my phone and reconnected it again to initiate a new sync on connection and all seems to be working fine!! Good luck out there!!
  • 49. Re: iPhoto library won't sync to iPhone 4
    rajapayu Level 1 Level 1 (0 points)
    Thank you for the tip about right clicking on the 'iPhoto Library' package!!! I tried deleting 'iPod Photo Cache' using 'Spotlight Search',removed all files from my HD,powering off my iPhone while connected to computer,unchecking and re-checking the sync tab in iTunes after deleting all the 'iPod Photo Caches' and still nothing worked.Spotlight Search obviously doesn't show this remaining 'iPod Photo Cache' file which was hidden in iPhoto Library!!! From what i've read in over 50 support threads shows me that even Apple doesn't know how to fix this!!THANK YOU ONCE AGAIN!!!
  • 50. Re: iPhoto library won't sync to iPhone 4
    hartj Level 1 Level 1 (0 points)
    I can't believe after all the iPod Photo cache clearing, syncing photos.. unsyncing photos... syncing photos again.... that I've done this was the solution that worked. I took off all the audio like BakerBruce said and like magic, it began to sync my photos (and faces) again.

    Thanks, Bruce.
  • 51. Re: iPhoto library won't sync to iPhone 4
    haptic84 Level 1 Level 1 (0 points)
    This problem sure was annoying (I THINK im past it).

    For me the solution was deleting the "iPod Photo Cache" folder inside the contents of iPhoto Library
  • 52. Re: iPhoto library won't sync to iPhone 4
    tourist51 Level 1 Level 1 (0 points)
    On my IPHone 4 I had to go to my ITunes and at the top on my Itunes where the songs all are is a line and in the line are the following: Summary Info Apps Music Movies TV Shows Podcasts I tunes U Photos.

    I then had to click on PHOTOS and in there is soemhting which says SYNC PHOTOS from..pull down to I photo and click small box next to "SUNC PHOTOS FROM...... ..Then you can click om all pr selected albums or all videos.

    Hope this helps you
  • 53. Re: iPhoto library won't sync to iPhone 4
    Robert B Worman Level 1 Level 1 (25 points)
    Just to add another point of data, I just noticed this same problem on my iphone4 running the latest firmware.

    In my case it really looks like iTunes is getting confused by an iphone that's close to full. Here's my sequence of observations/steps/results:

    0. "hey, why aren't my photos syncing to my iphone?"

    1. with syncing photos disabled, itunes reports that my iphone4 has 0.21 GB of free space. (iphone4 agrees...)

    2. turned on syncing photos, and chose a tiny album with only 4 photos in it. (full sized, this is ~10MB of data)

    3. still no sync of the photos - no errors of any sort, just no syncing.

    4. deleted the ipod photo cache - still no sync

    5. On a crazy whim, I went ahead and freed up another 926MB of space on the iphone. (by removing one movie from the sync list)

    6. poof, my tiny little album synced!

    7. a subsequent larger sync of the photos I care about (~100 MB) works for the first time too.
    =======

    I don't really have the time to diagnose this further today, but I thought this account might be helpful to others. The key in my case seems to be "don't let the iphone get too close to full, even though the photos should fit"
  • 54. Re: iPhoto library won't sync to iPhone 4
    timrob1976 Level 1 Level 1 (0 points)
    Iphone 4 running 4.2.1 syncing with Macbook running OSx 10.5.8 and have tried all of the above and I cannot get my videos to sync back to my iphone. If I take a new video it shows in the camera roll on the phone no problem. If I sync my phone to my book the video shows in iphoto no problem, but once it's been deleted from my phone it won't go back. I have tried freeing up memory, deleting the cache and restarting evertything in various order but no luck.
    I do have the 'include videos' box ticked in the photos tab on itunes
    I do have enough memory space on the phone (by a long shot)
    I am not stupid !!!
    PLEASE CAN ANYONE HELP !!!!
    Thanks
  • 55. Re: iPhoto library won't sync to iPhone 4
    manahijinx Level 1 Level 1 (0 points)
    I have plenty of free space on my iPhone, over 10 GB, but when I sync my photo's through iTunes from my computer to my iPhone I get an error message at the photo phase stating "The iPhone "phone's name" cannot be synced. The required file cannot be found."

    Yes, I have tried the deleting of the iPod photo cache folder. This problem has been occurring for a while now. Well before I deleted the iPod photo cache.

    Anyone have a REAL solution to this problem. I even completely reset and reinstalled the iPhone OS.
  • 56. Re: iPhoto library won't sync to iPhone 4
    Paul Wren Level 1 Level 1 (25 points)
    The problem only started with the latest mac OSX update - I only get the most recent events - so it's reading some and ignoring others
  • 57. Re: iPhoto library won't sync to iPhone 4
    Slapguts Level 1 Level 1 (0 points)
    Deleting the "iPod Photo Cache" in the Package Contents of "iPhoto Library" worked for me.
  • 58. Re: iPhoto library won't sync to iPhone 4
    maximw Level 1 Level 1 (0 points)
    I have iphone 3GS and started to have the same problem with syncing photos, notwithstanding the fact that my iphone still has 12GB memory available. My previous syncing worked fine until last one a few days ago when only a camera roll album was synced, and nothing worked. Finally I found this discussion and followed BakerBruceW's solution and it worked fine. I un-checked "Sync Music," which removed all music from my iphone and synced photos first, all of which were copied back to iphone. Then I checked back "Sync Music" and it synced music back to my iphone. So now I have again all my photos and music back on iphone and I still have 12 GB free on my iphone. Hope this helps to others.
  • 59. Re: iPhoto library won't sync to iPhone 4
    michelleandpaul Level 1 Level 1 (0 points)

    I had this, too, and, Wow, is it a pain in the bottom.  I got mine to work by plugging in my iPhone and after I let the auto sync finish, I right clicked on the device in the list in the left column and then choose "Reset Warnings".  Then sync'd it again.  It worked great.  Whew.  Pain in the bottom gone.  Hope this works for all of you.